Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Easy VPN on 1710 cisco router connected to a DSL using dyndns

I have a 1710 cisco router connected to a DSL modem at home. Dynamic DNS or dyndns is implemented on it and everything works fine. In order words, I do not have a static IP address.

I would like to be able to configure vpn or Easy VPN on it so that I can connect with my laptop from outside using the cisco vpn client software.

Can someone please post a step by step sample vpn configuration? Something that does not conflict with my configuration. Below is my config. Thanks in advance.

Paul Pagina

PageHut#show run

Building configuration...

Current configuration : 2543 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname PageHut

!

boot-start-marker

boot-end-marker

!

no logging console

enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxx.

enable password 7 xxxxxxxxxxxxxxxxxxxxxx

!

aaa new-model

aaa local authentication attempts max-fail 3

!

!

aaa authentication login default local

!

aaa session-id common

memory-size iomem 15

!

ip cef

ip inspect name CBAC-NAME tcp router-traffic

ip inspect name IPFW tcp timeout 3600

ip inspect name IPFW udp timeout 15

ip inspect name IPFW ftp

ip inspect name IPFW h323

ip inspect name IPFW rcmd

ip inspect name IPFW smtp

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

ip ddns update method DYNDNS

[a1]

HTTP

add http://xxxxxxxxx:yyyyyyy@members.dyndns.org/nic/update?hostname=yyyyyyy@members.dyndns.org/nic/update?hostname=<h>&myip=<a>

remove http://xxxxxxxxx:yyyyyy@members.dyndns.org/nic/update?hostname=yyyyyy@members.dyndns.org/nic/update?hostname=<h>&myip=<a>

interval maximum 28 0 0 0

interval minimum 28 0 0 0

!

!

vpdn enable

!

!

username cisco privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx!

!

interface Ethernet0

ip address 172.16.1.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

no ip mroute-cache

half-duplex

!

interface FastEthernet0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

speed 100

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface Dialer0

no ip address

ip inspect IPFW out

!

interface Dialer1

mtu 1492

ip ddns update hostname xxxxx.dyndns.org

ip ddns update DYNDNS host members.dyndns.org

ip address negotiated

ip access-group 101 in

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp chap hostname xxxxxxxxxxxxxxxxxxxxxx

ppp chap password 7 xxxxxxxxxxxxxxxxxxxxxxxxx

ppp pap sent-username xxxxxxx password 7 xxxxxxxxxxxxxxxxxx

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

no ip http secure-server

!

ip nat inside source list 1 interface Dialer1 overload

!

!

access-list 1 permit 172.16.1.0 0.0.0.255

access-list 10 permit 192.168.1.0 0.0.0.255

!

control-plane

!

banner motd ^C

**********************************************************

**This is a my banner***

*************************************************************************** ^C

!

line con 0

password 7 xxxxxxxxxxx

line aux 0

password 7 xxxxxxxxxxxxxxx

line vty 0 4

password 7 xxxxxxxxxxxxx

!

end

PageHut#


580
Views
0
Helpful
0
Replies