Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

EasyVPN problem - Can't access to the internet

Hi Everyone,


I'm trying to setup a very basic EasyVPN from my ASA 5505 (home/client) and ASA 5520 (work/server/ IP 74.25.12.245). Everytime when I enable 'Easy VPN Remote' on my ASA5505, my home PC get disconnected from the internet.


My ASA5505 client gets dhcp IP address (private IP 10.1.1.79) from my cable modem. I believe my cable modem has this public ip 50.54.12.224.


I looked at the logs on my ASA 5520, it seems that all the requests from my ASA 5505 client are going thru and connected. And similar with ASA 5505's log. Any ideas? or Am I setting the EasyVPN wrong? Thanks.


            

ASA5520's log:

Group = EasyVPN01, Username = home, IP = 50.54.12.224, PHASE 2 COMPLETED (msgid=f50b1d70)

IPSEC: An inbound remote access SA (SPI= 0x7440E3A5) between 74.25.12.245 and 50.54.12.224 (user= home) has been created.

IPSEC: An outbound remote access SA (SPI= 0xA0319409) between 74.25.12.245 and 50.54.12.224 (user= home) has been created.

Group = EasyVPN01, Username = home, IP = 50.54.12.224, Security negotiation complete for User (home)  Responder, Inbound SPI = 0x7440e3a5, Outbound SPI = 0xa0319409

Group = EasyVPN01, Username = home, IP = 50.54.12.224, Overriding Initiator's IPSec rekeying duration from 2147483647 to 4608000 Kbs

Group = EasyVPN01, Username = home, IP = 50.54.12.224, Overriding Initiator's IPSec rekeying duration from 2147483647 to 28800 seconds

Group = EasyVPN01, Username = home, IP = 50.54.12.224, PHASE 2 COMPLETED (msgid=79de20eb)

IPSEC: An inbound remote access SA (SPI= 0x0F5F537D) between 74.25.12.245 and 50.54.12.224 (user= home) has been created.

IPSEC: An outbound remote access SA (SPI= 0xC706D891) between 74.25.12.245 and 50.54.12.224 (user= home) has been created.

Group = EasyVPN01, Username = home, IP = 50.54.12.224, Security negotiation complete for User (home)  Responder, Inbound SPI = 0x0f5f537d, Outbound SPI = 0xc706d891

Group = EasyVPN01, Username = home, IP = 50.54.12.224, Overriding Initiator's IPSec rekeying duration from 2147483647 to 4608000 Kbs

Group = EasyVPN01, Username = home, IP = 50.54.12.224, Overriding Initiator's IPSec rekeying duration from 2147483647 to 28800 seconds

Group = EasyVPN01, Username = home, IP = 50.54.12.224, PHASE 2 COMPLETED (msgid=7812ba43)

IPSEC: An inbound remote access SA (SPI= 0xF5A411EC) between 74.25.12.245 and 50.54.12.224 (user= home) has been created.

IPSEC: An outbound remote access SA (SPI= 0xD028BFAD) between 74.25.12.245 and 50.54.12.224 (user= home) has been created.

Group = EasyVPN01, Username = home, IP = 50.54.12.224, Security negotiation complete for User (home)  Responder, Inbound SPI = 0xf5a411ec, Outbound SPI = 0xd028bfad

Group = EasyVPN01, Username = home, IP = 50.54.12.224, Overriding Initiator's IPSec rekeying duration from 2147483647 to 4608000 Kbs

Group = EasyVPN01, Username = home, IP = 50.54.12.224, Overriding Initiator's IPSec rekeying duration from 2147483647 to 28800 seconds

Group = EasyVPN01, Username = home, IP = 50.54.12.224, PHASE 1 COMPLETED

Group = EasyVPN01, Username = home, IP = 50.54.12.224, Assigned private IP address 192.168.80.10 to remote user

Group = EasyVPN01, Username = home, IP = 50.54.12.224, Client Type: ASA5505  Client Application Version: 8.2(5)

DAP: User home, Addr 50.54.12.224, Connection IPSec: The following DAP records were selected for this connection: DfltAccessPolicy

ASA5505's log

Group = 74.25.12.245, IP = 74.25.12.245, PHASE 2 COMPLETED (msgid=9e63583b)

IPSEC: An inbound remote access SA (SPI= 0x8712C66D) between 10.1.1.79 and 74.25.12.245 (user= 74.25.12.245) has been created.

Group = 74.25.12.245, IP = 74.25.12.245, Security negotiation complete for peer (74.25.12.245)  Initiator, Inbound SPI = 0x8712c66d, Outbound SPI = 0xa2046fa7

IPSEC: An outbound remote access SA (SPI= 0xA2046FA7) between 10.1.1.79 and 74.25.12.245 (user= 74.25.12.245) has been created.

Group = 74.25.12.245, IP = 74.25.12.245, Responder forcing change of IPSec rekeying duration from 2147483647 to 28800 seconds

Group = 74.25.12.245, IP = 74.25.12.245, Responder forcing change of IPSec rekeying duration from 2147483647 to 4608000 Kbs

Group = 74.25.12.245, IP = 74.25.12.245, IKE Initiator: New Phase 2, Intf inside, IKE Peer 74.25.12.245  local Proxy Address 192.168.80.10, remote Proxy Address 192.168.20.0,  Crypto map (_vpnc_cm)

Group = 74.25.12.245, IP = 74.25.12.245, PHASE 2 COMPLETED (msgid=c5251229)

IPSEC: An inbound remote access SA (SPI= 0x1B8734EA) between 10.1.1.79 and 74.25.12.245 (user= 74.25.12.245) has been created.

Group = 74.25.12.245, IP = 74.25.12.245, Security negotiation complete for peer (74.25.12.245)  Initiator, Inbound SPI = 0x1b8734ea, Outbound SPI = 0x53732dad

IPSEC: An outbound remote access SA (SPI= 0x53732DAD) between 10.1.1.79 and 74.25.12.245 (user= 74.25.12.245) has been created.

Group = 74.25.12.245, IP = 74.25.12.245, Responder forcing change of IPSec rekeying duration from 2147483647 to 28800 seconds

Group = 74.25.12.245, IP = 74.25.12.245, Responder forcing change of IPSec rekeying duration from 2147483647 to 4608000 Kbs

Group = 74.25.12.245, IP = 74.25.12.245, IKE Initiator: New Phase 2, Intf NP Identity Ifc, IKE Peer 74.25.12.245  local Proxy Address 10.1.1.79, remote Proxy Address 192.168.20.0,  Crypto map (_vpnc_cm)

Group = 74.25.12.245, IP = 74.25.12.245, PHASE 2 COMPLETED (msgid=44f556fc)

IPSEC: An inbound remote access SA (SPI= 0xD8603BDF) between 10.1.1.79 and 74.25.12.245 (user= 74.25.12.245) has been created.

Group = 74.25.12.245, IP = 74.25.12.245, Security negotiation complete for peer (74.25.12.245)  Initiator, Inbound SPI = 0xd8603bdf, Outbound SPI = 0xae68426f

IPSEC: An outbound remote access SA (SPI= 0xAE68426F) between 10.1.1.79 and 74.25.12.245 (user= 74.25.12.245) has been created.

Group = 74.25.12.245, IP = 74.25.12.245, Responder forcing change of IPSec rekeying duration from 2147483647 to 28800 seconds

Group = 74.25.12.245, IP = 74.25.12.245, Responder forcing change of IPSec rekeying duration from 2147483647 to 4608000 Kbs

Group = 74.25.12.245, IP = 74.25.12.245, Responder forcing change of IKE rekeying duration from 2147483647 to 86400 seconds

Group = 74.25.12.245, IP = 74.25.12.245, PHASE 1 COMPLETED

Group = 74.25.12.245, IP = 74.25.12.245, Client rejected NAT enabled IPSec request,    falling back to standard IPSec

VPNClient: Head end : 74.25.12.245

Group = 74.25.12.245, IP = 74.25.12.245, Client Type: ASA5550  Client Application Version: 8.2(2)

IP = 74.25.12.245, IKE Initiator: New Phase 1, Intf NP Identity Ifc, IKE Peer 74.25.12.245  local Proxy Address 10.1.1.79, remote Proxy Address 74.25.12.245,  Crypto map (_vpnc_cm)

User 'enable_15' executed the 'vpnclient server 74.25.12.245' command.

My ASA5505's config file

: Saved

: Written by enable_15 at 08:00:20.809 UTC Thu Jun 7 2012

!

ASA Version 8.2(5)

!

hostname ciscoasa

domain-name default.domain.invalid

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.1.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address dhcp setroute

!

ftp mode passive

dns server-group DefaultDNS

domain-name default.domain.invalid

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu outside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130

    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117

    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b

    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504

    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72

    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56

    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043

    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31

    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b

    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20

    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65

    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420

    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329

    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365

    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7

    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597

    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10

    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc

    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845

    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8

    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced

    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f

    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201

    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868

    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101

    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8

    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777

    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a

    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406

    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973

    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403

    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969

    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b

    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973

    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30

    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603

    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355

    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80

    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e

    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a

    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16

    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0

    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8

    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28

    6c2527b9 deb78458 c61f381e a4c4cb66

  quit

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

dhcpd address 192.168.1.5-192.168.1.36 inside

dhcpd enable inside

!

vpnclient server 74.25.12.245

vpnclient mode client-mode

vpnclient vpngroup EasyVPN01 password 123456789

vpnclient username home password 123456

vpnclient enable

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

username myasa password PQmZVGTXdlAUhg.J encrypted privilege 15

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

call-home reporting anonymous

Cryptochecksum:05ad2e82b9ca27db2d473c0bf9379c1d

: end

3 REPLIES
New Member

EasyVPN problem - Can't access to the internet

Hi Tin,

Going via your config i see you missing some important acl's and nat statement to stop your pc's or home network ip going via your vpn for internet. Cos that's what i'll say is happening. Below are things i see missing

Your nat exemption

nat (inside) 0 access-list inside_nat0_outside

Acl

access-list Split_Tunnel_List_ACL remark *****NAT Access List*****

access-list inside_nat0_outside line 1 extended permit ip any 1.1.1. 255.255.255.0 (your IP pool for remote vpn)

access-list Split_Tunnel_List_ACL remark *****Split Tunnel  Access Encrypted Traffic*****

access-list Split_Tunnel_List_ACL standard permit 192.168.1.0 255.255.255.0 ( Your Remote LAN IP address)

I want to believe if you add these, it should sort it out for you

Cheers

Teddy

New Member

Re: EasyVPN problem - Can't access to the internet

Hi Teddy,

These are what I jus enter in my ASA5505 (client)

access-list  inside_nat0_outside extended permit ip any 10.10.20.0 255.255.255.0

nat (inside) 0 access-list inside_nat0_outside

The subnet 10.10.20.0/24 is the pool for vpn client which is given by ASA5520 (server).

For these access lists below, do I need to have them on the ASA5520 (server)? I'm not sure what they are, can you explain to me a little more detail?

access-list Split_Tunnel_List_ACL remark *****NAT Access List*****

access-list inside_nat0_outside line 1 extended permit ip any 1.1.1. 255.255.255.0 (your IP pool for remote vpn)

access-list Split_Tunnel_List_ACL remark *****Split Tunnel  Access Encrypted Traffic*****

access-list Split_Tunnel_List_ACL standard permit 192.168.1.0 255.255.255.0 ( Your Remote LAN IP address)      

New Member

Re: EasyVPN problem - Can't access to the internet

Tinh,

Oh sure you do need them, that's your split tunnel acl to your ASA which is eligible IP that's not going to be natted. Ok let me break it down for you this way.

Going into a club and you have a bouncers at the entrance, stairways entrance and just about any entrance into a major part of the club, now you have instructed the bouncers that just incase you see anyone that has the number 10.10.20.0/24 please allow them into the club for they are the visitors we have permitted in and have access only to the 1st floor of the club.

For those you see with the 192.168.1.0/24 they own the club and could move in and out of the floors at the club, you need not sweat yourself about them.

What you just did is tell your ASA which is the bouncer that, these are the permitted pple or network i should say that have access to your network.

Then the  nat (inside) 0 access-list inside_nat0_outside statement is like saying, sure enough they have access to the network but i don't want them to have access the vault which everyone at 192.168.1.0/24 network has. They have their own vault, let them take money from there and buy themselve drinks.

I hope this is pretty explanatory enough for you.

Cheers

Teddy

1016
Views
0
Helpful
3
Replies