Cisco Support Community
Community Member

fwsm rdp dhcp ip helper

Dear Friends

My problem is that Despite entering IP helper address RDP(DHCP and PXE) server does not work when the traffic need to forward in different IP subnets.

Here is My Case:

We have 6500 with sup 720-3b and a FWSM. FWSM working in transparent mode and it is used between MSFC and access switches. For each IP subnet I have created a pair of VLANs(one inside and one outside) that are bridged in a bridge group by FWSM. (Refer to picture in the file attached)

All of access ports are belong to the Inside VLANs.

VLAN:60 , VLAN:61 IP subnet:

VLAN:30, VLAN:31 IP subnet:

I have a RDP server plugged into VLAN 61 and it?s IP is:

And another server is plugged to VLAN 31. We need to deploy OS on this server by the way of RDP(HP rapid deployment pack) server. But I can?t. FWSM did not forward DHCP and PXE broadcast traffic. RDP server works with DHCP, PXE and MTFTP services.

VLAN 61 and 31 are not SVI(L3).

It only works when we replace the configuration of interface VLAN 60 with int vlan 61 and also int vlan 30 and int vlan 31. This means bypassing the FWSM.

I can provide further information if you need any.

I wonder If you could help me.

Thank you

Here is the configuration:


interface Vlan30

description Oracle DB outside

ip address

ip helper-address

interface Vlan60

description mng out

ip address


firewall transparent

interface Vlan30

nameif db-outside

bridge-group 4

security-level 0


interface Vlan31

nameif db-inside

bridge-group 4

security-level 100

interface Vlan60

nameif mng-outside

bridge-group 6

security-level 0


interface Vlan61

nameif mng-inside

bridge-group 6

security-level 100

access-list BPDU ethertype permit bpdu

access-list All-Traffic extended permit ip any any

access-group BPDU in interface db-outside

access-group BPDU out interface db-outside

access-group All-Traffic in interface db-outside

access-group All-Traffic out interface db-outside

access-group BPDU in interface db-inside

access-group BPDU out interface db-inside

access-group All-Traffic in interface db-inside

access-group All-Traffic out interface db-inside

access-group BPDU in interface mng-outside

access-group BPDU out interface mng-outside

access-group All-Traffic in interface mng-outside

access-group All-Traffic out interface mng-outside

access-group BPDU in interface mng-inside

access-group BPDU out interface mng-inside

access-group All-Traffic in interface mng-inside

access-group All-Traffic out interface mng-inside


Re: fwsm rdp dhcp ip helper

Correct me if I understand it differently, but do you expect server in Vlan31 to be able to grab DHCP from the DHCP server (, and/or different IP subnets?

Try to put "ip helper-address" under all L3 SVI Vlan interfaces, instead of one Vlan (vlan 30) only.



Community Member

Re: fwsm rdp dhcp ip helper

Thank you,

we expect server in VLAN 31 to get IP form rdp/DHCP server in VLAN 61.

Actually I have already put IP helper in all SVI's but it didn't worked.

It seems that FWSM didn't forward the DHCP traffic between SVIs.



CreatePlease to create content