Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

GRE Tunnel always up EIGRP not recovering after failure

I have setup an IPSEC GRE Tunnel between two routers over a wireless connection and running EIRGP routing protocol over this link.  The problem I am having is that the GRE tunnel stays up all the time regardless of whether the wireless connection is available.  If the wireless connection goes down the GRE tunnel stays up even if I don't have connectivity over the encrypted link.

When the link goes down, my EIGRP neighbors drop as expected, however when the wireless link comes back up, my eigrp neighbors and routes do not re-establish automatically.  They only re-establish if I manually shutdown the GRE tunnel and then bring it back up.

What can I do to address these two issues that I think are related.  I would like the GRE tunnels to track the actual connectivity and the EIGRP routes to re-establish automatically.

7 REPLIES

Re: GRE Tunnel always up EIGRP not recovering after failure

Hi,

If the GRE tunnel is over the wireless connection, then it cannot be up if the wireless connection goes down.

On the other hand, EIGRP should recovery automatically when the link is up again (through the GRE tunnel).

Could you post your configurations?

Federico.

New Member

Re: GRE Tunnel always up EIGRP not recovering after failure

The problem is my wireless connection is not direct, I have several other routers and hops beyond the initial link.  The issue is when the wireless links stay up, but one of the intermidiate hops goes down.  So as far as the routers creating the GRE tunnel are concerned the links are still up, they just don't have connectivity.  I also have a backup T1 connected between these locations so that may not be helping the tunnel issue since my traffic (perhaps keepalives too) are routing through the T1 rather than the wireless connection that stops passing traffic.

Re: GRE Tunnel always up EIGRP not recovering after failure

You're saying that the GRE tunnel stays up even though both routers establishing the GRE tunnel cannot reach each other?

Or they can reach each other via another path (T1).

When this happens, can you PING between tunnel IPs?

Federico.

New Member

Re: GRE Tunnel always up EIGRP not recovering after failure

That is correct.  Right now an intermediate path is down over the path this tunnel goes over the wireless network.  I cannot ping the other end of the tunnel from either side, nor can I ping the destination physical addresses that the tunnel uses from either router.  Yet the tunnel shows up/up on both sides.

Any thoughts?

The tunnel interface at the remote router shows is configured and shows status as follows:

interface Tunnel0
bandwidth 54000
ip address 10.86.1.2 255.255.255.0
ip mtu 1400
ip nhrp authentication DMVPN_NW
ip nhrp map 10.86.1.1 172.16.1.56
ip nhrp network-id 100000
ip nhrp holdtime 360
ip nhrp nhs 10.86.1.1
ip tcp adjust-mss 1360
load-interval 30
delay 1000
tunnel source FastEthernet0/1
tunnel destination 172.16.1.56
tunnel key 100000
tunnel protection ipsec profile CiscoCP_Profile2
tunnel bandwidth transmit 54000
tunnel bandwidth receive 54000

Tunnel0 is up, line protocol is up
  Hardware is Tunnel
  Internet address is 10.86.1.2/24
  MTU 1514 bytes, BW 54000 Kbit/sec, DLY 10000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 10.99.99.11 (FastEthernet0/1), destination 172.16.1.56
  Tunnel protocol/transport GRE/IP
    Key 0x186A0, sequencing disabled
    Checksumming of packets disabled
  Tunnel TTL 255
  Fast tunneling enabled
  Tunnel transmit bandwidth 54000 (kbps)
  Tunnel receive bandwidth 54000 (kbps)
  Tunnel protection via IPSec (profile "CiscoCP_Profile2")
  Last input 1d00h, output never, output hang never
  Last clearing of "show interface" counters 3w1d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 21143
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  30 second input rate 0 bits/sec, 0 packets/sec
  30 second output rate 0 bits/sec, 0 packets/sec
     22870836 packets input, 828608086 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     21812835 packets output, 2377290735 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

And my host side is configured and shows as follows:

interface Tunnel0
bandwidth 54000
ip address 10.86.1.1 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication DMVPN_NW
ip nhrp map 10.86.1.2 10.99.99.11
ip nhrp network-id 100000
ip nhrp holdtime 360
ip tcp adjust-mss 1360
no ip split-horizon eigrp 100
delay 1000
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 100000
tunnel protection ipsec profile CiscoCP_Profile2
tunnel bandwidth transmit 54000
tunnel bandwidth receive 54000

Tunnel0 is up, line protocol is up
  Hardware is Tunnel
  Internet address is 10.86.1.1/24
  MTU 1514 bytes, BW 54000 Kbit/sec, DLY 10000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 172.16.1.56 (GigabitEthernet0/0), destination UNKNOWN
  Tunnel protocol/transport multi-GRE/IP
    Key 0x186A0, sequencing disabled
    Checksumming of packets disabled

  Fast tunneling enabled
  Tunnel transmit bandwidth 54000 (kbps)
  Tunnel receive bandwidth 54000 (kbps)
  Tunnel protection via IPSec (profile "CiscoCP_Profile2")
  Last input 23:47:40, output 00:00:03, output hang never
  Last clearing of "show interface" counters 3w1d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 77
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     21770491 packets input, 2949368516 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     22927484 packets output, 226052633 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

New Member

Re: GRE Tunnel always up EIGRP not recovering after failure

I just came into post the same thing, so I hope you don't mind if post my configs also. It's driving me crazy. I've been trying to get it to work for a week. I've gotten tunnels to work before and even managed it in packet tracer, but this scenario has me stumped. A colleague created an exam/lab for the students in his class. However, the lab doesn't work. Partly due to routing. And partly due to something we're missing in the below configurations. I'd appreciate any help.

hostname student1_POP
!
enable secret 5 $1$jMJ6$avAW5obhhul6geSUOsf2./
enable password 7 00071A150754
!
!
no ip domain lookup

!
username student secret 5 $1$4Cyk$W/Z1g9uHGMFNZtDbP257J0
archive
log config
  hidekeys
!
!
crypto isakmp policy 10
encr aes
group 5
lifetime 3600
crypto isakmp key student address 205.0.0.2
!
!
crypto ipsec transform-set student esp-aes esp-md5-hmac
!
crypto map vpn 10 ipsec-isakmp
set peer 205.0.0.2
set transform-set student
match address 101
!
!
interface Loopback0
ip address 193.0.0.253 255.255.255.255
!
interface Tunnel0
ip address 192.168.1.2 255.255.255.0
tunnel source FastEthernet1/0
tunnel destination 205.0.0.2
!
interface FastEthernet0/0
ip address 193.0.0.5 255.255.255.252
speed 100
full-duplex
!
interface FastEthernet0/1
ip address 193.0.0.1 255.255.255.252
speed 100
full-duplex
!
interface FastEthernet1/0
ip address 10.0.0.2 255.255.255.252
speed 100
full-duplex
!
router eigrp 100
network 192.168.1.0
network 193.0.0.0
no auto-summary
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 10.0.0.0 mask 255.255.255.252
network 193.0.0.0 mask 255.255.255.252
network 193.0.0.4 mask 255.255.255.252
network 193.0.0.253 mask 255.255.255.255
neighbor 10.0.0.1 remote-as 700
neighbor 10.0.0.1 route-map ISPROUTERFILTER out
neighbor 193.0.0.2 remote-as 100
neighbor 193.0.0.6 remote-as 100
neighbor 193.0.0.14 remote-as 100
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
!
ip http server
no ip http secure-server
!
access-list 1 permit 10.0.0.0 0.0.0.3
access-list 101 permit gre host 10.0.0.2 host 205.0.0.2
!
!
!
route-map ISPROUTERFILTER permit 10
match ip address 1

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

hostname Instructor_Router
!
crypto isakmp policy 10
encr aes
group 2
lifetime 3600
crypto isakmp key student address 197.0.0.253
!
!
crypto ipsec transform-set student esp-aes esp-md5-hmac
!
crypto map vpn 50 ipsec-isakmp
set peer 197.0.0.253
set transform-set student
match address 105
!
!
interface Loopback0
ip address 205.0.0.231 255.255.255.255
!
interface Loopback1
ip address 205.0.0.232 255.255.255.255
!
interface Loopback2
ip address 205.0.0.233 255.255.255.255
!
interface Loopback3
ip address 205.0.0.234 255.255.255.255
!
interface Loopback4
ip address 205.0.0.235 255.255.255.255
!
interface Loopback5
ip address 205.0.0.236 255.255.255.255
!
interface Loopback6
ip address 205.0.0.237 255.255.255.255
!
interface Loopback7
ip address 205.0.0.238 255.255.255.255
!
interface Loopback8
ip address 205.0.0.239 255.255.255.255
!
interface Loopback9
ip address 205.0.0.240 255.255.255.255
!
interface Loopback10
ip address 205.0.0.241 255.255.255.255
!
interface Loopback11
ip address 205.0.0.242 255.255.255.255
interface Loopback12
ip address 205.0.0.243 255.255.255.255
!
interface Loopback13
ip address 205.0.0.244 255.255.255.255
!
interface Loopback14
ip address 205.0.0.245 255.255.255.255
!
interface Loopback15
ip address 205.0.0.246 255.255.255.255
!
interface Loopback16
ip address 205.0.0.247 255.255.255.255
!
interface Loopback17
ip address 205.0.0.248 255.255.255.255
!
interface Loopback18
ip address 205.0.0.249 255.255.255.255
!
interface Loopback19
ip address 205.0.0.250 255.255.255.255
!
interface Loopback20
ip address 205.0.0.251 255.255.255.255
!
interface Loopback21
ip address 205.0.0.252 255.255.255.255
!
interface Loopback22
ip address 205.0.0.253 255.255.255.255
!
interface Loopback23
ip address 205.0.0.254 255.255.255.255
!
interface Tunnel0
ip address 192.168.1.1 255.255.255.252
tunnel source Loopback0
tunnel destination 193.0.0.253
!
interface Tunnel1
ip address 192.168.2.1 255.255.255.252
tunnel source Loopback1
tunnel destination 193.0.0.254
!
interface Tunnel2
ip address 192.168.3.1 255.255.255.252
tunnel source Loopback2
tunnel destination 195.0.0.253
!
interface Tunnel3
ip address 192.168.4.1 255.255.255.252
tunnel source Loopback3
tunnel destination 195.0.0.254
!
interface Tunnel4
ip address 192.168.5.1 255.255.255.252
tunnel source Loopback4
tunnel destination 197.0.0.253
interface Tunnel5
ip address 192.168.6.1 255.255.255.252
tunnel source Loopback5
tunnel destination 197.0.0.254
!
interface Tunnel6
ip address 192.168.7.1 255.255.255.252
tunnel source Loopback6
tunnel destination 199.0.0.253
!
interface Tunnel7
ip address 192.168.8.1 255.255.255.252
tunnel source Loopback7
tunnel destination 199.0.0.254
!
interface Tunnel8
ip address 192.168.9.1 255.255.255.252
tunnel source Loopback8
tunnel destination 201.0.0.253
!
interface Tunnel9
ip address 192.169.10.1 255.255.255.252
tunnel source Loopback9
tunnel destination 201.0.0.254
!
interface GigabitEthernet0/0
ip address 205.0.0.2 255.255.255.252
duplex auto
speed auto
!
router eigrp 100
network 192.168.1.0 0.0.0.3
network 192.168.2.0 0.0.0.3
network 192.168.3.0 0.0.0.3
network 192.168.4.0 0.0.0.3
network 192.168.5.0 0.0.0.3
network 192.168.6.0 0.0.0.3
network 192.168.7.0 0.0.0.3
network 192.168.8.0 0.0.0.3
network 192.168.9.0 0.0.0.3
network 192.168.10.0 0.0.0.3
network 192.168.11.0 0.0.0.3
network 192.168.12.0 0.0.0.3
network 192.168.13.0 0.0.0.3
network 192.168.14.0 0.0.0.3
network 192.168.15.0 0.0.0.3
network 192.168.16.0 0.0.0.3
network 192.168.17.0 0.0.0.3
network 192.168.18.0 0.0.0.3
network 192.168.19.0 0.0.0.3
network 192.168.20.0 0.0.0.3
network 192.168.21.0 0.0.0.3
network 192.168.22.0 0.0.0.3
network 192.168.23.0 0.0.0.3
network 192.168.24.0 0.0.0.3
no auto-summary

ip route 0.0.0.0 0.0.0.0 205.0.0.1
!access-list 105 permit gre host 205.0.0.235 host 197.0.0.253

New Member

Re: GRE Tunnel always up EIGRP not recovering after failure

No problem, try this in your situation.  I had a problem with my eigrp routes coming up at all to begin with and I solved that one by adding the neighbor manually rather than letting them discover each other.

I.E.  Something similar to:

Router EIGRP 100

neighbor 192.168.1..1 Tunnel0

Try that and cycle your tunnel and see if the routes come back up.

As for my issue, the strange thing is about 2 hours after my wireless network connectivity came back up my eigrp neighbors came back up.  Not sure why it took 2 hours for this to occur.

New Member

Re: GRE Tunnel always up EIGRP not recovering after failure

For whatever reason, EIGRP keeps timing out. It won't maintain the adjacency. And this is before I apply the crypto map to the interface, which all the worse.

I keep getting:

*Apr  9 22:57:40.071: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.5.2 (
Tunnel4) is down: retry limit exceeded
*Apr  9 22:57:42.975: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.5.2 (
Tunnel4) is up: new adjacency

I tried putting in router eigrp 100

neighbor 192.168.#.2 tunnel 0 (the ip address belongs to the distant end's tunnel interface)

and it still keeps flapping.

1806
Views
0
Helpful
7
Replies
CreatePlease to create content