Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Help setting DMVPN tunnel source to Loopback 0

OK. I am trying to set up a hub/spoke DMVPN to use the Loopback 0 as the tunnel sourec on the spokes. Right now I have about 150 spokes all using the F0/0 interface, but since that CAN be duplicated (by a home office such as a linksys giving out 192.168.1.x addresses) I want to change that to the Lo0 address. We have a scheme how that each spoke gets a 172.28.x.0/24. the Lo0 scheme will be 10.172.28.x/32, so each spoke will have a unique Lo0 controlled by us. The problem is that it won't come up with Lo0 as the source. I believe I have all of the relevant config below, and can add anything that is missing. The problem I am getting is that the tunnel gets stuck in NHRP - the tunnel interface is up/up, but eigrp doesn't come up and the tunnel will not pass traffic.

TIA

Russell

interface Tunnel2

ip address 172.26.3.10 255.255.0.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1400

ip pim sparse-mode

ip nhrp authentication HMDMVPN1

ip nhrp map 172.26.0.1 x.x.x.x

ip nhrp map multicast x.x.x.x

ip nhrp network-id 100000

ip nhrp holdtime 360

ip nhrp nhs 172.26.0.1

ip tcp adjust-mss 1360

ip summary-address eigrp 100 172.28.10.0 255.255.255.0 5

load-interval 30

delay 1000

qos pre-classify

tunnel source FastEthernet0/0

tunnel destination x.x.x.x

tunnel key 100000

tunnel protection ipsec profile HM-DMVPN1

end

DMVPNTest#sh run int f0/0

Building configuration...

Current configuration : 264 bytes

!

interface FastEthernet0/0

ip address dhcp

ip access-group 101 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

ip nat outside

ip virtual-reassembly in

load-interval 30

duplex auto

speed auto

no cdp enable

no mop enabled

end

DMVPNTest#sh run int lo0

Building configuration...

Current configuration : 133 bytes

!

interface Loopback0

ip address 10.172.28.10 255.255.255.255

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1412

end

DMVPNTest#sh dmvpn

Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete

        N - NATed, L - Local, X - No Socket

        # Ent --> Number of NHRP entries with same NBMA peer

        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting

        UpDn Time --> Up or Down Time for a Tunnel

==========================================================================

Interface: Tunnel2, IPv4 NHRP Details

Type:Spoke, NHRP Peers:1,

# Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb

----- --------------- --------------- ----- -------- -----

     1  x.x.x.x      172.26.0.1    UP 00:06:26     S

DMVPNTest#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

DMVPNTest(config)#int tu2

DMVPNTest(config-if)#shut

DMVPNTest(config-if)#tunn sou lo0

DMVPNTest(config-if)#no shut

DMVPNTest(config-if)#end

DMVPNTest#sh dmvpn

Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete

        N - NATed, L - Local, X - No Socket

        # Ent --> Number of NHRP entries with same NBMA peer

        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting

        UpDn Time --> Up or Down Time for a Tunnel

==========================================================================

Interface: Tunnel2, IPv4 NHRP Details

Type:Spoke, NHRP Peers:1,

# Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb

----- --------------- --------------- ----- -------- -----

     1  x.x.x.x      172.26.0.1  NHRP 00:00:13     S

DMVPNTest#sh dmvpn

Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete

        N - NATed, L - Local, X - No Socket

        # Ent --> Number of NHRP entries with same NBMA peer

        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting

        UpDn Time --> Up or Down Time for a Tunnel

==========================================================================

Interface: Tunnel2, IPv4 NHRP Details

Type:Spoke, NHRP Peers:1,

# Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb

----- --------------- --------------- ----- -------- -----

     1  x.x.x.x      172.26.0.1  NHRP 02:07:41     S

DMVPNTest#sh ip nhrp nhs det

Legend: E=Expecting replies, R=Responding, W=Waiting

Tunnel2:

172.26.0.1   E priority = 0 cluster = 0  req-sent 532  req-failed 0  repl-recv 0 (02:10:01 ago)

DMVPNTest#sh ip int br | i Tunnel2

Tunnel2                    172.26.3.10     YES NVRAM  up                    up

DMVPNTest#sh run | sec eigrp

ip summary-address eigrp 100 172.28.10.0 255.255.255.0 5

ip summary-address eigrp 100 172.28.10.0 255.255.255.0 5

ip summary-address eigrp 100 172.28.10.0 255.255.255.0 5

router eigrp 100

network 172.24.0.0 0.7.255.255

eigrp stub connected


Everyone's tags (4)
1 REPLY
New Member

Help setting DMVPN tunnel source to Loopback 0

Hi Russel,

I'm not an expert on dmvpn, but have you tried to set the tunnel source to be lo0

e.g:

interface Tunnel2

tunnel source int lo0

Cheers, Simon

3194
Views
0
Helpful
1
Replies