Cisco Support Community
Community Member

How automatically logout the pppoe client with the 827 router

Hi all.

I have a customer that gains internet access, using a Cisco 827 router, configured as pppoe

client over an ADSL line.

He needs to automatically disconnect/logout the pppoe client, when there isn't activity.

I tried, w/o success, using the "dialer idle-timeout" parameter on the Dialer Interface. The pppoe client logins itself, without the needing of the "interesting traffic" of the dialer_list/dialer_group statement.

Any suggestion will be appreciate.



version 12.2


hostname Cisco827




vpdn enable


vpdn-group pppoe


protocol pppoe


interface Ethernet0

ip address

ip nat inside

hold-queue 100 out


interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

hold-queue 224 in


interface ATM0.1 point-to-point

pvc 8/35

pppoe-client dial-pool-number 1



interface Dialer1

ip address negotiated

no ip proxy-arp

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer idle-timeout 30

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username user1 password passwd1


ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route Dialer1

no ip http server


access-list 1 permit

dialer-list 1 protocol ip permit


Community Member

Re: How automatically logout the pppoe client with the 827 route

if his sole internet purpose is web browsing.........

i'd make only http and dns "interesting" traffic so that when the client sits down and brings up a browser, then the link will come up.

****but if he uses an AntiVirus that checks for Automatic Updates or Windows Update, then DNS will cause the line to come up when no one is using the pc.

access-list 101 permit tcp any any eq 80

access-list 101 permit udp any any eq 53

dialer-list 1 protocol ip list 101

****then again if you figure out the resolved IPs used for Automated Updates, you could deny them in the acl referenced by the dialer-list (so that the link only comes up as expected).

Community Member

Re: How automatically logout the pppoe client with the 827 route

Thanks for the answer, but they aren't the ethernet attached clients that rise the link: it rises also with no powered on clients.


CreatePlease to create content