Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How to join a domain over VPN connection

I have a Cisco ASA 5505 using Cisco anyconnect as it's VPN client. I am trying to joing a computer to the domain via VPN. I have the annyconnect client set up so that it will download on to the client computer and say on there, it will also start up before login. The problem is when I try to join the domain I get the following error:

The domain name  *name* might be a NetBIOS domain name.  If this is the case, verify that  the domain name is properly registered with WINS.

If you are  certain that the name is not a NetBIOS domain name, then the following  information can help you troubleshoot your DNS configuration.

The  following error occurred when DNS was queried for the service location  (SRV) resource record used to locate a domain controller for domain  nrsc:

The error was: "DNS name does not exist."
(error code 0x0000232B RCODE_NAME_ERROR)

The query was for the SRV record for _ldap._tcp.dc._msdcs.*name*

Common causes of this error include the following:

- The DNS SRV record is not registered in DNS.

- One or more of the following zones do not include delegation to its child zone:

*name*
. (the root zone)

I can ping the server's ip address and name, but I can't join the domain. Any suggestions? Thanks.

3 REPLIES

Re: How to join a domain over VPN connection

Hi,

You can PING the server because that's unicast and IP packet.

I think that joining a domain might use broadcast which will not be sent through the IPsec tunnel.

You could send NetBIOS over the IPsec tunnel and that might take care of it.

Take a look at this to see if it helps:

https://supportforums.cisco.com/message/265224#265224

Federico.

New Member

Re: How to join a domain over VPN connection

I took a look at the link you posted but it ended up confusing me when they got into crypto-access lists and such.

New Member

Re: How to join a domain over VPN connection

I'm pretty sure I tried to join the domain using the NetBIOS nme and it is still giving me the same error.

4786
Views
0
Helpful
3
Replies