Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Internet Access via spli tunnel assistance needed

dear all ,

i have configured my remote access vpn and its working perfectly....now i want to have internet access via split tunnel which i have already configured but still i cant have internet via the VPN , someone please assist.attached is my config and diagram to illustrate :

BUJ-IT-ASA-LAN-2# sh run

: Saved

:

ASA Version 8.2(5)

!

hostname BUJ-IT-ASA-LAN-2

domain-name leo.bi

enable password MgKXXPviZgW4zhKc encrypted

passwd UwiM/pkFcM.xYc8s encrypted

names

dns-guard

!

!

interface Ethernet0/1

description out interface

nameif outside

security-level 0

ip address x.x.x.x 255.255.255.240

!

interface GigabitEthernet1/0

nameif test1

security-level 100

ip address 10.224.224.22 255.255.255.252

ospf hello-interval 1

ospf dead-interval 3

!

interface GigabitEthernet1/1

nameif test2

security-level 100

ip address 10.224.224.26 255.255.255.252

ospf hello-interval 1

ospf dead-interval 3

!

interface GigabitEthernet1/3

shutdown

no nameif

security-level 100

no ip address

!

boot system disk0:/asa825-k8.bin

ftp mode passive

dns server-group DefaultDNS

domain-name leo.bi

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

access-list access-in extended permit icmp any any

access-list Split_Tunnel_List standard permit host 10.21.44.1

access-list Split_Tunnel_List standard permit host 10.192.1.11

access-list Split_Tunnel_List standard permit host 10.192.1.254

access-list Split_Tunnel_List standard permit host 10.224.224.13

access-list Split_Tunnel_List standard permit host 10.224.224.17

access-list Split_Tunnel_List standard permit host 10.224.224.29

access-list Split_Tunnel_List standard permit host 10.224.224.46

access-list Split_Tunnel_List standard permit host 10.224.224.49

access-list Split_Tunnel_List standard permit host 10.224.224.57

access-list Split_Tunnel_List standard permit host 10.224.224.62

access-list Split_Tunnel_List standard permit host 10.224.224.65

access-list Split_Tunnel_List standard permit host 10.224.224.69

access-list Split_Tunnel_List standard permit host 192.168.1.1

access-list Split_Tunnel_List standard permit host 192.168.1.2

access-list Split_Tunnel_List standard permit host 192.168.10.30

access-list Split_Tunnel_List standard permit host 192.168.10.31

access-list Split_Tunnel_List standard permit host 192.168.11.149

access-list Split_Tunnel_List standard permit 192.168.16.0 255.255.255.0

access-list Split_Tunnel_List standard permit host 192.168.16.71

access-list Split_Tunnel_List standard permit host 192.168.16.72

access-list Split_Tunnel_List standard permit host 192.168.16.131

access-list Split_Tunnel_List standard permit host 192.168.16.248

access-list Split_Tunnel_List standard permit host 192.168.16.249

access-list Split_Tunnel_List standard permit host 192.168.16.250

access-list Split_Tunnel_List standard permit host 192.168.16.251

access-list Split_Tunnel_List standard permit host 192.168.16.252

access-list Split_Tunnel_List standard permit host 192.168.17.247

access-list Split_Tunnel_List standard permit host 192.168.17.248

access-list Split_Tunnel_List standard permit host 192.168.17.250

access-list Split_Tunnel_List standard permit host 192.168.17.251

access-list Split_Tunnel_List standard permit host 192.168.18.233

access-list Split_Tunnel_List standard permit host 192.168.18.234

access-list Split_Tunnel_List standard permit host 192.168.21.1

access-list Split_Tunnel_List standard permit host 192.168.21.4

access-list Split_Tunnel_List standard permit host 192.168.31.6

access-list Split_Tunnel_List standard permit host 192.168.32.82

access-list Split_Tunnel_List standard permit host 192.168.32.83

access-list Split_Tunnel_List standard permit host 192.168.50.253

access-list Split_Tunnel_List standard permit host 192.168.16.247

access-list Split_Tunnel_List standard permit 192.168.0.0 255.255.248.0

access-list Split_Tunnel_List standard permit host 192.168.50.254

access-list Split_Tunnel_List standard permit host 192.168.100.2

access-list Split_Tunnel_List standard permit host 192.168.100.3

access-list Split_Tunnel_List standard permit host 192.168.100.5

access-list Split_Tunnel_List standard permit host 192.168.100.6

access-list Split_Tunnel_List standard permit host 192.168.100.8

access-list Split_Tunnel_List standard permit host 192.168.100.9

access-list Split_Tunnel_List standard permit host 192.168.100.10

access-list Split_Tunnel_List standard permit host 192.168.100.11

access-list Split_Tunnel_List standard permit host 192.168.100.13

access-list Split_Tunnel_List standard permit host 192.168.100.14

access-list Split_Tunnel_List standard permit host 192.168.100.117

access-list Split_Tunnel_List standard permit host 192.168.100.251

access-list Split_Tunnel_List standard permit host 192.168.100.252

access-list Split_Tunnel_List standard permit host 192.168.100.254

access-list Split_Tunnel_List standard permit host 192.168.101.3

access-list Split_Tunnel_List standard permit host 192.168.101.5

access-list Split_Tunnel_List standard permit host 192.168.101.12

access-list Split_Tunnel_List standard permit 192.168.100.0 255.255.255.0

access-list Split_Tunnel_List standard permit 192.168.101.0 255.255.255.0

access-list Split_Tunnel_List standard permit 10.224.224.20 255.255.255.252

access-list test1_nat0_outbound extended permit ip any 172.16.2.0 255.255.255.224

pager lines 24

logging enable

logging trap errors

logging asdm informational

logging class vpn asdm informational

mtu test1 1500

mtu test2 1500

mtu SBC 1500

ip local pool IT-Technet 172.16.2.1-172.16.2.30 mask 255.255.255.224

no failover

icmp unreachable rate-limit 1 burst-size 1

icmp permit any inside

icmp permit any outside

asdm image disk0:/asdm-713.bin

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (test1) 0 access-list test1_nat0_outbound

nat (test1) 1 192.168.0.0 255.255.248.0

nat (test2) 1 192.168.0.0 255.255.248.0

!

access-group access-in in interface outside

!

router ospf 1

router-id x.x.x.x

network 10.224.224.20 255.255.255.252 area 0

network 10.224.224.24 255.255.255.252 area 0

log-adj-changes

default-information originate always metric-type 1

!

route outside 0.0.0.0 0.0.0.0 x.x.x.x 1

route test1 10.21.44.1 255.255.255.255 192.168.0.223 1

route test1 10.192.1.11 255.255.255.255 192.168.16.201 1

route test1 10.192.1.254 255.255.255.255 192.168.16.201 1

route test1 10.224.224.13 255.255.255.255 192.168.0.223 1

route test1 10.224.224.17 255.255.255.255 192.168.0.223 1

route test1 10.224.224.29 255.255.255.255 192.168.0.223 1

route test1 10.224.224.46 255.255.255.255 192.168.0.223 1

route test1 10.224.224.49 255.255.255.255 192.168.0.223 1

route test1 10.224.224.57 255.255.255.255 192.168.0.223 1

route test1 10.224.224.62 255.255.255.255 192.168.0.223 1

route test1 10.224.224.65 255.255.255.255 192.168.0.223 1

route test1 10.224.224.69 255.255.255.255 192.168.0.223 1

route inside 172.16.2.0 255.255.255.224 192.168.0.233 1

route test1 192.168.1.1 255.255.255.255 192.168.0.223 1

route test1 192.168.1.2 255.255.255.255 192.168.0.223 1

route test1 192.168.10.30 255.255.255.255 192.168.0.223 1

route test1 192.168.10.31 255.255.255.255 192.168.0.223 1

route test1 192.168.11.149 255.255.255.255 192.168.0.223 1

route test1 192.168.16.0 255.255.255.0 192.168.0.223 1

route test1 192.168.16.71 255.255.255.255 192.168.0.223 1

route test1 192.168.16.72 255.255.255.255 192.168.0.223 1

route test1 192.168.16.131 255.255.255.255 192.168.0.223 1

route test1 192.168.16.248 255.255.255.255 192.168.0.223 1

route test1 192.168.16.249 255.255.255.255 192.168.0.223 1

route test1 192.168.16.250 255.255.255.255 192.168.0.223 1

route test1 192.168.16.251 255.255.255.255 192.168.0.223 1

route test1 192.168.16.252 255.255.255.255 192.168.0.223 1

route Signal 192.168.17.0 255.255.255.0 10.224.224.2 1

route test1 192.168.17.247 255.255.255.255 192.168.0.223 1

route test1 192.168.17.248 255.255.255.255 192.168.0.223 1

route test1 192.168.17.250 255.255.255.255 192.168.0.223 1

route test1 192.168.17.251 255.255.255.255 192.168.0.223 1

route test1 192.168.18.233 255.255.255.255 192.168.0.223 1

route test1 192.168.18.234 255.255.255.255 192.168.0.223 1

route test1 192.168.21.1 255.255.255.255 192.168.0.223 1

route test1 192.168.21.4 255.255.255.255 192.168.0.223 1

route test1 192.168.31.6 255.255.255.255 192.168.0.223 1

route test1 192.168.32.82 255.255.255.255 192.168.0.223 1

route test1 192.168.32.83 255.255.255.255 192.168.0.223 1

route test1 192.168.50.253 255.255.255.255 192.168.0.223 1

route test1 192.168.50.254 255.255.255.255 192.168.0.223 1

route test1 192.168.100.2 255.255.255.255 192.168.0.223 1

route test1 192.168.100.3 255.255.255.255 192.168.0.223 1

route test1 192.168.100.5 255.255.255.255 192.168.0.223 1

route test1 192.168.100.6 255.255.255.255 192.168.0.223 1

route test1 192.168.100.8 255.255.255.255 192.168.0.223 1

route test1 192.168.100.9 255.255.255.255 192.168.0.223 1

route test1 192.168.100.10 255.255.255.255 192.168.0.223 1

route test1 192.168.100.11 255.255.255.255 192.168.0.223 1

route test1 192.168.100.13 255.255.255.255 192.168.0.223 1

route test1 192.168.100.14 255.255.255.255 192.168.0.223 1

route test1 192.168.100.117 255.255.255.255 192.168.0.223 1

route test1 192.168.100.251 255.255.255.255 192.168.0.223 1

route test1 192.168.100.252 255.255.255.255 192.168.0.223 1

route test1 192.168.100.254 255.255.255.255 192.168.0.223 1

route test1 192.168.101.3 255.255.255.255 192.168.0.223 1

route test1 192.168.101.5 255.255.255.255 192.168.0.223 1

route test1 192.168.101.12 255.255.255.255 192.168.0.223 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

aaa authentication ssh console LOCAL

aaa authentication http console LOCAL

aaa authentication telnet console LOCAL

aaa authentication enable console LOCAL

http server enable

no snmp-server location

no snmp-server contact

snmp-server community *****

snmp-server enable traps snmp authentication linkup linkdown coldstart

snmp-server enable traps syslog

snmp-server enable traps ipsec start stop

snmp-server enable traps entity config-change fru-insert fru-remove

snmp-server enable traps remote-access session-threshold-exceeded

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map 3 set security-association lifetime seconds 3600

crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map interface outside

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130

    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117

    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b

    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504

    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72

    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56

    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043

    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31

    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b

    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20

    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65

    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420

    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329

    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365

    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7

    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597

    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10

    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc

    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845

    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8

    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced

    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f

    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201

    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868

    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101

    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8

    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777

    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a

    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406

    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973

    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403

    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969

    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b

    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973

    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30

    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603

    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355

    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80

    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e

    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a

    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16

    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0

    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8

    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28

    6c2527b9 deb78458 c61f381e a4c4cb66

  quit

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

crypto isakmp nat-traversal 30

telnet timeout 5

ssh timeout 5

ssh version 2

console timeout 0

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn       

group-policy IT-Technet internal

group-policy IT-Technet attributes

dns-server value 41.79.47.6 41.79.47.7

vpn-tunnel-protocol IPSec

split-tunnel-policy tunnelspecified

split-tunnel-network-list value Split_Tunnel_List

default-domain value leo.bi

nem enable

username UcomTech password 0m8FyfsypfWGHUg5 encrypted privilege 0

username UcomTech attributes

vpn-group-policy IT-Technet

tunnel-group IT-Technet type remote-access

tunnel-group IT-Technet general-attributes

address-pool IT-Technet

default-group-policy IT-Technet

tunnel-group IT-Technet ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map global_policy

class inspection_default

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect icmp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

call-home reporting anonymous

call-home

profile CiscoTAC-1

  no active

  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService

  destination address email callhome@cisco.com

  destination transport-method http

  subscribe-to-alert-group diagnostic

  subscribe-to-alert-group environment

  subscribe-to-alert-group inventory periodic monthly

  subscribe-to-alert-group configuration periodic monthly

  subscribe-to-alert-group telemetry periodic daily

Cryptochecksum:dee1c8ab6fc31ceb0f8163e69b1d8c68

: end

6 REPLIES
New Member

Internet Access via spli tunnel assistance needed

actually when i check my windows 8 network icon , i see to network icons one says i have internet access while network two which i presume its the VPN , there is unlimited internet access...i need to be able to ping to 8.8.8.8 to verify internet access while at the same time remote access , SOMEONE out there give a hand

Super Bronze

Internet Access via spli tunnel assistance needed

Hi,

I am not sure if I just missunderstand the issue but the point of configuring Split Tunnel VPN is usually to allow the user to access the Internet through its local Internet connection and only send traffic to the VPN connection towards some specific networks like corporate LAN network.

Typically if you want to forward the users Internet traffic through the VPN connection to the ASA and from the ASA to the Internet then you would use Full Tunnel VPN Client. This is because all traffic would be forwarded through the VPN to the ASA and from there to the Internet if needed.

If you used Split Tunnel VPN then you would have to tell the ASA all the different public IP addresses to which the users need access with the Split Tunnel ACL you are currently using.

You would also need an additional NAT configuration on the ASA to NAT the VPN users address before going to the Internet

nat (outside) 1 172.16.2.0 255.255.255.224

Your configuration at the moment seems to be configured as Split Tunnel VPN that only forwards traffic towards certain private IP addresses through the VPN connection and should forward all Internet traffic through the users current Internet connection.

If its not working like that then I dont see anything in the configuration that should cause that.

I am wondering why this is configured though

group-policy IT-Technet attributes

nem enable

Do you have some remote sites that connect to this site as NEM Hardware VPN Clients?

- Jouni

New Member

Internet Access via spli tunnel assistance needed

dear jouni,

thanks for the above reply!

what i  want to know is with the current config , when i remote access with the VPN  will i be able to have internet access , let say if i try to ping google DNS 8.8.8.8 , my ping doesnt work ??? assist please

New Member

Internet Access via spli tunnel assistance needed

indeed it worked ...thanks alot Jouni

Super Bronze

Internet Access via spli tunnel assistance needed

Hi,

What did you end up doing?

Can your VPN user use the Internet at the same time he/she has VPN connection active?

Did you change it to Full Tunnel VPN or did you perhaps add rules to the Split Tunnel ACL?

- Jouni

New Member

Re: Internet Access via spli tunnel assistance needed

i removed all the acls i had created for the different private networks and add a standard acl with permit any and also

the nat (outside) 1 172.16.2.0 255.255.255.224 ...and it works though i want to limit the acl to specific hosts instead of the any

my host has internet through the VPN as of now ..

right now i just finished to edit extended acls ...check the attached jpeg file.

thanks alot

670
Views
0
Helpful
6
Replies
CreatePlease login to create content