Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ipsec is not working

Hi,

I have created virtual lab with ipsec tunnel. I have attached diagram as well . Please refer below configuration as well.


R2#show running-config

crypto isakmp policy 10

encr 3des

hash md5

authentication pre-share

crypto isakmp key cisco address 209.85.160.2

crypto ipsec transform-set vinod esp-3des esp-md5-hmac

crypto map myvpn 10 ipsec-isakmp

set peer 209.85.160.2

set transform-set vinod

match address 101

ip route 0.0.0.0 0.0.0.0 10.10.10.2

access-list 101 permit ip 10.10.0.0 0.0.255.255 192.168.10.0 0.0.0.255

interface FastEthernet1/1

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

crypto map myvpn

Other end router configuration :

R5#show running-config

crypto isakmp policy 10

encr 3des

hash md5

authentication pre-share

crypto isakmp key cisco address 10.10.10.1

crypto ipsec transform-set vinod esp-3des esp-md5-hmac!

crypto map myvpn 10 ipsec-isakmp

set peer 10.10.10.1

set transform-set vinod

match address 101

interface Serial1/0

ip address 209.85.160.2 255.255.255.0

serial restart-delay 0

crypto map myvpn

access-list 101 permit ip 192.168.10.0 0.0.0.255 10.10.0.0 0.0.255.255

I have checked with below command and confirmed that it is not working ...

Please share the knowledge for the same . It will be appreciative

1 REPLY

Re: ipsec is not working

HI Vinod,

Debugs would have helped a lot here. In any case, modify the follwing and let us know if it still does not come up. Attach the debugs if req.

(remove the pre-shared-keys first)

First router:

crypto isakmp key cisco address 209.85.160.2 no-xauth

Second router:

crypto isakmp key cisco address 10.10.10.1 no-xauth

Show commands:

show crypto isakmp sa detail

show crypto ipsec sa

Debugs:

debug crypto isakmp

debug crypto ipsec

Regards,

Praveen

309
Views
0
Helpful
1
Replies