Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

IPsec Remote VPN with VPN client 5.0.07 using ASDM IPsec wizard

Hi,

I am setting up IPsec remote VPN for ASA 5505 using ASDM wizard and want to use VPN client for client machines. I have follwing questions:

My inside network IP 192.168.0.1 and outside IP 162.212.232.174.

1. what is POOL ip for step 6 for ASDM Ipsec wizard?? which range I should put??

2. for VPN client: what I should put for Host IP and group authentication username and password??

Please advise or provide me any link for help.

I want help for setting up both VPN client and ASA using ASDM wizard.

please help.

thanks,

Sap

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: IPsec Remote VPN with VPN client 5.0.07 using ASDM IPsec wiz

Sap,

Use this link as a reference

http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008060f25c.shtml

* For Pool you can use any private  IP range based on RFC1918 space   , as example you could use 172.16.10.0/24 

* For VPN client you use your firewall outside IP address [ 162.212.232.174]  which will become your RA VPN gateway facing internet. User authentication information is on the same link  above.

Good luck

IPsec Remote VPN with VPN client 5.0.07 using ASDM IPsec wizard

Hi Sap,  glad that link helped ..

For primary and Secondary DNS    you could  use  what you currently use  internally  in your LAN. If you do not depend on internal DNS  use one public DNS   like 4.2.2.2   etc.. or one from your current ISP

Regards

6 REPLIES

Re: IPsec Remote VPN with VPN client 5.0.07 using ASDM IPsec wiz

Sap,

Use this link as a reference

http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008060f25c.shtml

* For Pool you can use any private  IP range based on RFC1918 space   , as example you could use 172.16.10.0/24 

* For VPN client you use your firewall outside IP address [ 162.212.232.174]  which will become your RA VPN gateway facing internet. User authentication information is on the same link  above.

Good luck

New Member

IPsec Remote VPN with VPN client 5.0.07 using ASDM IPsec wizard

Thanks Jorge,

Can I leave step 7 for ASDM wizard: Primary DNS and secondary DNS empty??

Thanks,

Sap

IPsec Remote VPN with VPN client 5.0.07 using ASDM IPsec wizard

Hi Sap,  glad that link helped ..

For primary and Secondary DNS    you could  use  what you currently use  internally  in your LAN. If you do not depend on internal DNS  use one public DNS   like 4.2.2.2   etc.. or one from your current ISP

Regards

New Member

IPsec Remote VPN with VPN client 5.0.07 using ASDM IPsec wizard

Thanks Jorge,

for initial ASDM wizard: inside interface (VLAN 1) has IP 192.168.1.1 and outside (VLAN2) is showing down, both outside and inside interfaces should be up for ASA, please advise for this??

should I select DHCP to assign IP to outside interface or should assign any other IP??

thanks,

Sap

New Member

Re: IPsec Remote VPN with VPN client 5.0.07 using ASDM IPsec wiz

Hi Jorge,

my current configuration is :

esult of the command: "show running-config"

: Saved
:
ASA Version 8.2(5)
!
hostname TEST

enable password ___________ encrypted
passwd __________ encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
ftp mode passive
access-list sap_vpn_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.10.0 255.255.255.224
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool test_pool 192.168.10.0-192.168.10.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.132 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy sap_vpn internal
group-policy sap_vpn attributes
dns-server value 192.168.2.1
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value sap_vpn_splitTunnelAcl
username test password ____________ encrypted privilege 0
username test attributes
vpn-group-policy sap_vpn
username TEST password ________________ encrypted privilege 15
tunnel-group sap_vpn type remote-access
tunnel-group sap_vpn general-attributes
address-pool test_pool
default-group-policy sap_vpn
tunnel-group sap_vpn ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:b67cdffbb9567f754052e72f69ef95f1
: end

I am using VPN client with host IP 192.168.2.20 and group authentication with username:sap_vpn and preshared key as password but could not connect to vpn and getting attached error message.

please advise me

New Member

Re: IPsec Remote VPN with VPN client 5.0.07 using ASDM IPsec wiz

Hi Jorge,

my current configuration is :

esult of the command: "show running-config"

: Saved
:
ASA Version 8.2(5)
!
hostname TEST

enable password ___________ encrypted
passwd __________ encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
ftp mode passive
access-list sap_vpn_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.10.0 255.255.255.224
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool test_pool 192.168.10.0-192.168.10.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.132 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy sap_vpn internal
group-policy sap_vpn attributes
dns-server value 192.168.2.1
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value sap_vpn_splitTunnelAcl
username test password ____________ encrypted privilege 0
username test attributes
vpn-group-policy sap_vpn
username TEST password ________________ encrypted privilege 15
tunnel-group sap_vpn type remote-access
tunnel-group sap_vpn general-attributes
address-pool test_pool
default-group-policy sap_vpn
tunnel-group sap_vpn ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:b67cdffbb9567f754052e72f69ef95f1
: end

I am using VPN client with host IP 192.168.2.20 and group authentication with username:sap_vpn and preshared key as password but could not connect to vpn and getting attached error message.

please advise me

Attachments:
542
Views
0
Helpful
6
Replies
CreatePlease to create content