Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IPSec remote VPN with VPN client giving error

Hi ,

ASA 5505 current configuration is : (setup using ASDM)

esult of the command: "show running-config"

: Saved
:
ASA Version 8.2(5)
!
hostname TEST

enable password ___________ encrypted
passwd __________ encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
ftp mode passive
access-list sap_vpn_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.10.0 255.255.255.224
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool test_pool 192.168.10.0-192.168.10.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.132 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy sap_vpn internal
group-policy sap_vpn attributes
dns-server value 192.168.2.1
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value sap_vpn_splitTunnelAcl
username test password ____________ encrypted privilege 0
username test attributes
vpn-group-policy sap_vpn
username TEST password ________________ encrypted privilege 15
tunnel-group sap_vpn type remote-access
tunnel-group sap_vpn general-attributes
address-pool test_pool
default-group-policy sap_vpn
tunnel-group sap_vpn ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:b67cdffbb9567f754052e72f69ef95f1
: end

I am using VPN client with host IP 192.168.2.20 and group authentication with username:sap_vpn and preshared key as password but could not connect to vpn and getting attached error message.

ASA set up with ASDM initial wizard: inside interface (VLAN1) IP 192.168.1.1 and outside (VLAN2) IP 192.168.2.20 assigned using DHCP. I am using outside interface IP 192.168.2.20 for HOST IP in VPN client for remote connection??? is it right??

please advise for this.

8 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

IPSec remote VPN with VPN client giving error

Hi,

What about trying a static IP on the Outside? We need a static IP in order to connect, could you try again and let us know how it works?

Regards,

New Member

IPSec remote VPN with VPN client giving error

Hi,

The set up is not correct, first, 192.168.2.20 is a private IP and is not reachable via internet, Try going to ipchicken.com from a pc on the inside to get to know your public ip address and then try using that ip for host.

though this is not a preffered way to implement and we strongly suggest to use a public ip because as soon as the modem gets rebooted the ip address will be changed.

HTH

~Harry

IPSec remote VPN with VPN client giving error

Hello Sap,

Best practise is to configure your modem in bridge mode and let ASA have the public IPs directly.

Second best practise is in your bell modem configure DMZ and specify 192.168.2.20 as the DMZ host.

Third and worst practise is to lookup for necessary ports for VPN on google and forward those one by one.

However before coming to public IP discussion, I see that you are trying to VPN to the outside IP address of the ASA, which should technically work if your laptop is also in 192.168.2.0/24 network (while testing your VPN, you should unplug your computers communication with inside network which is 192.168.1.0/24 and move it to 2.0/24)

If the conditions in paranthesis above are met, then something is wrong with the VPN configuration. I would suggest you to enable ASDM logging, then try VPN again and take the screenshot of the logs that occured and post here.

Regards

New Member

Re: IPSec remote VPN with VPN client giving error

Hi,
I would call your Local ISP to check that so we wont affect other services. Also, make sure on having a static ip address, that ip will be used to connect from the outside and configured on the ASA external IP address

Regards,

Sent from Cisco Technical Support iPhone App

IPSec remote VPN with VPN client giving error

Sap,

Basicaly you turn your modem into nothing but a medium converter. That means your existing configuration (such as port forwardings etc) will be gone. In full bridge mode, ASA is doing the dial-up connection.

I dont know your full modem type but found the following link for configuring bell modem in bridge mode.

http://www.wikihow.com/Set-Your-Bell-2Wire-2701Hg-G-Modem-Router-to-Bridge-Mode

After that, you have to configure your ASA for dial-up.

http://www.net-gyver.com/?p=1405

Cheers!

Re: IPSec remote VPN with VPN client giving error

That modem supports bridge mode, and how it is done is in the link I have previously posted. Did your ISP say that it doesnt support?

IPSec remote VPN with VPN client giving error

A quick google shows that DIR-601 does not support bridge mode.

Your best bet looks like trying DMZ host option.

Re: IPSec remote VPN with VPN client giving error

Could you please explain bit more about DMZ host option?? Do I have to configure ASA as DMZ host??

Yes, ASA will be a DMZ host according to the modem (so configuration will be carried on the modem, not ASA), if modem supports that functionality. Two typical implementation of DMZ is

1)Forward all ports and protocols to the DMZ host private IP

2)Figure out DMZ host's MAC address and assign the public IP directly to the DMZ host via DHCP (or static in some occasions)

I have tried with static IP and after assigning static IP at outside  interface, I can not connect to internet. any comments for this pls??

What did you do in the modem first in order to be able to assign public IP to ASA outside interface?

27 REPLIES
New Member

IPSec remote VPN with VPN client giving error

Hi,

What about trying a static IP on the Outside? We need a static IP in order to connect, could you try again and let us know how it works?

Regards,

New Member

IPSec remote VPN with VPN client giving error

Hi,

The set up is not correct, first, 192.168.2.20 is a private IP and is not reachable via internet, Try going to ipchicken.com from a pc on the inside to get to know your public ip address and then try using that ip for host.

though this is not a preffered way to implement and we strongly suggest to use a public ip because as soon as the modem gets rebooted the ip address will be changed.

HTH

~Harry

New Member

IPSec remote VPN with VPN client giving error

Thanks Harry and Andrus,

I am connecting my home network (bell internet) to ASA through bell modem.

For assigning outside interface I am using DHCP and it is assigning private  IP to outside interface.

I know my public IP by going to whatismyip.com or ipchicken.com but how should I assign this IP to outside interface of ASA.

Please advise.

Thanks,

Sap Dhanoa

IPSec remote VPN with VPN client giving error

Hello Sap,

Best practise is to configure your modem in bridge mode and let ASA have the public IPs directly.

Second best practise is in your bell modem configure DMZ and specify 192.168.2.20 as the DMZ host.

Third and worst practise is to lookup for necessary ports for VPN on google and forward those one by one.

However before coming to public IP discussion, I see that you are trying to VPN to the outside IP address of the ASA, which should technically work if your laptop is also in 192.168.2.0/24 network (while testing your VPN, you should unplug your computers communication with inside network which is 192.168.1.0/24 and move it to 2.0/24)

If the conditions in paranthesis above are met, then something is wrong with the VPN configuration. I would suggest you to enable ASDM logging, then try VPN again and take the screenshot of the logs that occured and post here.

Regards

New Member

IPSec remote VPN with VPN client giving error

Thanks Husy,

could you please eloborate more for " configure your modem in bridge mode".

I want to ASA should take public IP Directly.

I am attaching here my bell home modem configuration.(pls see the attached)

I think VPN settings are fine, I can not access VPN because outside interface for ASA is not taking public IP.

please advice

thanks,

Sap

IPSec remote VPN with VPN client giving error

Sap,

Basicaly you turn your modem into nothing but a medium converter. That means your existing configuration (such as port forwardings etc) will be gone. In full bridge mode, ASA is doing the dial-up connection.

I dont know your full modem type but found the following link for configuring bell modem in bridge mode.

http://www.wikihow.com/Set-Your-Bell-2Wire-2701Hg-G-Modem-Router-to-Bridge-Mode

After that, you have to configure your ASA for dial-up.

http://www.net-gyver.com/?p=1405

Cheers!

New Member

Re: IPSec remote VPN with VPN client giving error

Hi,
I would call your Local ISP to check that so we wont affect other services. Also, make sure on having a static ip address, that ip will be used to connect from the outside and configured on the ASA external IP address

Regards,

Sent from Cisco Technical Support iPhone App

New Member

Re: IPSec remote VPN with VPN client giving error

Hi,
I would call your Local ISP to check that so we wont affect other services. Also, make sure on having a static ip address, that ip will be used to connect from the outside and configured on the ASA external IP address

Regards,

Sent from Cisco Technical Support iPhone App

New Member

Re: IPSec remote VPN with VPN client giving error

Hi Husy and Andrus,

Thanks for your help!

I have called my ISP and I can not change my home modem in bridge mode.

how can I get static IP to connect from outside and configure on the ASA external IP address??

I have edited outside interface as PPPOE client (as screen shot attached), but then I can not access internet.

I have seen three options to configure outside interface for ASA: static IP, using DHCP and PPPOE client and results are as below:

using DHCP: it is assigning private IP to outside interface

Using PPPOE: I can not access internet

static IP : do I have to apply for static IP??

Please see the attached screen shots and advise me.

Thanks,

Sap

Re: IPSec remote VPN with VPN client giving error

Sap,

If you can not configure the modem in bridge mode, configuring ASA outside interface in PPPOE mode is useless.

Your next shot is DMZ functionality. Some modems have the option to assign the public IP to host specified as DMZ.

What is your modem's model number?

New Member

Re: IPSec remote VPN with VPN client giving error

Thanks,

Bell modem is "2wire 2701HG-G"

tHANKS,

sAP

Re: IPSec remote VPN with VPN client giving error

That modem supports bridge mode, and how it is done is in the link I have previously posted. Did your ISP say that it doesnt support?

New Member

Re: IPSec remote VPN with VPN client giving error

Thanks Husy,

ISP is not giving me MDC password, only have PPPOE username and password.so I can not change Bell model to bridge mode.

anyway I got D-LINK DIR-601.

Can I connect D-link and configure in bridge mode and then try PPPOE login on ASA???

Please advise

thanks,

Sapinder

IPSec remote VPN with VPN client giving error

A quick google shows that DIR-601 does not support bridge mode.

Your best bet looks like trying DMZ host option.

New Member

IPSec remote VPN with VPN client giving error

Thanks,

yeah I have looked DIR-601 does not support bridge mode.

Could you please explain bit more about DMZ host option?? Do I have to configure ASA as DMZ host??

I have tried with static IP and after assigning static IP at outside interface, I can not connect to internet. any comments for this pls??

Thanks,

Sap

Re: IPSec remote VPN with VPN client giving error

Could you please explain bit more about DMZ host option?? Do I have to configure ASA as DMZ host??

Yes, ASA will be a DMZ host according to the modem (so configuration will be carried on the modem, not ASA), if modem supports that functionality. Two typical implementation of DMZ is

1)Forward all ports and protocols to the DMZ host private IP

2)Figure out DMZ host's MAC address and assign the public IP directly to the DMZ host via DHCP (or static in some occasions)

I have tried with static IP and after assigning static IP at outside  interface, I can not connect to internet. any comments for this pls??

What did you do in the modem first in order to be able to assign public IP to ASA outside interface?

New Member

IPSec remote VPN with VPN client giving error

Thanks,

I will study more about DMZ and follow your comments.

For static IP: I have tested ASA with Rogers fiber internet and I connected outside interface of ASA with internet (internal network) and went to configure the interface then edit and assign static ip as screen shot shows.

after that I could not access internet.

Thanks,

Sap

New Member

IPSec remote VPN with VPN client giving error

I got static IP by whatismyip.com

IPSec remote VPN with VPN client giving error

Sap,

For you to be able to assign your outside interface a public IP, one of the following must hold.

1)Your ASA is directly connected to the ISP via Ethernet and your ISP provided you the IP address, subnetmask and default gateway information. No PPPoE involved here

2)There exists an equipment between ASA and ISP (a modem or a router) which dials a PPPoE user+pass. You configure this modem in bridge mode and pass PPPoE handling to ASA (you configure PPPoE on ASA to obtain the IP dynamically)

If none of the above holds, you can not simply assign your public IP that you found out in whatsmyip.com to your ASA outside interface and expect it to work.

New Member

IPSec remote VPN with VPN client giving error

Thanks Husy,


If none of the above holds, you can not simply assign your public IP that you found out in whatsmyip.com to your ASA outside interface and expect it to work.

I have tried assigning public ip to outside interface of ASA, then internet stop working and I cannot access internet on devices attached to interside interface of ASA.

any clue why that is happening.

Thanks,

Sap

New Member

IPSec remote VPN with VPN client giving error

Hi,

current configuration for ASA 5505 for IPSec remote VPN as below:

ASA Version 8.2(5)
!
hostname _________

domain-name ________
enable password ___________ encrypted
passwd _________ encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.0.7 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address ______________(public IP)
!
ftp mode passive
dns server-group DefaultDNS
domain-name ________
access-list inside_nat0_outbound extended permit ip any 172.16.0.0 255.255.224.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool test_pool 172.16.10.0-172.16.16.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcp-client client-id interface outside
dhcpd auto_config outside
!
dhcpd address 192.168.0.11-192.168.0.138 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy dyt_vpn internal
group-policy dyt_vpn attributes
vpn-tunnel-protocol IPSec
default-domain value _______
username test password _________ encrypted privilege 0
username test attributes
vpn-group-policy dyt_vpn
username ________ password ______________encrypted privilege 15
tunnel-group dyt_vpn type remote-access
tunnel-group dyt_vpn general-attributes
address-pool test_pool
default-group-policy dyt_vpn
tunnel-group dyt_vpn ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:eb0f7a5c2385b7400e9b9432fb2df9d1
: end

when I am assigning PUblic IP to outisde interface of ASA, it is showing outside interface down.

can anybody please help me for that.

Thanks,

Sap

IPSec remote VPN with VPN client giving error

Sap,

Please re-read my previous post very carefully. I am explaining there that you can not just go ahead and asssign the pub IP. Let me know which one of the criterias that I mentioned hold in your infrastructure?

If none of those conditions are met, what you are doing is like writing $20.000 on a piece of paper and handing this to your bank to claim $20K

New Member

IPSec remote VPN with VPN client giving error

Thanks Husy,

I understand your previous comments but now I am testing ASA at my work where I have fiber internet, so it means ISP directly connected to ASA via ethernet, no PPPOE?? right?

I have static IP provided by ISP.

please advise for this.

Thanks,

Sap

IPSec remote VPN with VPN client giving error

Sap,

Your default route in above configuration is missing. It should work once you type in the default route and if your IP and subnetmask are correct

New Member

IPSec remote VPN with VPN client giving error

Thanks Husy,

Could you please explain more which default route configurationis missing??

Thanks for your help!

sap

New Member

Re: IPSec remote VPN with VPN client giving error

If you are using an IP address assigned by you ISP you also need to enter a route or gateway for the outside interface. You can do this both from ASDM or CLI. CLI syntax is: route outside 0.0.0.0/0 [isp router] 1

The [isp router] is the IP your ISP has provided as gateway.

If you do this all traffic that are leaving the inside interface to outside will be routed to the ISP router and then you will have access to the internet.

Sent from Cisco Technical Support iPhone App

New Member

Re: IPSec remote VPN with VPN client giving error

Thanks Jon,

I have .176 on my side and .175 on ISP side, so for "route outside 0.0.0.0/0 [isp router] 1", in this command I have to type .175 isp router IP.

Thanks,

Sap

831
Views
0
Helpful
27
Replies