Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

L2L ipsec tunnel is up, but i cant ping the remote host? help!

I have successfully configured a tunnel between two pix 501e. THe problem is now, i cant ping the remote hosts, and they cant ping me. These are two brand new pixs so am i missing something?

Here is are some notables:

1. tunnel lights on on both PIX's

2. each host can ping their gateway

3. the two peers cannot ping each other (this is something i dont understand) ?

How can the tunnel be up, when the two peers cant ping each other?

Both configs are below... help!

Configs are attached!

here is my atlanta config...

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

hostname Atlanta

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 100 remark ****** Link to PIX 1 ******

access-list 100 permit ip host 10.1.2.3 host 10.1.1.4

access-list nonat remark ****** NAT ACL ******

access-list nonat permit ip host 10.1.2.3 host 10.1.1.4

access-list outside_in permit ip any any

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside 216.12.30.20 255.255.255.0

ip address inside 10.1.2.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list nonat

nat (inside) 1 10.1.2.3 255.255.255.255 0 0

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

access-group outside_in in interface outside

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

http 10.1.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set Atlanta_transform_set esp-aes-256 esp-sha-hmac

crypto map mymap 2 ipsec-isakmp

crypto map mymap 2 match address 100

crypto map mymap 2 set peer 216.12.5.20

crypto map mymap 2 set transform-set Atlanta_transform_set

crypto map mymap interface outside

isakmp enable outside

isakmp key ******** address 216.12.5.20 netmask 255.255.255.255 no-xauth

isakmp identity address

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption aes

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

terminal width 80

Cryptochecksum:e369a3f40a86a9ce975a5140ad75d0fc

: end

here is my chicago pix...

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

hostname Chicago

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 100 remark ****** Link to PIX 2 ******

access-list 100 permit ip host 10.1.1.4 host 10.1.2.3

access-list nonat remark ****** NAT ACL ******

access-list nonat permit ip host 10.1.1.4 host 10.1.2.3

access-list outside_in permit ip any any

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside 216.12.5.20 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list nonat

nat (inside) 1 10.1.1.4 255.255.255.255 0 0

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

access-group outside_in in interface outside

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set Chicago_Transform_set esp-aes-256 esp-sha-hmac

crypto map mymap 1 ipsec-isakmp

crypto map mymap 1 match address 100

crypto map mymap 1 set peer 216.12.30.20

crypto map mymap 1 set transform-set Chicago_Transform_set

crypto map mymap interface outside

isakmp enable outside

isakmp key ******** address 216.12.30.20 netmask 255.255.255.255 no-xauth

isakmp identity address

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption aes

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

terminal width 80

Cryptochecksum:ec75071e4e1e5c83b791a9d012fa7729

: end

1 REPLY

Re: L2L ipsec tunnel is up, but i cant ping the remote host? hel

config looks OK.

capture "show crypto ipsec sa" from both PIX.

then issuing a ping

capture "show crypto ipsec sa" again.

Comparing encryp/decryp count in two capture to see which one is NOT incrementing.

I am suspecting "routing" issue or your host has firewall which is blocking icmp.

380
Views
0
Helpful
1
Replies
CreatePlease to create content