Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

L2L VPN between two ASA5505 not working

Let me start by prefacing that I know a thing or two about networking.  VPNs no so much.

I'm trying to setup a Site-toSite VPN between two ASA 5505's.  I'm building this in an office lab before I deploy it to the end sites.  I folllowed the directions on this very informative forum and believe I have it setup correctly.  I can see the tunnel get built and I can even see traffic counters incrementing.  But the actual user sessions don't seem to work.  For example, ping and telnet don't work.

Here's an excerpt from the syslog for a ping test to a computer on the remote end. 

(10.1.10.5 is the local computer, 10.1.11.5 is the remote computer.  10.1.11.1 is the inside interface of the remote ASA)

6|Jan 20 2012|01:04:12|302021|10.1.11.1|0|10.1.10.5|1|Teardown ICMP connection for faddr 10.1.11.1/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:04:10|302020|10.1.10.5|1|10.1.11.1|0|Built outbound ICMP connection for faddr 10.1.11.1/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:04:07|302021|10.1.11.1|0|10.1.10.5|1|Teardown ICMP connection for faddr 10.1.11.1/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:04:05|302020|10.1.10.5|1|10.1.11.1|0|Built outbound ICMP connection for faddr 10.1.11.1/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:04:02|302021|10.1.11.1|0|10.1.10.5|1|Teardown ICMP connection for faddr 10.1.11.1/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:04:00|302020|10.1.10.5|1|10.1.11.1|0|Built outbound ICMP connection for faddr 10.1.11.1/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:03:57|302021|10.1.11.1|0|10.1.10.5|1|Teardown ICMP connection for faddr 10.1.11.1/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:03:55|302020|10.1.10.5|1|10.1.11.1|0|Built outbound ICMP connection for faddr 10.1.11.1/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:03:48|302021|10.1.11.5|0|10.1.10.5|1|Teardown ICMP connection for faddr 10.1.11.5/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:03:46|302020|10.1.10.5|1|10.1.11.5|0|Built outbound ICMP connection for faddr 10.1.11.5/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:03:43|302021|10.1.11.5|0|10.1.10.5|1|Teardown ICMP connection for faddr 10.1.11.5/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:03:41|302020|10.1.10.5|1|10.1.11.5|0|Built outbound ICMP connection for faddr 10.1.11.5/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:03:38|302021|10.1.11.5|0|10.1.10.5|1|Teardown ICMP connection for faddr 10.1.11.5/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
6|Jan 20 2012|01:03:36|302020|10.1.10.5|1|10.1.11.5|0|Built outbound ICMP connection for faddr 10.1.11.5/0 gaddr 10.1.10.5/1 laddr 10.1.10.5/1
5|Jan 20 2012|01:03:32|713041|||||IP = 192.168.24.211, IKE Initiator: New Phase 1, Intf inside, IKE Peer 192.168.24.211  local Proxy Address 10.1.10.0, remote Proxy Address 10.1.11.0,  Crypto map (outside_map)

Here's the configuration for one of them.  The other is setup the same way with the usual opposite settings.

ASA Version 8.2(1)
!
hostname ASATWDS
!

names
name 10.1.11.0 remote-network
!
interface Vlan1
nameif inside
security-level 100
ip address 10.1.10.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 192.168.24.210 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
access-list outside_1_cryptomap extended permit ip 10.1.10.0 255.255.255.0 remote-network 255.255.255.0
access-list inside_nat0_outbound extended permit ip 10.1.10.0 255.255.255.0 remote-network 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 192.168.24.1 1
route outside remote-network 255.255.255.0 192.168.24.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.1.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 192.168.24.211
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 1 set phase1-mode aggressive
crypto map outside_map 1 set reverse-route
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 10.1.10.5-10.1.10.36 inside
dhcpd dns 209.18.47.61 209.18.47.62 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
tunnel-group 192.168.24.211 type ipsec-l2l
tunnel-group 192.168.24.211 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:b4bea5393489da3aa83f281d3107a32e

  • VPN
Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions

L2L VPN between two ASA5505 not working

The Configuration Looks good to me, though I do think that you dont need following :-

crypto map outside_map 1 set phase1-mode aggressive

crypto map outside_map 1 set reverse-route

Anyways,

1> Can you please check if the Computers you are trying to Ping or Telnet dont have Machine based Firewall or Anti-virus or iptables ( Linux ) ?

2> Paste output of

    a>sh crypto ipsec sa

    b> sh crypto isakmp sa

Manish

2 REPLIES

L2L VPN between two ASA5505 not working

The Configuration Looks good to me, though I do think that you dont need following :-

crypto map outside_map 1 set phase1-mode aggressive

crypto map outside_map 1 set reverse-route

Anyways,

1> Can you please check if the Computers you are trying to Ping or Telnet dont have Machine based Firewall or Anti-virus or iptables ( Linux ) ?

2> Paste output of

    a>sh crypto ipsec sa

    b> sh crypto isakmp sa

Manish

New Member

L2L VPN between two ASA5505 not working

Thanks Manish.

You were right on the money with the Windows Firewall.  I had neglected to consider the fact that Windows Firewall is only allowing traffic from the local subnet and not from the traffic originating on the subnet on the other end of the VPN.  Once I turned off the firewall, everything flowed smoothly.

Thanks again for a quick response.

George

1229
Views
0
Helpful
2
Replies