Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

L2TP VPDN Not Routing

Hello,

I have setup a L2TPv3 tunnel between two 2811 routers. I followed directions in the Cisco documentation and the tunnel shows that it is established, but I can not route across the tunnel from the far sides of each network. My topology looks like this:

192.168.100.0/24->2811->192.168.0.0/24->2811->192.168.200.0/24 .

The 100 and 200 subnets are what I hope to be able to route between with the tunnel crossing between the interfaces on the 0 subnet. The tunnel shows established, but I can not ping from the 100 subnet to the 200 subnet. I have attached configs and results of "show vpdn tunnel".

Thanks for any assistance.

Tom

Router 2 Tunnel - show vpdn tunnel

L2TP Tunnel Information Total tunnels 1 sessions 1

LocID RemID Remote Name State Remote Address Port Sessions L2TP Class/

VPDN Group

45441 4293 router1 est 192.168.0.100 0 1 class1

Router 2 Tunnel - show vpdn tunnel

L2TP Tunnel Information Total tunnels 1 sessions 1

LocID RemID Remote Name State Remote Address Port Sessions L2TP Class/

VPDN Group

4293 45441 router2 est 192.168.0.200 0 1 l2tpclass2

Router 1

hostname router1

!

l2tp-class l2tpclass2

!

pseudowire-class pwclass2

encapsulation l2tpv3

protocol l2tpv3 l2tpclass2

ip local interface FastEthernet0/1

ip pmtu

!

interface Loopback1

no ip address

!

interface FastEthernet0/0

bandwidth 1500000

ip address 192.168.100.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

bandwidth 1500000

ip address 192.168.0.100 255.255.255.0

duplex auto

speed auto

!

interface Virtual-PPP2

ip unnumbered Loopback1

no cdp enable

ppp authentication chap

ppp chap hostname peer2

pseudowire 192.168.0.200 10 pw-class pwclass2

!

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip route 192.168.200.0 255.255.255.0 Virtual-PPP2

Router2

!

hostname router2

l2tp-class class1

!

pseudowire-class pwclass1

encapsulation l2tpv3

protocol l2tpv3 class1

ip local interface FastEthernet0/1

ip pmtu

!

interface Loopback1

no ip address

!

interface FastEthernet0/0

ip address 192.168.200.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.0.200 255.255.255.0

duplex auto

speed auto

!

interface Virtual-PPP1

ip unnumbered Loopback1

no cdp enable

ppp authentication chap

ppp chap hostname peer2

pseudowire 192.168.0.100 10 pw-class pwclass1

!

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip route 192.168.100.0 255.255.255.0 Virtual-PPP1

293
Views
0
Helpful
0
Replies