Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPOE help only ever used PPOA on 877 routers

Hi,

I have only ever configured Cisco 877 routers for PPOA ADSL lines in the UK, I now have to configure another 877 for a new VPN on Ireland which use PVC 8/38 (normally 0/38 in UK) and PPOE instead of PPOA.

I have the configure attched, what do I need to change for PPOE? I can see I need to change the PVC to 8/38, but I'm not sure from then on.

7 REPLIES

Re: PPOE help only ever used PPOA on 877 routers

Here's the working config of my PPoE connection at home.

interface FastEthernet0/1

description DSL WAN Interface

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

!

interface Dialer1

description DSL WAN Dialer$FW_OUTSIDE$

ip address negotiated

no ip unreachables

ip nat outside

ip virtual-reassembly

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username CORP@static.sbcglobal.net password 0 SeCrEt

dialer-list 1 protocol ip permit

Hope that helps.

New Member

Re: PPOE help only ever used PPOA on 877 routers

Thanks, what router do you have? I think I have the wrong one, I have an 877 which has an ATM port and not and Ethernet like yours.

Re: PPOE help only ever used PPOA on 877 routers

That's from an 871. Here's one from an 877.

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/35

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface Dialer0

description Virtual Public Interface

ip address 75.50.95.73 255.255.255.248

ip access-group outside_in in

ip mtu 1452

ip flow ingress

ip inspect STATEFUL_FW out

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp chap hostname username@static.sbcglobal.net

ppp chap password 0 SeCrEtPaSsWd

ppp pap sent-username username@static.sbcglobal.net password 0 SeCrEtPaSsWd

!

ip route 0.0.0.0 0.0.0.0 Dialer0 permanent

As you stated before, you'll have to change the ATM pvc.

New Member

Re: PPOE help only ever used PPOA on 877 routers

Great, apart from changing the PVC I notice the only other part I have to add is the ppoe setting under the ATM?

What are the differences between the ppoe and ppoa as thought it was just the port on the back, I immediately assumed as it was ethernet I would need an 871!

New Member

Re: PPOE help only ever used PPOA on 877 routers

Hi Collin,

Just one last thing, does this look ok on my 877 before I ship it off:

interface ATM0

no ip address

no ip mroute-cache

atm vc-per-vp 64

no atm ilmi-keepalive

pvc 8/35

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

It was originally a PPOA router, so should I remove "atm vc-per-vp 64"?

interface Dialer1

ip address negotiated

ip access-group inbound in

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname eircom

ppp chap password 0 broadband

ppp pap sent-username broadband password 0 broadband

crypto map Crypto_Map

Thanks

Re: PPOE help only ever used PPOA on 877 routers

It won't hurt anything being in there. Make sure you create the dialer pool as well (it's not posted). Is the connection really ppp?

New Member

Re: PPOE help only ever used PPOA on 877 routers

I can see the dialer pool under my dialer 1 interface, or should this be somewhere else?

Are the DSL lines normally CHAP, is my config just using either PPP or CHAP?

214
Views
0
Helpful
7
Replies