Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PPTP disappeared on a 2901?

Hi all,

I recently obtained a 2901 router running 15.2(2)T to replace my old 877 which was running 15.1(4)M1. The 2901 is humming along quite nicely but I have had difficulty configuring one feature which was working fine on the 877. The router needs to be a PPTP client to a hosted VPN service. On the 877, I had it configured like this:

vpdn enable

!

vpdn-group 2

request-dialin

  protocol pptp

  rotary-group 2

initiate-to ip xxx.xxx.xxx.xxx

I then had a dialer interface to actually set up the connection, and some PBR to control what went over the VPN. All well and good, and it worked fine. But on the 2901, when I try to configure the same thing, there is no such command as "protocol pptp" -- the only option is protocol l2tp.

Any ideas? Was PPTP support deprecated somwhere between 15.1 and 15.2, or does the 2901 itself not support it for some reason? Obviously I understand that l2tp is superior to pptp, but at the moment this is my only option.

Thanks in advance,

-- Tim

Everyone's tags (3)
2 REPLIES
New Member

PPTP disappeared on a 2901?

Bump... anybody?

New Member

PPTP disappeared on a 2901?

In case anybody is searching and finds this...

In the end I opened a TAC case for this issue; the engineer explained that pptp client functionality had actually been deprecated since 12.2 -- entering the command service internal in config mode re-enables it. It turns out that I actually had service internal enabled on the 877 all along (must've been a hangover from a previous TAC session), which is why pptp worked in the first place.

585
Views
0
Helpful
2
Replies