Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPTP VPN on a stick

Hello All,

Just need a bit of guidance please.  In sumamry I have a Cisco 1841 sitting behind a Firewall (non Cisco).  Im port forwarding pptp through to the 1841 to act as a pptp vpn server.   The site is a flat network so no vlans etc.. I would like to have the 1841 on a stick so that it has an internal IP on fa0/0 192.168.254.252 which will terminate teh PPTP VPN and then forward the traffic to the servers on the network 192.168.254.221.  Any ideas.  Please see the config below.  Default route out of the network is 192.168.254.254

My pptp vpn is connecting ok and handing an IP from the pool but I can't communicate with the internal servers.  Any pointers where I'm going wrong?

Thanks in advance

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

logging buffered 100000 informational

!

no aaa new-model

!

dot11 syslog

ip source-route

!

!

!

!

!

ip cef

!

multilink bundle-name authenticated

!

vpdn enable

vpdn logging

vpdn logging local

vpdn logging user

!

vpdn-group 1

! Default PPTP VPDN group

accept-dialin

  protocol pptp

  virtual-template 1

l2tp tunnel timeout no-session 15

!

crypto pki token default removal timeout 0

!

!

!

!

username xxxx  priv 15 pass xxx

!

redundancy

!

!

controller Cellular 0/0

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.254.252 255.255.255.0

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface ATM0/1/0

no ip address

shutdown

no atm ilmi-keepalive

!

interface Cellular0/0/0

no ip address

encapsulation ppp

!

interface Virtual-Template1

ip unnumbered FastEthernet0/0

ip mtu 1492

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1360

peer default ip address pool vpnpool

no keepalive

ppp encrypt mppe auto passive

!

ip local pool vpnpool 192.168.255.220 192.168.255.225

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip route 0.0.0.0 0.0.0.0 192.168.254.254

!

logging esm config

!

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line 0/0/0

no exec

line vty 0 4

login local

transport input all

line vty 5 15

login local

transport input all

!

scheduler allocate 20000 1000

end

Router#

Everyone's tags (5)
164
Views
0
Helpful
0
Replies
CreatePlease to create content