Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with EIGRP over DMVPN

I am setting up my first DMVPN tunnel and I appear to be having a problem with it.

With EIGRP turned off the tunnel comes right up and works fine. However when I turn up EIGRP the tunnel drops every 15 seconds or so for about 5-10 seconds.

The message on the spoke router is that a goodbye message was received. On the hub router the holding timer expires. Not only does eigrp go down but I can't even pass basic peer to peer traffic over the tunnel, which I can when EIGRP is turned off.

Now this would suggest that, for some reason, one side or the other is not receiving the EIGRP hellos. However I can't imagine for the the life of me why it wouldn't be.

I don't have any filters on the terminating interfaces other than NAT statements on the spoke router.

Has anyone seen anything like this before? I have tried just about every combo of using the split-horizon command and the ip next-hop-self to no avail.

My EIGRP settings on both routers are very basic. Just no auto-summary and the networks.

Any ideas would be great.

4 REPLIES
New Member

Re: Problem with EIGRP over DMVPN

Check if you have any recursing route. If your endpoint of the tunnel is leared inside the tunnnel you will have some similar effect.

New Member

Re: Problem with EIGRP over DMVPN

Yes, i had the same issue as runmosta is describing, my router was learning of the route encrypted and unencrypted.

New Member

Re: Problem with EIGRP over DMVPN

Thanks. I had thought that I wouldn't need to do that with DMVPN. I guess I do.

My question is how do I avoid this problem at the hub router if I don't know the IP address of the spoke?

Does this only apply on the spoke if you have NHRP running?

New Member

Re: Problem with EIGRP over DMVPN

I have had the same problem with EIGRP.

You want to check the Bandwidth statement on the tunnel. Make sure it is correct and matches your

Wan circuit. If not and it is under sized you will starve EIGRP....

241
Views
0
Helpful
4
Replies