Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

RA tunnel up, but can't access remote resources

The VPN client successfully connects to the PIX, but it doesn't appear that any traffic is passing through the tunnel.  There is a site-to-site tunnel up that is working fine, it's just the RA stuff that doesn't.  This had been working at one point, and then stopped.  Here's a sanitized config:

:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password *********
passwd ***********
hostname depot-pix
domain-name domain.local
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 2.2.2.2 cottage-pix
name 192.168.0.3 server1
name 192.168.0.4 server2
access-list vpn permit ip 192.168.0.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list vpn permit icmp any any
access-list vpn permit ip 192.168.0.0 255.255.255.0 192.168.30.0 255.255.255.0 log
access-list split-tunnel permit ip 192.168.0.0 255.255.255.0 192.168.30.0 255.255.255.0
access-list acl_out permit icmp any any
access-list acl_out permit tcp any interface outside eq https
access-list acl_out permit tcp any interface outside eq 9333
pager lines 24
logging on
logging monitor debugging
logging buffered debugging
icmp permit any unreachable outside
mtu outside 1500
mtu inside 1500
ip address outside 1.2.3.4 255.255.255.248
ip address inside 192.168.0.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnPool 192.168.30.10-192.168.30.20
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list vpn
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface smtp server1 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5989 192.168.0.2 5989 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https server1 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 9333 server2 9333 netmask 255.255.255.255 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 1.2.3.5 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa-server raAuth protocol radius
aaa-server raAuth (inside) host server1 secretkey timeout 5
aaa-server local protocol radius
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set strong esp-3des esp-sha-hmac
crypto dynamic-map dynMap 20 set transform-set strong
crypto map OutsideMap 10 ipsec-isakmp
crypto map OutsideMap 10 match address vpn
crypto map OutsideMap 10 set peer cottage-pix
crypto map OutsideMap 10 set transform-set strong
crypto map OutsideMap 20 ipsec-isakmp dynamic dynMap
crypto map OutsideMap client authentication raAuth
crypto map OutsideMap interface outside
isakmp enable outside
isakmp key ******** address cottage-pix netmask 255.255.255.255
isakmp nat-traversal 20
isakmp policy 9 authentication pre-share
isakmp policy 9 encryption 3des
isakmp policy 9 hash sha
isakmp policy 9 group 1
isakmp policy 9 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup remoteAccess address-pool vpnPool
vpngroup remoteAccess dns-server server1
vpngroup remoteAccess wins-server server1
vpngroup remoteAccess default-domain domain.local
vpngroup remoteAccess split-tunnel split-tunnel
vpngroup remoteAccess idle-time 1800
vpngroup remoteAccess password ********
management-access inside
console timeout 0
dhcpd auto_config outside
terminal width 80
Cryptochecksum:9f8a7e0796962279858931db84e4e14a
: end

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: RA tunnel up, but can't access remote resources

Hi,

You're sending the traffic intended to the remote clients, through the Site-to-Site tunnel.

The recommendation is to use a different ACL for nat0 and for the crypto ACL.

Federico.

3 REPLIES

Re: RA tunnel up, but can't access remote resources

Hi,

You're sending the traffic intended to the remote clients, through the Site-to-Site tunnel.

The recommendation is to use a different ACL for nat0 and for the crypto ACL.

Federico.

New Member

Re: RA tunnel up, but can't access remote resources

edit: fixed, thank you!

Re: RA tunnel up, but can't access remote resources

ACL for nat0
nat (inside) 0 access-list vpn
access-list vpn permit ip 192.168.0.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list vpn permit ip 192.168.0.0 255.255.255.0 192.168.30.0 255.255.255.0


ACL for VPN
access-list newvpn permit ip 192.168.0.0 255.255.255.0 192.168.10.0 255.255.255.0
crypto map OutsideMap 10 match address newvpn

In this way, the ACL for the Site-to-Site tunnel will not conflict with the ACL for remote access tunnel.

Federico.

466
Views
0
Helpful
3
Replies
CreatePlease to create content