Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Remote VPN Cannot access Site-to-Site subnets - Cisco ASA 5505

Hi Everyone, 


We had to completely reinstall our Cisco ASA5505 which is the router connecting all our branch sites. All the sites are connecting fine but I'm having headaches trying to figure out why the remote users cannot reach my site-to-site subnets. It was working before so I know the problem is on this router.

Any help would be greatly appreciated! 

Our main site network is 192.168.1.0/24
Site-to-Site Networks are 192.168.2.0/24 & 192.168.3.0/24 & 192.168.4.0/24
Remote VPN network is 192.168.140.0/24

Running config:

ASA Version 8.2(5)
!
domain-name emballage
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.2 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address XX.XX.XX.XX 255.255.255.240
!
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
 domain-name emballage

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.4.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.140.0 255.255.255.0

access-list outside_nat0_outbound extended permit ip 192.168.140.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list outside_nat0_outbound extended permit ip 192.168.140.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list outside_nat0_outbound extended permit ip 192.168.140.0 255.255.255.0 192.168.4.0 255.255.255.0

access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 192.168.4.0 255.255.255.0
access-list outside_2_cryptomap extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list outside_3_cryptomap extended permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list outside_access_in extended permit ip any any
access-list inside_access_in extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool UserVPN 192.168.140.10-192.168.140.250 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.1.0 255.255.255.0
nat (outside) 0 access-list outside_nat0_outbound
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 XX.XX.XX.XX 1
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.140.0 255.255.255.0 inside
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer XX.XX.XX.XX
crypto map outside_map 1 set transform-set ESP-3DES-MD5
crypto map outside_map 2 match address outside_2_cryptomap
crypto map outside_map 2 set pfs
crypto map outside_map 2 set peer XX.XX.XX.XX
crypto map outside_map 2 set transform-set ESP-3DES-MD5
crypto map outside_map 3 match address outside_3_cryptomap
crypto map outside_map 3 set pfs
crypto map outside_map 3 set peer XX.XX.XX.XX
crypto map outside_map 3 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh 192.168.140.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy SJ-PACK internal
group-policy SJ-PACK attributes
 dns-server value 192.168.1.10 192.168.1.20
 vpn-tunnel-protocol IPSec
 default-domain value emballage
username admin password XXXXXXXX encrypted privilege 15
tunnel-group SJ-PACK type remote-access
tunnel-group SJ-PACK general-attributes
 address-pool UserVPN
 default-group-policy SJ-PACK
tunnel-group SJ-PACK ipsec-attributes
 pre-shared-key *****
tunnel-group XX.XX.XX.XX type ipsec-l2l
tunnel-group XX.XX.XX.XX ipsec-attributes
 pre-shared-key *****
tunnel-group XX.XX.XX.XX type ipsec-l2l
tunnel-group XX.XX.XX.XX ipsec-attributes
 pre-shared-key *****
tunnel-group XX.XX.XX.XX type ipsec-l2l
tunnel-group XX.XX.XX.XX ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect ip-options
!
service-policy global_policy global

  • VPN
Everyone's tags (1)
1 REPLY
VIP Purple

Do I understand you right

Do I understand you right that you want that your Users in 192.168.140.0 can communicate with the spoke networks 192.168.2.0, 3.0 and 4.0?

Then you need to extend your config with the following:

  1. You have to allow the ASA to send traffic out of the same interface where the traffic arrived. That is needed because the Remote-VPN-traffic enters the ASA on the outside interfae and the S2S VPNs are also terminated on the outside interface:

    same-security-traffic permit intra-interface

  2. Then, the crypto-definition to the spokes have to include the traffic from the remote-VPN:

    access-list outside_1_cryptomap extended permit ip 192.168.140.0 255.255.255.0 192.168.4.0 255.255.255.0
    access-list outside_2_cryptomap extended permit ip 192.168.140.0 255.255.255.0 192.168.2.0 255.255.255.0
    access-list outside_3_cryptomap extended permit ip 192.168.140.0 255.255.255.0 192.168.3.0 255.255.255.0
-- Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
18
Views
0
Helpful
1
Replies
This widget could not be displayed.