Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Site-to-site IPSec VPN configuration issues

I have a pair of Cisco ASA 5505s that have been installed at their respective sites and I am currently trying to configure them remotely. I am having issues with the Site-to-site VPN functionality as mentioned in the subject. Nothing comes up in any debugging messages as neither ASA recognizes that there is a VPN connection between the two. I'm a bit of a novice but I tried to follow Cisco documentation in this set up with no luck. (Also Site A has a remote IPsec VPN that is currently functioning as intended).

Some more information:

Site A - 208.*.*.* (public), 10.20.1.1 255.255.255.0 (private)

Site B - 69.*.*.* (public), 10.11.1.7 255.255.252.0 (private)

Configs:


Site A -

ASA Version 8.2(5)

!

hostname ciscoasa

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd T4hNGVUh4ws5aBBi encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 10.20.1.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 208.*.*.* 255.255.255.0

!

ftp mode passive

dns domain-lookup inside

dns domain-lookup outside

object-group network DM_INLINE_NETWORK_1

network-object 10.11.0.0 255.255.252.0

network-object 208.*.*.0 255.255.255.0

object-group service DM_INLINE_SERVICE_1

service-object ip

service-object tcp eq www

service-object tcp eq ssh

access-list nlets extended permit tcp any any eq ssh

access-list split_tunnel extended permit ip any any

access-list outside_access_in extended permit tcp 10.11.0.0 255.255.252.0 10.20.1.0 255.255.255.0 eq ssh

access-list inside_access_in extended permit object-group DM_INLINE_SERVICE_1 object-group DM_INLINE_NETWORK_1 10.20.1.0 255.255.255.0

access-list outside_cryptomap extended permit ip 10.20.1.0 255.255.255.0 10.11.0.0 255.255.252.0

access-list outside_20_cryptomap extended permit ip 10.20.1.0 255.255.255.0 10.11.0.0 255.255.252.0

access-list inside_nat0_outbound extended permit ip 10.20.1.0 255.255.255.0 10.11.0.0 255.255.252.0

no pager

logging enable

logging monitor errors

logging asdm informational

mtu inside 1500

mtu outside 1500

ip local pool N2 10.10.1.5-10.10.1.20 mask 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

access-group inside_access_in in interface inside

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 208.*.*.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

aaa authentication ssh console LOCAL

aaa authentication http console LOCAL

aaa authentication serial console LOCAL

http server enable

http 10.20.1.0 255.255.255.0 inside

http 64.*.*.* 255.255.255.255 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map 1 match address outside_cryptomap

crypto map outside_map 1 set peer 69.*.*.*

crypto map outside_map 1 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map 20 match address outside_20_cryptomap

crypto map outside_map 20 set pfs

crypto map outside_map 20 set peer 69.*.*.*

crypto map outside_map 20 set transform-set ESP-3DES-SHA

crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map interface outside

crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map inside_map interface inside

crypto isakmp identity address

crypto isakmp enable inside

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh 10.20.1.0 255.255.255.0 inside

ssh 64.*.*.* 255.255.255.255 outside

ssh timeout 45

console timeout 0

management-access inside

dhcpd auto_config outside

!

threat-detection basic-threat

threat-detection statistics access-list

threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200

webvpn

group-policy DfltGrpPolicy attributes

dns-server value 8.8.8.8

group-policy N2 internal

group-policy N2 attributes

dns-server value 8.8.8.8

vpn-tunnel-protocol IPSec

group-policy GroupPolicy1 internal

group-policy GroupPolicy1 attributes

vpn-tunnel-protocol IPSec

username sd password t4tlbj3IRk5n2fWc encrypted privilege 15

username ee password DElkRqyuPDMaRTxM encrypted privilege 15

tunnel-group N2 type remote-access

tunnel-group N2 general-attributes

address-pool N2

default-group-policy N2

tunnel-group N2 ipsec-attributes

pre-shared-key *****

tunnel-group 69.*.*.* type ipsec-l2l

tunnel-group 69.*.*.* general-attributes

default-group-policy GroupPolicy1

tunnel-group 69.*.*.* ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:fd94bc36fda60c30b01a363c24888ad1

: end

Site B -

ASA Version 8.2(5)

!

hostname ciscoasa

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 10.11.1.7 255.255.252.0

!

interface Vlan2

nameif outside

security-level 0

ip address 69.*.*.* 255.255.255.0

!

ftp mode passive

object-group network DM_INLINE_NETWORK_1

network-object 10.20.1.0 255.255.255.0

network-object 69.*.*.0 255.255.255.0

object-group service DM_INLINE_SERVICE_1

service-object ip

service-object tcp eq www

service-object tcp eq ssh

access-list outside_cryptomap extended permit ip 10.11.0.0 255.255.252.0 10.20.1.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 10.11.0.0 255.255.252.0 69.*.*.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 10.11.0.0 255.255.252.0 10.20.1.0 255.255.255.0

access-list nonat extended permit ip 10.11.0.0 255.255.252.0 10.20.1.0 255.255.255.0

access-list outside_cryptomap_1 extended permit ip 10.11.0.0 255.255.252.0 10.20.1.0 255.255.255.0

access-list inside_access_in extended permit object-group DM_INLINE_SERVICE_1 object-group DM_INLINE_NETWORK_1 10.11.0.0 255.255.252.0

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu outside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 0.0.0.0 0.0.0.0

access-group inside_access_in in interface inside

route outside 0.0.0.0 0.0.0.0 69.*.*.17 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 10.11.0.0 255.255.252.0 inside

http 64.*.*.* 255.255.255.255 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set my-set esp-3des esp-sha-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map0 1 match address outside_cryptomap

crypto map outside_map0 1 set peer 208.*.*.*

crypto map outside_map0 1 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map1 1 match address outside_cryptomap_1

crypto map outside_map1 1 set peer 208.*.*.*

crypto map outside_map1 1 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map1 interface outside

crypto isakmp identity address

crypto isakmp enable inside

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh 10.11.0.0 255.255.252.0 inside

ssh 64.*.*.* 255.255.255.255 outside

ssh timeout 5

console timeout 0

management-access inside

dhcpd auto_config outside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

group-policy GroupPolicy1 internal

group-policy GroupPolicy1 attributes

vpn-tunnel-protocol IPSec

username safespeed password t4tlbj3IRk5n2fWc encrypted privilege 15

tunnel-group 208.*.*.* type ipsec-l2l

tunnel-group 208.*.*.* general-attributes

default-group-policy GroupPolicy1

tunnel-group 208.*.*.* ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:5b2a81067def0ad35a87f26481ff17c9

: end


2 REPLIES
Community Member

Site-to-site IPSec VPN configuration issues

More info: I cannot get through phase 1.

I have confirmed that I am using the same PSK on each side, enabled PFS on the side that did not have it and removed redundant cryptomaps (as well as tailored outside_map1 to only use AES-256-SHA). Also, I've reloaded multiple times... Thanks ahead of time.

show crypto isakmp output: (not much to look at)

> ciscoasa# show crypto isakmp
> 
> There are no isakmp sas
> 
> Global IKE Statistics
> Active Tunnels: 0
> Previous Tunnels: 0
> In Octets: 0
> In Packets: 0
> In Drop Packets: 0
> In Notifys: 0
> In P2 Exchanges: 0
> In P2 Exchange Invalids: 0
> In P2 Exchange Rejects: 0
> In P2 Sa Delete Requests: 0
> Out Octets: 0
> Out Packets: 0
> Out Drop Packets: 0
> Out Notifys: 0
> Out P2 Exchanges: 0
> Out P2 Exchange Invalids: 0
> Out P2 Exchange Rejects: 0
> Out P2 Sa Delete Requests: 0
> Initiator Tunnels: 0
> Initiator Fails: 0
> Responder Fails: 0
> System Capacity Fails: 0
> Auth Fails: 0
> Decrypt Fails: 0
> Hash Valid Fails: 0
> No Sa Fails: 0
> 
> Global IPSec over TCP Statistics
> --------------------------------
> Embryonic connections: 0
> Active connections: 0
> Previous connections: 0
> Inbound packets: 0
> Inbound dropped packets: 0
> Outbound packets: 0
> Outbound dropped packets: 0
> RST packets: 0
> Recevied ACK heart-beat packets: 0
> Bad headers: 0
> Bad trailers: 0
> Timer failures: 0
> Checksum errors: 0
> Internal errors: 0
> 
Community Member

Re: Site-to-site IPSec VPN configuration issues

I think you are missing nat exempt rules for private subnets on both cisco A and B.

Go to firewall and nat configuration and add them there. Then the tunnel will initiate.

Sent from Cisco Technical Support iPhone App

Please rate as helpful, if that would be the case. Thanx
188
Views
0
Helpful
2
Replies
CreatePlease to create content