Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Site to site VPN not working between ASA 5505 and 5510

I have an ASA 5505 and a 5510 that had a VPN connection working until the external ip address of the 5510 changed. I deleted the existing VPN connection on the 5505 and recrerated it with the new address of the 5510. I can see that the vpn lin is established, but the 5505 isn't transmitting any bytes. I looked in the Monitoring > VPN > VPN Statistics > Sessions and I see that the link is established and the bytes Rx is working, but the bytes Tx stays at 0 (this is on the 5505, on the 5510 there are no Bytes Rx, but there are bytes Tx). I don't think the problem is with the 5510, because that router has a vpn connection to another 5505 which is working fine.

Here is the config for the 5505 where the VPN isn't working: The VPN in question is the one with the ip address 207.229.xx.xx the other VPN (208.118.xx.xx is working, but is no longer needed)

Result of the command: "show running-config"

: Saved

:

ASA Version 8.2(1)

!

hostname 5505

enable password POgOWyKyb0jgJ1Hm encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.12.1 255.255.254.0

!

interface Vlan2

nameif outside

security-level 0

ip address dhcp setroute

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

boot system disk0:/asa821-k8.bin

ftp mode passive

access-list outside_1_cryptomap extended permit ip 192.168.12.0 255.255.254.0 192.168.2.0 255.255.254.0

access-list inside_nat0_outbound extended permit ip 192.168.12.0 255.255.254.0 192.168.2.0 255.255.254.0

access-list inside_nat0_outbound extended permit ip any 192.168.1.192 255.255.255.192

access-list inside_nat0_outbound extended permit ip 192.168.12.0 255.255.254.0 192.168.4.0 255.255.254.0

access-list outside_2_cryptomap extended permit ip 192.168.12.0 255.255.254.0 192.168.4.0 255.255.254.0

access-list outside_3_cryptomap extended permit ip 192.168.12.0 255.255.254.0 192.168.2.0 255.255.254.0

pager lines 24

logging asdm informational

mtu inside 1500

mtu outside 1500

ip local pool vpn_dhcp 192.168.1.200-192.168.1.250 mask 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-621.bin

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 0.0.0.0 0.0.0.0

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

dynamic-access-policy-record DfltAccessPolicy

http server enable 444

http 192.168.12.0 255.255.254.0 inside

http 0.0.0.0 0.0.0.0 outside

http 0.0.0.0 0.0.0.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map 1 match address outside_1_cryptomap

crypto map outside_map 1 set pfs group1

crypto map outside_map 1 set transform-set ESP-3DES-SHA

crypto map outside_map 2 match address outside_2_cryptomap

crypto map outside_map 2 set pfs group1

crypto map outside_map 2 set peer 208.118.xx.xx

crypto map outside_map 2 set transform-set ESP-3DES-SHA

crypto map outside_map 3 match address outside_3_cryptomap

crypto map outside_map 3 set pfs group1

crypto map outside_map 3 set peer 207.229.xx.xx

crypto map outside_map 3 set transform-set ESP-3DES-SHA

crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map interface outside

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

management-access inside

dhcpd auto_config outside

dhcpd update dns both

!

dhcpd address 192.168.12.100-192.168.12.254 inside

dhcpd auto_config outside interface inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

group-policy vpn internal

group-policy vpn attributes

vpn-tunnel-protocol IPSec

username admin password shbn5zbLkuHP/mJX encrypted privilege 15

username username password KqzErd5TLyODddx0 encrypted privilege 0

username username attributes

vpn-group-policy vpn

tunnel-group 2 type ipsec-l2l

tunnel-group 2 ipsec-attributes

pre-shared-key *

tunnel-group vpn type remote-access

tunnel-group vpn general-attributes

address-pool vpn_dhcp

default-group-policy vpn

tunnel-group vpn ipsec-attributes

pre-shared-key *

tunnel-group 208.118.xx.xxtype ipsec-l2l

tunnel-group 208.118.xx.xxipsec-attributes

pre-shared-key *

tunnel-group 207.229.xx.xxtype ipsec-l2l

tunnel-group 207.229.xx.xxipsec-attributes

pre-shared-key *

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

message-length maximum 512

policy-map global_policy

class inspection_default

inspect dns preset_dns_map

inspect ftp

inspect h323 h225

inspect h323 ras

inspect rsh

inspect rtsp

inspect esmtp

inspect sqlnet

inspect skinny

inspect sunrpc

inspect xdmcp

inspect sip

inspect netbios

inspect tftp

!

service-policy global_policy global

prompt hostname context

Cryptochecksum:351a84599ea1bfb2e23b8b4ca88618bc

: end

1 REPLY
New Member

Site to site VPN not working between ASA 5505 and 5510

Nevermind I got it. I deleted the site to site profile and and crypto map/acl entry associated with it then recreated the vpn profile and it is working now.

881
Views
0
Helpful
1
Replies
CreatePlease login to create content