Cisco Support Community
Community Member

Site-to-Site VPN Tunnel between ASA 5505 and router 3925


Trying for days to configure a site to site vpn between ASA 5505 and router 3925.

Any help is more than welcome.

Thank you!


All external ip was replaced.

ASA config:

: Saved
ASA Version 9.1(4)
hostname iceRTR
domain-name ice.***.ca
enable password ******* encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd ****** encrypted
interface Ethernet0/0
 switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
interface Vlan1
 nameif inside
 security-level 100
 ip address
interface Vlan2
 nameif outside
 security-level 0
 ip address
boot system disk0:/asa914-k8.bin
boot system disk0:/asa821-k8.bin
ftp mode passive
clock timezone EDT -4
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 domain-name ice.*****.ca
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj-
object-group network obj_any
access-list outbound extended permit ip any4
access-list outside_access_in extended permit ip any4
access-list outside_access_in extended permit ip any any
access-list 100 extended permit ip
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
object network obj-
 nat (inside,outside) dynamic interface
access-group outbound in interface inside
access-group outside_access_in in interface outside
router eigrp 500
 passive-interface outside
route outside 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
http server enable
http inside
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec ikev1 transform-set vps1TS esp-aes esp-sha-hmac
crypto ipsec security-association pmtu-aging infinite
crypto map outside-cmap 40 match address 100
crypto map outside-cmap 40 set peer
crypto map outside-cmap 40 set ikev1 transform-set vps1TS
crypto map outside-cmap interface outside
crypto ca trustpool policy
crypto ikev1 enable outside
crypto ikev1 policy 40
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 3600
telnet timeout 5
ssh outside
ssh timeout 30
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access outside
vpdn username ******@*****.ca password ***** store-local

dhcpd address inside
dhcpd dns interface inside
dhcpd lease 86400 interface inside
dhcpd domain ice.*****.ca interface inside
dhcpd enable inside
dhcpd address outside
dhcpd dns interface outside
dhcpd lease 86400 interface outside
dhcpd ping_timeout 60 interface outside
dhcpd enable outside
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
username admin password ******** encrypted privilege 15
tunnel-group type ipsec-l2l
tunnel-group ipsec-attributes
 ikev1 pre-shared-key *****
class-map inspection_default
 match default-inspection-traffic
policy-map type inspect dns preset_dns_map
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect pptp
  inspect ip-options
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
 profile CiscoTAC-1
  no active
  destination address http
  destination address email
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily



router config :

crypto isakmp policy 10
 encr aes
 authentication pre-share
 group 2
crypto isakmp key ****** address
crypto ipsec transform-set AES128-SHA esp-aes esp-sha-hmac
crypto map MAP1 10 ipsec-isakmp
 set peer
 set transform-set AES128-SHA
 match address 100


interface GigabitEthernet0/1
 ip address
 ip access-group ACL-IN2 in
 ip nat outside
 ip virtual-reassembly in
 duplex full
 speed 100
 media-type rj45
 no cdp enable
 no mop enabled
 crypto map MAP1

ip access-list extended ACL-IN2
 permit ip host any

*other rules


access-list 100 permit ip


VIP Purple

On The ASA you need to

  1. On The ASA you need to configure NAT-exemption. You have a NAT statement that NATs all traffic from to outside. With that you also NAT the traffic to the other side. In packet-tracer you should see that the source address get's NATted to the outside IP-address.
  2. On the router you have "ip nat outside" on the Gig0/1 but you don't show the NAT rules. Make sure that IPSec-traffic is also not NATted.
CreatePlease to create content