Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Site to Site VPN with ASA 5520 *please help*

I'm using two ASA 5520's and trying to set up a site-to-site VPN.  This looks to be fairly simple, but I'm on my third day of trying to get this up and running. Both 5520's are running the latest IOS 9.1(5).

Please note: I've substituted [#1-WAN IP] and [#2-WAN IP] for the ASA's WAN IP addresses.

Thanks in advance for any help you might have.

-------------------------------------------------------------------------------------------------------------------------------------------------

ASA 5520 # 1:

crypto ikev1 enable outside

object network net-local
subnet 10.0.0.0 255.255.255.0
 

object network net-remote
subnet 172.20.0.0 255.255.255.0
 

access-list outside_1_cryptomap permit ip object net-local object net-remote

tunnel-group [#2-WAN IP] type ipsec-l2l

tunnel-group [#2-WAN IP] ipsec-attributes
pre-shared-key cisco123
 

crypto ikev1 policy 10 
authentication pre-share
encrypt 3des
hash sha
group 2
lifetime 86400
 

crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto map oustide_map 1 match address outside_1_cryptomap
crypto map oustide_map 1 set ikev1 transform-set ESP-3DES-SHA
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer [#2-WAN IP]
crypto map outside_map interface outside

nat (inside,outside) 1 source static net-local net-local destination static net-remote net-remote

 

-------------------------------------------------------------------------------------------------------------------------------------------------


ASA 5520 #2:

crypto ikev1 enable outside

object network net-local
subnet 172.20.0.0 255.255.255.0
 

object network net-remote
subnet 10.0.0.0 255.255.255.0
 

access-list outside_1_cryptomap permit ip object net-local object net-remote

tunnel-group [#1-WAN IP] type ipsec-l2l

tunnel-group [#1-WAN IP] ipsec-attributes
pre-shared-key cisco123
 

crypto ikev1 policy 10 
authentication pre-share
encrypt 3des
hash sha
group 2
lifetime 86400
 

crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto map oustide_map 1 match address outside_1_cryptomap
crypto map oustide_map 1 set ikev1 transform-set ESP-3DES-SHA
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer [#1-WAN IP]
crypto map outside_map interface outside

nat (inside,outside) 1 source static net-local net-local destination static net-remote net-remote

 

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Try correcting the typos in

Try correcting the typos in both configs.

In a couple places you have "oustide_map" where you need "outside_map".

24 REPLIES
Bronze

Hi,it seems your ipsec

Hi,

it seems your ipsec configuration is correct so question is what do you see in logs and if rest of ASA configuration is correct.

Could you please post whole config of ASA boxes and also output of debug crypto isakmp ?

Best regards,

Jan

New Member

#1 ASA----------------------

#1 ASA

-----------------------

DTI-HQ# sh run
: Saved
:
ASA Version 9.1(5)
!
hostname DTI-HQ
enable password 0J5AMi9XdmSR5cxE encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd 0J5AMi9XdmSR5cxE encrypted
names
!
interface GigabitEthernet0/0
 nameif outside
 security-level 0
 ip address [#1-WAN IP] 255.255.255.248
!
interface GigabitEthernet0/1
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 nameif inside
 security-level 100
 ip address 10.0.0.40 255.255.255.0
!
interface Management0/0
 shutdown
 no nameif
 no security-level
 no ip address
!
ftp mode passive
object network OBJ_GENERIC_ALL
 subnet 0.0.0.0 0.0.0.0
object network net-local
 subnet 10.0.0.0 255.255.255.0
object network net-remote
 subnet 172.20.0.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip object net-local object net-remote
pager lines 24
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static net-local net-local destination static net-remote net-remote
nat (inside,outside) source dynamic OBJ_GENERIC_ALL interface
route outside 0.0.0.0 0.0.0.0 [#1-WAN GATEWAY]
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 10.0.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association pmtu-aging infinite
crypto map oustide_map 1 match address outside_1_cryptomap
crypto map oustide_map 1 set ikev1 transform-set ESP-3DES-SHA
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer [#2-WAN IP]
crypto map outside_map interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca trustpool policy
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 10.0.0.0 255.255.255.0 inside
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
tunnel-group [#2-WAN IP] type ipsec-l2l
tunnel-group [#2-WAN IP] ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect ip-options
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:cbfd0dba3bd9adf6ff9ae7510234a1d0
: end

 

New Member

#2 ASA-----------------------

#2 ASA

--------------------------

ASA Version 9.1(5)
!
hostname DTI-EQ
enable password 0J5AMi9XdmSR5cxE encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd 0J5AMi9XdmSR5cxE encrypted
names
!
interface GigabitEthernet0/0
 nameif outside
 security-level 0
 ip address [#2-WAN IP] 255.255.255.224
!
interface GigabitEthernet0/1
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 nameif inside
 security-level 100
 ip address 172.20.0.40 255.255.255.0
!
interface Management0/0
 shutdown
 no nameif
 no security-level
 no ip address
!
ftp mode passive
object network OBJ_GENERIC_ALL
 subnet 0.0.0.0 0.0.0.0
object network net-local
 subnet 172.20.0.0 255.255.255.0
object network net-remote
 subnet 10.0.0.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip object net-local object net-remote
pager lines 24
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-721.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static net-local net-local destination static net-remote net-remote
nat (inside,outside) source dynamic OBJ_GENERIC_ALL interface
route outside 0.0.0.0 0.0.0.0 [#2-GATEWAY IP] 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 172.20.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association pmtu-aging infinite
crypto map oustide_map 1 match address outside_1_cryptomap
crypto map oustide_map 1 set ikev1 transform-set ESP-3DES-SHA
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer [#1-WAN IP]
crypto map outside_map interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca trustpool policy
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 172.20.0.0 255.255.255.0 inside
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection statistics
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
tunnel-group [#1-WAN IP] type ipsec-l2l
tunnel-group [#1-WAN IP] ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect ip-options
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
 class class-default
  user-statistics accounting
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
hpm topN enable
Cryptochecksum:a49eb3d0c262b6c233884a1d323a6f7f
: end

New Member

Hi Jan, Thank you kindly for

Hi Jan, Thank you kindly for looking at my config and for your response. I've posted the two configs below, but for ease, I'm going to tell you what I've put on these two firewalls, because they are in a test environment right now and barely configured. Admittedly, this is my first time using this hardware, though I've worked plenty with cisco routers and in the old days, PIX. Subesquently, my mistake will probably be blatant.

 

Each router has the default config plus the following:

int gig0/0 
ip address [WAN IP] 255.255.255.248
nameif outside
no shut
exit


int gig0/3
ip address [LAN IP] 255.255.255.0
nameif inside
no shut
exit

route outside 0 0 [WAN GATEWAY]

object network OBJ_GENERIC_ALL 
 subnet 0.0.0.0 0.0.0.0
exit

nat (inside,outside) source dynamic OBJ_GENERIC_ALL interface


telnet 10.0.0.0 255.255.255.0 inside
password [password]
enable password [password]


http server enable
http 10.0.0.0 255.255.255.0 inside

Hall of Fame Super Silver

So how are you testing the

So how are you testing the VPN? The best way is to send "interesting" traffic from a host a one end to a host at the other end.

When you do that, please capture and share the output of "show crypto isa sa" and "show crypto ipsec sa" .

Additional step, as noted, would be to turn on debug - "debug crypto isa 7" is a good start.

New Member

I've tried sh crypto isa sa

I've tried sh crypto isa sa and ipsec sa. See below:

 

DTI-EQ# sh crypto isa sa

There are no IKEv1 SAs

There are no IKEv2 SAs
DTI-EQ# sh crypto ipsec sa

There are no ipsec sas
DTI-EQ#

 

Turning on "debug crypto isa 7" resulted in some interesting messages:

May 12 04:31:22 [IKEv1]IKE Receiver: device udp/localized/2/4500 successfully opened

May 12 04:31:22 [IKEv1]IKE Receiver: device udp/localized/v6/2/4500 successfully opened
May 12 04:31:22 [IKEv1]Ignoring msg to mark SA with specified coordinates <oustide_map, 1> dead
May 12 04:31:22 [IKEv1]Ignoring msg to mark SA with specified coordinates <oustide_map, 1> dead
May 12 04:31:22 [IKEv1]Ignoring msg to mark SA with specified coordinates <outside_map, 1> dead
May 12 04:31:22 [IKEv1]Ignoring msg to mark SA with specified coordinates <outside_map, 1> dead

Hall of Fame Super Silver

Try correcting the typos in

Try correcting the typos in both configs.

In a couple places you have "oustide_map" where you need "outside_map".

New Member

gosh, if this is the only

gosh, if this is the only problem, I'll be glad I didn't throw my monitor out the window last night...

New Member

I fixed these type-o's May 12

I fixed these type-o's

 

May 12 12:03:12 [IKEv1]Ignoring msg to mark SA with specified coordinates <outside_map, 1> dead
May 12 12:03:12 [IKEv1]Ignoring msg to mark SA with specified coordinates <outside_map, 1> dead
May 12 12:03:12 [IKEv1]Ignoring msg to mark SA with specified coordinates <outside_map, 1> dead
May 12 12:03:12 [IKEv1]Ignoring msg to mark SA with specified coordinates <outside_map, 1> dead

 

 

Hall of Fame Super Silver

Verifying basics - both

Verifying basics - both outside interfaces are up and able to reach other (ping) via the configured default routes, yes?

New Member

Yes sir, they can reach each

Yes sir, they can reach each other (ping) and computers that are on those networks can reach the internet.

I tried pinging from a computer on each side to each other as well as to the other end's inside interfaces with no luck.

Hall of Fame Super Silver

Now that you've fixed the map

Now that you've fixed the map references, it wouldn't hurt to remove and reapply it to the outside interface:

     conf t

     no crypto map outside_map interface outside

     crypto map outside_map interface outside

     end

Can you also try (on dti-hq):

     packet-tracer input inside tcp 10.0.0.41 1024 172.20.0.41 23

That will show us how the ASA would theoretically treat tcp traffic from hq to eq

New Member

Interesting. I did the packet


DTI-HQ# packet-tracer input inside tcp 10.0.0.41 1024 172.20.0.41 23

Phase: 1
Type: UN-NAT
Subtype: static
Result: ALLOW
Config:
nat (inside,outside) source static net-local net-local destination static net-remote net-remote
Additional Information:
NAT divert to egress interface outside
Untranslate 172.20.0.41/23 to 172.20.0.41/23

Phase: 2
Type: NAT
Subtype:
Result: ALLOW
Config:
nat (inside,outside) source static net-local net-local destination static net-remote net-remote
Additional Information:
Static translate 10.0.0.41/1024 to 10.0.0.41/1024

Phase: 3
Type: NAT
Subtype: per-session
Result: ALLOW
Config:
<--- More --->May 12 14:27:05 [IKEv1 DEBUG]Pitcher: received a key acquire message, spi 0x0
May 12 14:27:05 [IKEv1]IP = 66.23.138.230, IKE Initiator: New Phase 1, Intf inside, IKE Peer 66.23.138.230  local Proxy Address 10.0.0.0, remote Proxy Address 172.20.0.0,  Crypto map (outside_map)
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing ISAKMP SA payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing NAT-Traversal VID ver 02 payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing NAT-Traversal VID ver 03 payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing NAT-Traversal VID ver RFC payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing Fragmentation VID + extended capabilities payload
May 12 14:27:05 [IKEv1]IP = 66.23.138.230, IKE_DECODE SENDING Message (msgid=0) with payloads : HDR + SA (1) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 168
May 12 14:27:05 [IKEv1]IKE Receiver: Packet received on 50.246.85.10:500 from 66.23.138.230:500
May 12 14:27:05 [IKEv1]IP = 66.23.138.230, IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + SA (1) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 128
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, processing SA payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, Oakley proposal is acceptable
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, processing VID payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, Received NAT-Traversal RFC VID
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, processing VID payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, Received Fragmentation VID
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, IKE Peer included IKE fragmentation capability flags:  Main Mode:        True  Aggressive Mode:  True
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing ke payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing nonce payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing Cisco Unity VID payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing xauth V6 VID payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, Send IOS VID
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, Constructing ASA spoofing IOS Vendor ID payload (version: 1.0.0, capabilities: 20000001)
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing VID payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, Send Altiga/Cisco VPN3000/Cisco ASA GW VID
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing NAT-Discovery payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, computing NAT Discovery hash
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, constructing NAT-Discovery payload
May 12 14:27:05 [IKEv1 DEBUG]IP = 66.23.138.230, computing NAT Discovery hash
May 12 14:27:05 [IKEv1]IP = 66.23.138.230, IKE_DECODE SENDING Message (msgid=0) with payloads : HDR + KE (4) + NONCE (10) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NAT-D (20) + NAT-D (20) + NONE (0) total length : 304
May 12 14:27:13 [IKEv1]IP = 66.23.138.230, IKE_DECODE RESENDING Message (msgid=0) with payloads : HDR + KE (4) + NONCE (10) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NAT-D (20) + NAT-D (20) + NONE (0) total length : 304
May 12 14:27:13 [IKEv1]IKE Receiver: Packet received on 50.246.85.10:500 from 66.23.138.230:500
May 12 14:27:13 [IKEv1]IP = 66.23.138.230, IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + NOTIFY (11) + NONE (0) total length : 68
May 12 14:27:13 [IKEv1]IP = 66.23.138.230, IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + NOTIFY (11) + NONE (0) total length : 68
May 12 14:27:13 [IKEv1]IP = 66.23.138.230, Received an un-encrypted INVALID_COOKIE notify message, dropping
May 12 14:27:13 [IKEv1]IP = 66.23.138.230, Information Exchange processing failed
May 12 14:27:21 [IKEv1]IP = 66.23.138.230, IKE_DECODE RESENDING Message (msgid=0) with payloads : HDR + KE (4) + NONCE (10) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NAT-D (20) + NAT-D (20) + NONE (0) total length : 304
May 12 14:27:21 [IKEv1]IKE Receiver: Packet received on 50.246.85.10:500 from 66.23.138.230:500
May 12 14:27:21 [IKEv1]IP = 66.23.138.230, IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + NOTIFY (11) + NONE (0) total length : 68
May 12 14:27:21 [IKEv1]IP = 66.23.138.230, IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + NOTIFY (11) + NONE (0) total length : 68
May 12 14:27:21 [IKEv1]IP = 66.23.138.230, Received an un-encrypted INVALID_COOKIE notify message, dropping
May 12 14:27:21 [IKEv1]IP = 66.23.138.230, Information Exchange processing failed
May 12 14:27:29 [IKEv1]IP = 66.23.138.230, IKE_DECODE RESENDING Message (msgid=0) with payloads : HDR + KE (4) + NONCE (10) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NAT-D (20) + NAT-D (20) + NONE (0) total length : 304
May 12 14:27:29 [IKEv1]IKE Receiver: Packet received on 50.246.85.10:500 from 66.23.138.230:500
May 12 14:27:29 [IKEv1]IP = 66.23.138.230, IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + NOTIFY (11) + NONE (0) total length : 68
May 12 14:27:29 [IKEv1]IP = 66.23.138.230, IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + NOTIFY (11) + NONE (0) total length : 68
May 12 14:27:29 [IKEv1]IP = 66.23.138.230, Received an un-encrypted INVALID_COOKIE notify message, dropping
May 12 14:27:29 [IKEv1]IP = 66.23.138.230, Information Exchange processing failed
May 12 14:27:37 [IKEv1 DEBUG]IP = 66.23.138.230, IKE MM Initiator FSM error history (struct &0x750811d8)  <state>, <event>:  MM_DONE, EV_ERROR-->MM_WAIT_MSG4, EV_TIMEOUT-->MM_WAIT_MSG4, NullEvent-->MM_SND_MSG3, EV_SND_MSG-->MM_SND_MSG3, EV_START_TMR-->MM_SND_MSG3, EV_RESEND_MSG-->MM_WAIT_MSG4, EV_TIMEOUT-->MM_WAIT_MSG4, NullEvent
May 12 14:27:37 [IKEv1 DEBUG]IP = 66.23.138.230, IKE SA MM:9b24575b terminating:  flags 0x01000022, refcnt 0, tuncnt 0
May 12 14:27:37 [IKEv1 DEBUG]IP = 66.23.138.230, sending delete/delete with reason message
Additional Information:

Phase: 4
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:

Phase: 5
Type: VPN
Subtype: encrypt
Result: DROP
Config:
Additional Information:

Result:
input-interface: inside
input-status: up
input-line-status: up
output-interface: outside
output-status: up
output-line-status: up
Action: drop
Drop-reason: (acl-drop) Flow is denied by configured rule

Hall of Fame Super Silver

You do have the 3DES-AES

You do have the 3DES-AES license on both units, right?

sh activation-key | i 3DES

New Member

DTI-EQ# sh activation-key | i

DTI-EQ# sh activation-key | i 3DES
Encryption-3DES-AES               : Enabled        perpetual
DTI-EQ#

 

DTI-HQ# sh activation-key | i 3DES
Encryption-3DES-AES               : Enabled        perpetual
DTI-HQ#

 

Hall of Fame Super Silver

Can you run that packet

Can you run that packet-tracer once again with the "detailed" keyword? (You might want to "undebug all" first.)

New Member

Making some progress. The

Making some progress. The tunnel looks to be up!

Strange thing now, from the HQ side, I can not reach a shared folder on the EQ side.

I can on the other hand, reach a shared folder on the HQ from the EQ side.

 

Pings aren't going through either way from computers on each side's network.

 

Do I need to have an access list for icmp for the ping to respond?

 

--

 

DTI-HQ# sh crypto isa sa

IKEv1 SAs:

   Active SA: 1
    Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA during rekey)
Total IKE SA: 1

1   IKE Peer: 66.23.138.230
    Type    : L2L             Role    : initiator
    Rekey   : no              State   : MM_ACTIVE

There are no IKEv2 SAs
DTI-HQ# sh crypto ipsec sa
interface: outside
    Crypto map tag: outside_map, seq num: 1, local addr: 50.246.85.10

      access-list outside_1_cryptomap extended permit ip 10.0.0.0 255.255.255.0 172.20.0.0 255.255.255.0
      local ident (addr/mask/prot/port): (10.0.0.0/255.255.255.0/0/0)
      remote ident (addr/mask/prot/port): (172.20.0.0/255.255.255.0/0/0)
      current_peer: 66.23.138.230


      #pkts encaps: 56, #pkts encrypt: 56, #pkts digest: 56
      #pkts decaps: 51, #pkts decrypt: 51, #pkts verify: 51
      #pkts compressed: 0, #pkts decompressed: 0
      #pkts not compressed: 56, #pkts comp failed: 0, #pkts decomp failed: 0
      #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
      #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
      #TFC rcvd: 0, #TFC sent: 0
      #Valid ICMP Errors rcvd: 0, #Invalid ICMP Errors rcvd: 0
      #send errors: 0, #recv errors: 0

      local crypto endpt.: 50.246.85.10/0, remote crypto endpt.: 66.23.138.230/0
      path mtu 1500, ipsec overhead 58(36), media mtu 1500
      PMTU time remaining (sec): 0, DF policy: copy-df
      ICMP error validation: disabled, TFC packets: disabled
      current outbound spi: 59F3E112
      current inbound spi : E333B239

    inbound esp sas:
      spi: 0xE333B239 (3811815993)
         transform: esp-3des esp-sha-hmac no compression
         in use settings ={L2L, Tunnel, PFS Group 1, IKEv1, }
         slot: 0, conn_id: 4096, crypto-map: outside_map
         sa timing: remaining key lifetime (kB/sec): (3914991/28313)
         IV size: 8 bytes
         replay detection support: Y
         Anti replay bitmap:
          0x000FFFFF 0xFFFFFFFF
    outbound esp sas:
      spi: 0x59F3E112 (1509155090)
         transform: esp-3des esp-sha-hmac no compression
         in use settings ={L2L, Tunnel, PFS Group 1, IKEv1, }
         slot: 0, conn_id: 4096, crypto-map: outside_map
         sa timing: remaining key lifetime (kB/sec): (3914992/28313)
         IV size: 8 bytes
         replay detection support: Y
         Anti replay bitmap:
          0x00000000 0x00000001

DTI-HQ#

 

DTI-HQ# packet-tracer input inside tcp 10.0.0.41 1024 172.20.0.41 23

Phase: 1
Type: UN-NAT
Subtype: static
Result: ALLOW
Config:
nat (inside,outside) source static net-local net-local destination static net-remote net-remote
Additional Information:
NAT divert to egress interface outside
Untranslate 172.20.0.41/23 to 172.20.0.41/23

Phase: 2
Type: NAT
Subtype:
Result: ALLOW
Config:
nat (inside,outside) source static net-local net-local destination static net-remote net-remote
Additional Information:
Static translate 10.0.0.41/1024 to 10.0.0.41/1024

Phase: 3
Type: NAT
Subtype: per-session
Result: ALLOW
Config:
Additional Information:

Phase: 4
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:

Phase: 5
Type: VPN
Subtype: encrypt
Result: ALLOW
Config:
Additional Information:

Phase: 6
Type: NAT
Subtype: rpf-check
Result: ALLOW
Config:
nat (inside,outside) source static net-local net-local destination static net-remote net-remote
Additional Information:

Phase: 7
Type: VPN
Subtype: ipsec-tunnel-flow
Result: ALLOW
Config:
Additional Information:

Phase: 8
Type: NAT
Subtype: per-session
Result: ALLOW
Config:
Additional Information:

Phase: 9
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:

Phase: 10
Type: FLOW-CREATION
Subtype:
Result: ALLOW
Config:
Additional Information:
New flow created with id 21, packet dispatched to next module

Result:
input-interface: inside
input-status: up
input-line-status: up
output-interface: outside
output-status: up
output-line-status: up
Action: allow

Hall of Fame Super Silver

Cool! It may have been a

Cool! It may have been a combination of fixing the typos and then re-applying the maps and finally introducing interesting traffic.

As far as the remaining issue, can you try the packet-tracer again with the source and destinations addresses equal to the hosts you are testing with. That's a good tool that can be used to good effect to either a. show you why the ASA won't pass certain traffic or b. eliminate the ASA as the cause of the problem. You can run it at both ends with the source and destination roles reversed.

New Member

Yes, I'm going to do that

Yes, I'm going to do that right now!

 

I can ping from the EQ side to the HQ side, AND I can open a shared folder on the HQ side. 

 

The reverse still does not work. So frustrating.

New Member

When I try to ping from 10.0

When I try to ping from 10.0.0.200 to 172.20.0.16, it fails...but with the test  below, it seems that it should pass?

 

-

 

DTI-HQ# packet-tracer input inside tcp 10.0.0.200 1024 172.20.0.16 23

Phase: 1
Type: UN-NAT
Subtype: static
Result: ALLOW
Config:
nat (inside,outside) source static net-local net-local destination static net-remote net-remote
Additional Information:
NAT divert to egress interface outside
Untranslate 172.20.0.16/23 to 172.20.0.16/23

Phase: 2
Type: NAT
Subtype:
Result: ALLOW
Config:
nat (inside,outside) source static net-local net-local destination static net-remote net-remote
Additional Information:
Static translate 10.0.0.200/1024 to 10.0.0.200/1024

Phase: 3
Type: NAT
Subtype: per-session
Result: ALLOW
Config:
Additional Information:

Phase: 4
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:

Phase: 5
Type: VPN
Subtype: encrypt
Result: ALLOW
Config:
Additional Information:

Phase: 6
Type: NAT
Subtype: rpf-check
Result: ALLOW
Config:
nat (inside,outside) source static net-local net-local destination static net-remote net-remote
Additional Information:

Phase: 7
Type: VPN
Subtype: ipsec-tunnel-flow
Result: ALLOW
Config:
Additional Information:

Phase: 8
Type: NAT
Subtype: per-session
Result: ALLOW
Config:
Additional Information:

Phase: 9
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:

Phase: 10
Type: FLOW-CREATION
Subtype:
Result: ALLOW
Config:
Additional Information:
New flow created with id 335, packet dispatched to next module

Result:
input-interface: inside
input-status: up
input-line-status: up
output-interface: outside
output-status: up
output-line-status: up
Action: allow

Hall of Fame Super Silver

That syntax is for a tcp

That syntax is for a tcp connection on port 23 (ssh). Try this line instead:

     packet-tracer input inside icmp 10.0.0.200 0 0 172.20.0.40

New Member

So, I'm actually able to ping

So, I'm actually able to ping machine to machine, both ways.

 

The only problem left is, I can open a fileshare one direction, but not in the other.

 

Any suggestions?

Hall of Fame Super Silver

Nothing in the VPN setup

Nothing in the VPN setup should cause that remaining anomalous behavior. I would examine any host-based firewalls (or other intervening access-lists etc. in the network).

New Member

ok thank you SO MUCH for your

ok thank you SO MUCH for your help. I was really in the woods on this one.

1100
Views
0
Helpful
24
Replies
CreatePlease login to create content