Cisco Support Community
Community Member

Troubleshootng IPSec Site to Site VPN

Hi All, I recently purchased a new ASA5505 and have been having trouble creating a site to site VPN to another location/device.  I've used the VPN Site to Site wizard to configure the VPN but after the wizard completes how does one verify VPN connectivity via ASDM?  Also, I've run debug crypto IPSec and isakmp and see absolutely nothing?  So how does one verify that the VPN is up and if it is not, how does one troubleshoot why it is not?  The other side is configured and I had no trouble getting this same VPN working on an old Watchguard device.    ~Thanks

Everyone's tags (3)

Re: Troubleshootng IPSec Site to Site VPN

Try these shows commands.

sh crypto ipsec sa detail

show crypto ipsec sa

show crypto isakmp sa

copy your config on the forum.  I will exam it for you.


Community Member

Troubleshootng IPSec Site to Site VPN

Hi rizwanr74, all the sh crypto commands returned nothing?  Here is my current config (public IP's have been x'd out for privacy).  Let me know if you need more information.  btw, I can ping and the vpn peer address from the ASA.



ASA-01# sh run
ASA Version 8.2(5)
hostname ASA-01
enable password xxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxx encrypted
interface Ethernet0/0
switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
interface Vlan1
nameif inside
security-level 100
ip address
interface Vlan2
nameif outside
security-level 0
ip address x.x.x.x
ftp mode passive
dns server-group DefaultDNS
access-list outside_1_cryptomap extended permit ip
access-list inside_nat0_outbound extended permit ip
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1
route outside x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer x.x.x.x
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
tunnel-group x.x.x.x type ipsec-l2l
tunnel-group x.x.x.x ipsec-attributes
pre-shared-key *********
class-map inspection_default
match default-inspection-traffic
policy-map type inspect dns preset_dns_map
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
: end

Troubleshootng IPSec Site to Site VPN

Hi David,

Please remove this line highlighted

crypto map outside_map 1 set pfs group1

Please add this line higlighted below.

route outside x.x.x.x <<-- x is your Firewall defautl gateway.

Please initiate the traffic from inside your network to destination and use those above show commands to see whether tunnel is up nor not.

Please let me know the status.


Rizwan Rafeek

Cisco Employee

Troubleshootng IPSec Site to Site VPN


Your config looks good.

ASDM doesn't allow you to automatically initiate a VPN tunnel - the ASA has to see interesting traffic and decide to encrypt it.  This is different then many vendors that will just automatically initiate a tunnel (like watchguard).

Try the following from the command line on the ASA

ping inside

This should, in theory, initiate the VPN tunnel from the ASA.  The other thing you can try is from a host on the inside network, ping anything on the 10.10.0.x network (making sure that network is routed to the ASA) - and that should initiate the tunnel as well.

At that point, it should initiate the VPN tunnel - and if you match the other side it should come up.  Make sure you have 'debug crypto isakmp 8' on and if you see debugs you know the tunnel is at least initiating.


CreatePlease to create content