Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

VLAN/s on ASA5510

Hello guys,

I have problem setting up VLAN/s on ASA5510. I downloaded the command reference for my current version (7.2)of ASA OS but no one of the commands worked on my device. The license is Security Plus so there are no license restrictions.

Do I have to pre-configure something on the ASA or is there any way to enable the switching module in the ASA?? My task is to configure Trunk between one of the physical ports on the ASA and 2960 switch to carry multiple VLAN/s.

Any help will be highly appreciated.

rvr

1 ACCEPTED SOLUTION

Accepted Solutions

Re: VLAN/s on ASA5510

Here is an example of trunking configuration on the ASA:

interface GigabitEthernet0/1

description "Trunk Connectivity with switch"

speed 100

duplex full

no nameif

no security-level

no ip address

!

interface GigabitEthernet0/1.100

vlan 100

nameif DMZ0

security-level 80

ip address 10.0.0.1 255.255.255.0

!

interface GigabitEthernet0/1.101

vlan 101

nameif DMZ1

security-level 81

ip address 10.1.0.1 255.255.255.0

No special trunking commands there.

Please rate if this helped.

Regards,

Daniel

3 REPLIES

Re: VLAN/s on ASA5510

Here is an example of trunking configuration on the ASA:

interface GigabitEthernet0/1

description "Trunk Connectivity with switch"

speed 100

duplex full

no nameif

no security-level

no ip address

!

interface GigabitEthernet0/1.100

vlan 100

nameif DMZ0

security-level 80

ip address 10.0.0.1 255.255.255.0

!

interface GigabitEthernet0/1.101

vlan 101

nameif DMZ1

security-level 81

ip address 10.1.0.1 255.255.255.0

No special trunking commands there.

Please rate if this helped.

Regards,

Daniel

Community Member

Re: VLAN/s on ASA5510

Thanks, great,

rvr

Community Member

Re: VLAN/s on ASA5510

I created the VlANs, created the trunk on the switch too but the PIX doesnt send any traffic over. Created VLAN 1, 2, 3 on both devices but cannot ping the PIX from the Switch (SVI Interfaces) and vise versa. The trunk port on the switch says trunking is OK.

162
Views
4
Helpful
3
Replies
CreatePlease to create content