Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VPN Client over PSTN dialup and PPP session pb

Hello

Here is my pb : a Microsoft PC connects trough the PSTN to the router (via the aux port). The PPP connection succeeds.

Then, we establish the VPN tunnel with the same router (using Cisco VPN Client). The tunnel is established successfully.

After the VPN tunnel is up, we can only ping the async interface. No telnet is possible and the command 'sh crypto ipsec sa' shows that packets are decrypted but no packets are encrypted.

Could you see if there is something wrong in my configuration :

version 12.3

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no network-clock-participate slot 1

aaa new-model

!

!

aaa authentication login userauthen local

aaa authorization network groupauthor local

aaa session-id common

ip subnet-zero

!

!

ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

username test password 0 test

username xxx password xxx

!

!

!

crypto isakmp policy 3

encr aes

authentication pre-share

group 2

!

crypto isakmp client configuration group vpnclient

key cisco123

domain amenbank.com

pool vpnpool

!

!

crypto ipsec transform-set myset esp-aes esp-sha-hmac

!

crypto dynamic-map dynmap 10

set transform-set myset

!

!

crypto map clientmap client authentication list userauthen

crypto map clientmap isakmp authorization list groupauthor

crypto map clientmap client configuration address respond

crypto map clientmap 10 ipsec-isakmp dynamic dynmap

!

!

!

!

interface Loopback0

ip address 172.20.8.1 255.255.255.0

!

interface FastEthernet0/0

ip address 9.101.x.x.255.255.0

duplex auto

speed auto

crypto map clientmap

!

interface Serial0/0

no ip address

shutdown

clock rate 2000000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 125000

!

interface Serial0/2

no ip address

shutdown

clock rate 125000

!

interface Async97

ip unnumbered Loopback0

encapsulation ppp

async mode dedicated

peer default ip address 172.20.8.200

ppp authentication pap chap callin

crypto map clientmap

!

ip local pool acces_distant 172.20.8.200 172.20.8.250

ip local pool vpnpool 1.1.1.1 1.1.1.10

ip http server

no ip http secure-server

ip classless

!

!

!

!

!

!

!

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

modem InOut

modem autoconfigure discovery

autoselect ppp

speed 115200

flowcontrol hardware

line vty 0 4

password cisco

!

end

2 REPLIES
New Member

Re: VPN Client over PSTN dialup and PPP session pb

Another thing :

When I tried to establish the VPN from the FastEthernet Interface, it worked properly with packets encrypted and decrypted.

New Member

Re: VPN Client over PSTN dialup and PPP session pb

Hello

I added a route to the vpn group through the async interface and it's ok.

Thank you anyway.

338
Views
0
Helpful
2
Replies
CreatePlease to create content