Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VPN on ASA 5505

I have set up site-site VPN on 5505s on 2 sites.

I can ping outside interfaces from both sites but cannot get replies when I ping clients behind the 5505 from the ASA itself. I have also tried to ping from 10.x.x.x to 217.41.x.x and to 192.168..x.x but do not get a response.

 

I was expecting the configuration to be enough but there might be something I am missing.

 

See configs attached.

6 REPLIES

VPN on ASA 5505

eHi,

Please make the following changes:

hostname Romford

access-list inside_access_in extended permit ip 192.168.1.0 255.255.255.0 any

!
access-group inside_access_in in interface inside

!

access-list nonat_inside extended permit ip 192.168.1.0 255.255.255.0 10.0.0.0 255.255.255.0
!
nat (inside) 0 access-list nonat_inside
!
no crypto isakmp policy 1
!
crypto isakmp policy 10
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400

###############################################################

hostname Brentwood

object network obj_10.0.0.0-24
subnet 10.0.0.0 255.255.255.0
!
object network obj_192.168.1.0-24
subnet 192.168.1.0 255.255.255.0
!
access-list inside_access_in extended permit ip 10.0.0.0 255.255.255.0 any
no access-list inside_access_in extended permit icmp object RomfordASA interface inside
!
nat (inside,outside) 1 source static obj_10.0.0.0-24 obj_10.0.0.0-24 destination static obj_192.168.1.0-24 obj_192.168.1.0-24 no-proxy-arp route-lookup
!
no crypto ikev1 policy 1
!
crypto ikev1 policy 10
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400

HTH.

Portu.

New Member

VPN on ASA 5505

Portu,

Thanks for r feedback. I have made entries recommended.

At the moment, I cannot ping positively from either ASA to client connected to inside interface of ASA. I will not be able to ping from client until I am onsite tomorrow.

Is there a way I can test connectivity remotely from either ASAs from CLI?

Brentwood#

Brentwood#

Brentwood#

Brentwood# sh run

: Saved

:

ASA Version 8.4(4)1

!

hostname Brentwood

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 10.0.0.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

pppoe client vpdn group Brentwood

ip address pppoe setroute

!

ftp mode passive

object network obj_any

subnet 0.0.0.0 0.0.0.0

object network RomfordASA

host 217.41.x.x

object network obj_10.0.0.0-24

subnet 10.0.0.0 255.255.255.0

object network obj_192.168.1.0-24

subnet 192.168.1.0 255.255.255.0

access-list Brentwood_Romford extended permit ip 10.0.0.0 255.255.255.0 192.168.1.0 255.255.255.0

access-list inside_access_in extended permit ip 10.0.0.0 255.255.255.0 any

pager lines 24

logging enable

logging asdm informational

mtu outside 1500

mtu inside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

nat (inside,outside) source static obj_10.0.0.0-24 obj_10.0.0.0-24 destination static obj_192.168.1.0-24 obj_192.168.1.0-24 no-proxy-arp route-lookup

!

object network obj_any

nat (inside,outside) dynamic interface

access-group inside_access_in in interface inside

timeout xlate 3:00:00

timeout pat-xlate 0:00:30

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

http server enable

http 10.0.0.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

crypto ipsec ikev1 transform-set Brentwood esp-3des esp-sha-hmac

crypto map Brentwoodmap 1 match address Brentwood_Romford

crypto map Brentwoodmap 1 set peer 217.41.x.x

crypto map Brentwoodmap 1 set ikev1 transform-set Brentwood

crypto map Brentwoodmap interface outside

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130

    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117

    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b

    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504

    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72

    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56

    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043

    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31

    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b

    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20

    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65

    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420

    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329

    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365

    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7

    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597

    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10

    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc

    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845

    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8

    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced

    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f

    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201

    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868

    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101

    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8

    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777

    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a

    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406

    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973

    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403

    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969

    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b

    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973

    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30

    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603

    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355

    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80

    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e

    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a

    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16

    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0

    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8

    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28

    6c2527b9 deb78458 c61f381e a4c4cb66

  quit

crypto ikev1 enable outside

crypto ikev1 policy 10

authentication pre-share

encryption aes

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh timeout 5

ssh key-exchange group dh-group1-sha1

console timeout 0

vpdn group Romford request dialout pppoe

vpdn group Romford localname D173742@hg52.btclick.com

vpdn group Romford ppp authentication chap

vpdn group Brentwood request dialout pppoe

vpdn group Brentwood localname D173687@hg29.btclick.com

vpdn group Brentwood ppp authentication chap

vpdn username D173687@hg29.btclick.com password ***** store-local

dhcpd auto_config outside

!

dhcpd address 10.0.0.5-10.0.0.36 inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

username cctv password nTRDXh8W8tr9whEd encrypted

tunnel-group 217.41.x.x type ipsec-l2l

tunnel-group 217.41.x.x ipsec-attributes

ikev1 pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny

  inspect sunrpc

  inspect xdmcp

  inspect sip

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

call-home reporting anonymous

Cryptochecksum:6833cdea22b5e4889bb521086789df00

: end

Brentwood#

 

Romford# sh run

: Saved

:

ASA Version 8.2(1)

!

hostname Romford

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.1.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

pppoe client vpdn group Romford

ip address pppoe setroute

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

ftp mode passive

access-list Romford_Brentwood extended permit ip 192.168.1.0 255.255.255.0 10.0.0.0 255.255.255.0

access-list BrentwoodASA extended permit ip host 81.130.x.x 192.168.1.0 255.255.255.0

access-list inside_access_in extended permit ip 192.168.1.0 255.255.255.0 any

access-list nonat_inside extended permit ip 192.168.1.0 255.255.255.0 10.0.0.0 255.255.255.0

pager lines 24

logging asdm informational

mtu outside 1500

mtu inside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list nonat_inside

nat (inside) 1 0.0.0.0 0.0.0.0

access-group inside_access_in in interface inside

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set Romford esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto map Romfordmap 1 match address Romford_Brentwood

crypto map Romfordmap 1 set peer 81.130.x.x

crypto map Romdordmap 1 match address Romford_Brentwood

crypto map Romdordmap 1 set peer 81.130.x.x

crypto map Romdordmap interface outside

crypto map Romdord 1 set transform-set Romford

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption aes

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

vpdn group Romford request dialout pppoe

vpdn group Romford localname D173742@hg52.btclick.com

vpdn group Romford ppp authentication chap

vpdn username D173742@hg52.btclick.com password ********* store-local

dhcpd auto_config outside

!

dhcpd address 192.168.1.5-192.168.1.36 inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

tunnel-group 81.130.x.x type ipsec-l2l

tunnel-group 81.130.x.x                                      ipsec-attributes

pre-shared-key *

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny

  inspect sunrpc

  inspect xdmcp

  inspect sip

  inspect netbios

  inspect tftp

!

service-policy global_policy global

prompt hostname context

Cryptochecksum:75b003c984d1397e6788bf06f5b1420b

: end

Romford#

VPN on ASA 5505

Hi

Sure thing, add the "management-access inside" command on both ASA and test as following:

ping inside 192.168.1.1

ping inside 10.0.0.1

Let me know how it goes.

HTH.

Portu.

New Member

VPN on ASA 5505

no response so far...

Romford# conf t

Romford(config)# mana

Romford(config)# management-access

Romford(config)# management-access ?

configure mode commands/options:

Current available interface(s):

  inside   Name of interface Vlan1

  outside  Name of interface Vlan2

Romford(config)# management-access in

Romford(config)# management-access inside ?

configure mode commands/options:

 

Romford(config)# management-access inside

Romford(config)# wr

Building configuration...

Cryptochecksum: dbf444b9 a4bc301e 1f07fef3 5c7788e2

3663 bytes copied in 1.480 secs (3663 bytes/sec)

[OK]

Romford(config)# ping in

Romford(config)# ping inside ?

exec mode commands/options:

  Hostname or A.B.C.D     Ping destination IPv4 address or hostname

  Hostname or X:X:X:X::X  Ping destination IPv6 address or hostname

 

Romford(config)# ping inside 10.0.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:

?????

Success rate is 0 percent (0/5)

Romford(config)# ping inside 10.0.0.5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.5, timeout is 2 seconds:

?????

Success rate is 0 percent (0/5)

Romford(config)# ping inside 10.0.0.5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.5, timeout is 2 seconds:

?????

Success rate is 0 percent (0/5)

Romford(config)#

Brentwood# conf t

Brentwood(config)# ma

Brentwood(config)# man

Brentwood(config)# management-access ?

configure mode commands/options:

Current available interface(s):

  inside   Name of interface Vlan1

  outside  Name of interface Vlan2

Brentwood(config)# management-access in

Brentwood(config)# management-access inside

Brentwood(config)# wr

Building configuration...

Cryptochecksum: 578d8c0f 3ac61d4b efb4f168 9b66aaa6

7964 bytes copied in 1.30 secs (7964 bytes/sec)

[OK]

Brentwood(config)# ping 192.168.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

?????

Success rate is 0 percent (0/5)

Brentwood(config)# ping 192.168.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

?????

Success rate is 0 percent (0/5)

Brentwood(config)# ping inside 192.168.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

?????

Success rate is 0 percent (0/5)

Brentwood(config)# ping inside 192.168.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

?????

Success rate is 0 percent (0/5)

Brentwood(config)# ping 10.0.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Brentwood(config)#

New Member

Re: VPN on ASA 5505

Portu,

transform-set entry was missing from Romford config .. I noticed it from ASDM..

The tunnels are up and running, thanks for your support.

Cisco rules!!!

Sent from Cisco Technical Support iPhone App

Re: VPN on ASA 5505

Excellent job!!

Please rate any helpful posts

279
Views
10
Helpful
6
Replies