Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

VPN users access to DMZ area

3 REPLIES
New Member

Re: VPN users access to DMZ area

I have a PIX515 with three ethernet ports. 1 for internal LAN, 1 for Internet Access and 1 for DMZ.

How do I allow my VPN users access to my DMZ? I need the VPN users to be able to access the hosts using terminal services but I do not want them to be able to do it from the internet, only when they are VPN connected.

My internal number is 10.100.10.XXX

MY DMZ is 192.168.10.XXX

and my internet is 203.216.26.XXX

Currently my VPN users can access everything on my local LAN but not the DMZ but my local LAN users do have access to the DMZ.

I will incluse some of my config to help everyone out. I think I need either another access-list or static statements or both.

names

name 192.168.10.1 brcawel-ws02

name 192.168.10.2 trended

access-list 100 permit ip 10.100.10.0 255.255.240.0 10.108.135.0 255.255.255.0

access-list 80 permit ip 10.100.10.0 255.255.240.0 10.108.135.0 255.255.255.0

access-list www permit tcp any host 203.216.26.01 eq www

access-list www permit icmp any any echo-reply

access-list www permit icmp any any source-quench

access-list www permit icmp any any unreachable

access-list www permit icmp any any time-exceeded

access-list www permit tcp any host 203.x.x.02 eq www

pager lines 24

logging on

icmp deny any outside

icmp permit any inside

mtu outside 1500

mtu inside 1500

mtu dmz 1500

ip address outside 203.x.x.x.x.255.248

ip address inside 10.100.10.01 255.255.255.0

ip address dmz 192.x.x.x.255.255.0

ip audit info action alarm

ip audit attack action alarm

ip local pool dealer 10.108.135.1-10.108.135.99

no failover

failover timeout 0:00:00

failover poll 15

no failover ip address outside

no failover ip address inside

no failover ip address dmz

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 80

nat (dmz) 1 192.168.10.0 255.255.255.0 0 0

static (inside,dmz) 10.100.10.0 10.100.10.0 netmask 255.255.240.0 0 0

static (dmz,outside) 203.x.x.01 brcawel-ws02 netmask 255.255.255.255 0 0

static (dmz,outside) 203.x.x.02 trended netmask 255.255.255.255 0 0

access-group www in interface outside

access-group 120 in interface dmz

route outside 0.0.0.0 0.0.x.x.x.84.25 1

route inside 10.100.10.0 255.255.240.0 10.100.10.10 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-3des esp-md5-hmac

crypto dynamic-map cisco 10 set transform-set myset

crypto map dyn-map 20 ipsec-isakmp dynamic cisco

crypto map BasicVPN 20 ipsec-isakmp dynamic cisco

crypto map BasicVPN client configuration address initiate

crypto map BasicVPN client configuration address respond

crypto map BasicVPN interface outside

isakmp enable outside

isakmp key address 0.0.0.0 netmask 0.0.0.0

isakmp key address 203.x.x.200 netmask 255.255.255.255 no-xauth no-config-mode

isakmp policy 5 authentication pre-share

isakmp policy 5 encryption 3des

isakmp policy 5 hash md5

isakmp policy 5 group 2

isakmp policy 5 lifetime 86400

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption 3des

isakmp policy 10 hash md5

isakmp policy 10 group 1

isakmp policy 10 lifetime 1000

vpngroup basicteam address-pool dealer

vpngroup basicteam wins-server 10.100.10.26

vpngroup basicteam default-domain boschrexroth.ca

vpngroup basicteam split-tunnel 100

vpngroup basicteam idle-time 1800

vpngroup basicteam password xxxxx

Cryptochecksum:xxxxx

: end

New Member

Re: VPN users access to DMZ area

Try adding:

access-list 100 permit ip 192.168.10.0 255.255.255.0 10.108.135.0 255.255.255.0

New Member

Re: VPN users access to DMZ area

I think this was part of it.

I was looking at some sample configs and tried to add in a nonat access list and nat statement (see below) and now I have access to my DMZ.

access-list nonatdmz permit ip 192.168.10.0 255.255.255.0 10.108.135.0 255.255.255.0

nat (dmz) 0 access-list nonatdmz

Does this make sense.

Thanks.

177
Views
0
Helpful
3
Replies
CreatePlease to create content