Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WebVPN (5510 ASA) "no cookies" when accessing Citrix Web Interface 5.4

Our WebVPN was set up when we were running Citrix Web Interface 4.5.1. Recently we upgraded to Web Interface 5.4 and have been experiencing issues when it performs client detection stating "no cookies".

My research has shed some light on this and it looks like it is occuring when citrix performs a silentdetection for available clients; this involves testing cookies. I've monitored my browser's cookies at the time it runs and a cookie is created but it appears the data is not what citrix is expecting and thusly fails this check, dumping me to the "no cookies" page.

My reason for assuming it's to do with the ASA config is it worked on 4.5 through WebVPN and 5.4 works when directly accessing the site locally. I've read some articles pertaining to other clientless VPN portals that have circumvented this by performing custom rewrites but nothing referencing how with Cisco WebVPN.

Citrix is set to Direct connection so it isn't to do with the unsupported secure Citrix access methods. I've also tried the usual; clear all browser caches, add as trusted site with low security, allow all cookies, enable pop ups etc to no avail.

I will do my best to supply any additional information. Any ideas?

Thanks

589
Views
0
Helpful
0
Replies
CreatePlease login to create content