Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Windows 10 Preview - SSL VPN Client

I know the official answer will be it's not supported... but here's the issue.

 

Installed Cisco AnyConnect client  v3.1.05182 on Windows 10 Preview. It installs just fine and the service is started. However, when attempting to connect we receive the error "Failed to initialize connection subsystem." And in the system logs we get..

Function: ConnectMgr::doConnectIfcConnect

File: .\ConnectMgr.cpp

Line: 1937

Invoked Function: ConnectMgr::getConnectIfc

Return Code: -29622267 (0xFE3C0005)

Description: CONNECTMGR_ERROR_NULL_POINTER

 

Any help with ideas/known resolutions would be great. We're suppose to evaluate this release for testing by Friday. I know quick.... :( 

Found an additional error....

Function: CTransportWinHttp::clearSSLCache

File: .\CTransportWinHttp.cpp

Line: 1784

Invoked Function: SslEmptyCache

Return Code: 13 (0x0000000D)

Description: WINDOWS_ERROR_CODE

The error code above comes out to be MSG_E_CANNOT_GET_KEY_PROVIDER 

 

AND

Function: CTransportWinHttp::InitTransport

File: .\CTransportWinHttp.cpp

Line: 284

Invoked Function: CTransportWinHttp::clearSSLCache

Return Code: -30015447 (0xFE360029)

Description: CTRANSPORT_ERROR_SSL_EMPTY_CACHE

 

Everyone's tags (2)
20 REPLIES
Silver

Windows 10 is just a new

Windows 10 is just a new release.
Cisco will for sure release an anyconnect software that will support win10 but as of now, it does not

With regards to your problems, well highly likely we cannot fix it, but just wait for a few weeks hopefully, Cisco will release it. 

New Member

This discussion has been

This discussion has been reposted from Additional Communities to the VPN community.

Hall of Fame Super Gold

Windows 10, the announcement,

Windows 10, the announcement, is just a few HOURS old.  I seriously doubt if anyone in Cisco has done any compatibility testing.

New Member

well yes we know...

well yes we know... interesting thing is I just got it to connect. But after that session we are back to the empty SSL cache message. So it's probably fixable if I knew what exactly the error meant. So let's pretend it's not Windows 10 and it's Windows 8.1. What would cause the empty SSL cache message?

 

Look at the login at 6:08PM versus the later ones around 7:22PM.. Whats the issue?

While not a perfect answer,

While not a perfect answer, here is a workaround that I found on the Microsoft forums. I have not had a chance to do this yet, but it looks like it worked for the few people who were discussing it. I had the same issue you did, and also the same luck of it working once but not again, so I am looking forward to trying this out later today.

http://social.technet.microsoft.com/Forums/en-US/5fdd9a85-6999-44a7-8a95-19c5bca0d86a/cisco-vpn-access-with-windows-10-preview?forum=WinPreview2014General

It's going to take some time

It's going to take some time before AnyConnect catches up on preview releases of Windows.

It appears that you're comfortable living on the edge, so I'll suggest you give OpenConnect a try as a client alternative to see if it fits the bill until a working AnyConnect client is released for the platform.

New Member

I  have the same problem,wish

I  have the same problem,wish cisco can resolve it as soon as possible,Thanks~

New Member

Configure Windows 8

Configure Windows 8 compatibility mode for C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\vpnagent.exe. Restart "Cisco AnyConnect Secure Mobility Agent" windows service. It works for me.

New Member

I have not find the below

I have not find the below solution myself but can confirm that it is working: I have Windows 10 Preview with CISCO AnyConnect Secure Mobile Client Version 3.1.05160.

 


1. Right click VPNUI in the Cisco install folder. (I have it in "C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\"


2. Choose Troubleshoot compatibility.

3. The wizard suggests win8 compatibility.

4. The "test program does not work" since the program may be running. Just add the configuration. (It did work for me)


5. Restart the VPN service. (No need for me, worked after the compatibility mode fix)

6. Start AnyConnect from the start meny.
7. Working.


 

New Member

Hi ,If you have problem

Hi ,

If you have problem "Cisco VPN Client: Unable to Enable Virtual Adapter" with VPN Client. You must edit this registry subkey - 

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentSet\ControlSet001\Services\CVirta - right click on "Display Name"\Modify\ and then delete everything before "Cisco Systems VPN Adapter" in ""Value Data" box.

New Member

Thank you evanerwee your

Thank you evanerwee your solution works for me.

 

cheers

New Member

This worked for me. Win10

This worked for me. Win10 Build 9841 with AnyConnect v3.1.03103

New Member

First, uninstall any Cisco

First, uninstall any Cisco VPN Client software you may have installed earlier;

Then uninstall any DNE updater software(s) you may have installed earlier;

Reboot your computer.

Run winfix.exe from citrix to ensure the DNE is properly cleaned up.

Reboot your computer again.

Install the SonicWall VPN software to get a version of DNE that works (DNE off citrix website did not work for me)

Reboot your computer.

Reinstall the Cisco VPN Client software again. (You do not need to uninstall the SonicWall VPN software. If you face a version check issue, run the msi file instead of the exe file

Configure the Cisco VPN Client

Change  registry key HKLM\SYSTEM\CurrentControlSet\Services\CVirtA\DisplayName.  Remove preceding "@oemX.inf,%CVirtA_Desc%” so the entry reads “Cisco Systems VPN Adapter for 64-bit Windows”

Reboot your computer.

Your Cisco VPN Client should now work in Windows 10!

New Member

Hi, I have done all steps

Hi, 

I have done all steps that you mentioned above, however when I tried to install the VPN client, windows says that the app is not supported. Do you have any idea?

Are we talking about the

Are we talking about the Cisco VPN Client or the Cisco AnyConnect Secure Mobility Client at this point? These are two very different things.

If you want to run the Cisco VPN Client, that has been unsupported for quite some time and you're highly unlikely to get it working on Windows 10 without a lot of hacking and jumping through hoops. If you really need to connect to old-fashioned Cisco VPN Client (EzVPN) hosts, I recommend using the free Shrew Soft VPN client. Works like a charm and even imports profiles from the old Cisco VPN Client software.

If you need to run the Cisco AnyConnect Secure Mobility Client on Windows 10, this is now supported as of version 3.1.10010. See the following for details:

http://www.cisco.com/c/en/us/td/docs/security/vpn_client/anyconnect/anyconnect31/release/notes/anyconnect31rn.html#45952

New Member

Hi Jody, I've tried to

Hi Jody, 

I've tried to install the Shrew Soft VPN client, but did not work either. I am able to establish the VPN, however I cannot navigate through it even I can't surfer on Internet. About Cisco AnyConnect, there is any client that I can run on desktop available on Cisco download page?

 

Thanks in advance!

Yes. You can download the

Yes. You can download the Cisco AnyConnect Secure Mobility Client 3.1.10010 as a stand-alone EXE or MSI installer from the Cisco download pages. Just be sure you're connecting to an AnyConnect-enabled router or firewall. It can't be used to connect to a router or firewall if it has only been configured to support the Cisco VPN Client.

New Member

Hi Jody,  I just found

Hi Jody, 

 

I just found standalone for Linux, not for windows, for any reason is it the same?

It's there. Look for:Full

It's there. Look for:

Full installation package - Window / Standalone installer (ISO). Includes installation packages for DART, NAM, Core/VPN, Phone Home, Hostscan, ISE Posture, and WebSecurity components.   
anyconnect-win-3.1.10010-pre-deploy-k9.iso

New Member

NCP is a bit pricey but the

NCP is a bit pricey but the IPsec client works on all recent windows versions.  I am also able to use it without issue on android mobile devices.

 

https://www.ncp-e.com/en/products/ipsec-vpn-client-suite.html

 

188477
Views
15
Helpful
20
Replies