Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

1 router connecting to two l3 swtiches

Hi,

I wanted to setup network in below manner.

Lan is having two l3 switches. They are connecting to one router for external connectivity.

Two L3 switches are running HSRP. Router is having one physical link to active L3 and another physical link to standby L3.

I wanted to know the configuration required at router side. Router model is 2621, IOS 12.2

Regards

SKRAO

4 REPLIES

Re: 1 router connecting to two l3 swtiches

You should run a routing protocol say EIGRP between the L3 and the router.

Also run a L3 vlan link between the L3 switches over the trunks so that it will take care of the L3 link failures between the core and the router

on the router

router eigrp 100

network 10.10.10.0 0.0.0.3

network 20.20.20.1 0.0.0.3

no auto-summary

on the core sw1 (i assume there is a trunk between the 2 and should carry all the vlans)

vlan 98

name L3 link between switches

int vlan 98

ip address 30.30.30.1 255.255.255.252

no shut

router eigrp 100

network 10.10.10.0 0.0.0.3

network 30.30.30.0 0.0.0.3

no auto-summary

on core switch 2

int vlan 98

ip address 30.30.30.2 255.255.255.252

no shut

router eigrp 100

network 20.20.20.0 0.0.0.3

network 30.30.30.0 0.0.0.3

no auto-summary

HTH

Narayan

Hall of Fame Super Gold

Re: 1 router connecting to two l3 swtiches

Hi Narayan,

the thing is that a router cannot have two lan interfaces in the same subnet, so if this is the way they want it working, must use bridging/BVI on the router.

Re: 1 router connecting to two l3 swtiches

I agree Paolo and thats why i suggested using two different ip address and run a routing protocol.

If they need to have only one ip address then the config you posted is the way to go :-)

Narayan

Hall of Fame Super Gold

Re: 1 router connecting to two l3 swtiches

int fastethernet x/y

no ip address

bridge-group 1

int fastethernet x/y

no ip address

bridge-group 1

int bvi1

ip address ...

bridge irb

bridge 1 route ip

Hope this helps, please rate post if it does!

135
Views
4
Helpful
4
Replies
CreatePlease to create content