Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1700 Router Configuration DLCI

I have a cisco 1751 router with interfaces Ethernet0/0 and FastEthernet0/0.

My ISP is asking me to configure the router with DLCI 16 with IP X.X.X.Xa -Gateway X.X.X.Xb and DLCI 17 with IP Y.Y.Y.Yc - Gateway Y.Y.Y.Yd

How do I configure this?

13 REPLIES

Re: 1700 Router Configuration DLCI

Hi,

its very simple,

You cant do that without Serial interface..

HTH

Mohamed

New Member

Re: 1700 Router Configuration DLCI

Could you pls list the commands, do I need to define encapsulation as frame-relay on subinterfaces?

Cisco Employee

Re: 1700 Router Configuration DLCI

As pointed out by Mohamed, you would need a serial interface/module for frame relay. Here's how you can configure it:

!

interface Serial1/1

no ip address

encapsulation frame-relay

no shutdown

!

interface Serial1/1.16 multipoint << If using multipoint sub-if

ip add X.X.X.Xa

frame-relay map ip X.X.X.Xb 16 broadcast << If using multipoint sub-if

no shutdown

!

OR

interface Serial1/1.16 point-to-point << If using point-to-point sub-if

ip add X.X.X.Xa

frame-relay interface-dlci 16 << If using pont-to-point sub-if (No need to specify the gateway)

no shutdown

!

Same way create an additional sub-interface (Serial1/1.17) for Y.Y.Y.Yc (DLCI 17).

-Vaibhav

New Member

Re: 1700 Router Configuration DLCI

Thank You Vaibhav.

Is it not possible to define the DLCI on ethernet interface by creating suninterfaces or by something else.

My ISP has given me some details and from their side its a LAN cable which has to be connected to our router (no serail cable). All they have given is WAN IP's and DLCI id. I couldnot find the option to enable DLCI on Ehternet interface even by defining subinterfaces.

New Member

Re: 1700 Router Configuration DLCI

Sorry, It has to be terminated on BRI interface. I have BRI0 interface. How do I define subinterfaces on BRI0. I need 2 subinterfaces. I am getting the below error.

TEST(config)#interface BRI0

TEST(config-if)#no ip address

TEST(config-if)#encapsulation frame-relay ietf

TEST(config-if)#frame-relay lmi-type q933a

TEST(config)#interface BRI0:1

% Cannot access B-channel interfaces

Cisco Employee

Re: 1700 Router Configuration DLCI

BRI is normally used as a backup for the frame-relay link. You'll have to have a serial interface for frame-relay to be able to configure IP to DLCI mappings.

-Vaibhav

New Member

Re: 1700 Router Configuration DLCI

It wont work on the router you have.

Frame-relay connections terminate on serial interfaces. If you have a spare slot get a WIC-1T.

New Member

Re: 1700 Router Configuration DLCI

I am able to configure as below. Is it going to work? I cannpt have serial interface as the ISP side has given me LAN (RJ45) type connection

---------------------------------------------

interface BRI0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type q933a

!

interface BRI0.16 point-to-point

ip address x.x.x.x 255.255.255.0

no arp frame-relay

frame-relay interface-dlci 16

Hall of Fame Super Silver

Re: 1700 Router Configuration DLCI

avil

I do not believe that this will work. The BRI interface expects to talk to an ISDN switch but there is no ISDN switch configuration in what you have posted.

I would like to know more about this ISP connection. You tell us that it is an LAN(RJ45) type connection. What kind of device is it that is giving the connection?

There are quite a number of serial cards with built in CSU/DSU which have connection via RJ45 cable. I suspect that this is what the ISP wants you to use. Especially when a DLCI is part of what they specify it means Frame Relay. And Frame Relay needs a serial connection.

HTH

Rick

Hall of Fame Super Gold

Re: 1700 Router Configuration DLCI

Hi,

As strange it may seem, frame-realy can be used on ISDN BRI.

However, i think the rj45 that avil has been given, is either a t1 or e1 connector. Avil, can you clarify with you service provider, which service have your purchased ?

Hall of Fame Super Silver

Re: 1700 Router Configuration DLCI

Paolo

To run Frame Relay over BRI do you not still need the isdn switch-type and other ISDN configuration?

HTH

Rick

Hall of Fame Super Gold

Re: 1700 Router Configuration DLCI

Yes you do. It was something used in the past to provide back-up with frame-relay services, terminating into devices incapable of routing. I haven't heard on anyone using it for real, but the feature is there.

Also, in Germany, they used isdn bri as replacement for low speed leased lines, that's called nailed bri.

New Member

Re: 1700 Router Configuration DLCI

My ISDN leased line is up with the below config.

isdn switch-type ABC

isdn leased-line BRI1/0

interface BRI1/0:1

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type q933a

interface BRI1/0:1.16 point-to-point

ip address x.x.x.y 255.255.255.0

ip ospf network non-broadcast

ip ospf cost 10

ip ospf priority 0

no arp frame-relay

no cdp enable

frame-relay interface-dlci 16 IETF

!

interface BRI1/0:1.17 point-to-point

ip address y.y.y.z 255.255.255.0

ip ospf network non-broadcast

ip ospf cost 20

ip ospf priority 0

no cdp enable

frame-relay interface-dlci 17 IETF

492
Views
0
Helpful
13
Replies
CreatePlease to create content