Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1721 adsl router, lan internet connection problem

i am trying to set up a 1721 router as dsl gateway router and dhcp server, it connects to the isp, gets ip address and from the router i can ping any ip on the internet, but from the lan side, i can only ping the router, nothing else on the internet, cant connect to the internet from any pc, pc gets ip from the router acting as dhcp server, here is the router config, any help will be greatly appreciated, thanks

sh running-config

Building configuration...

Current configuration : 1218 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname badboy

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

!

!

--More-- ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool lan

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 68.x.x.1 68.94.157.1

!

ip cef

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

!

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

--More-- pvc 0/35

pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

speed auto

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

ppp chap hostname XXXXXXXXXXXXXXXXX

ppp chap password 0 XXXXXXXXX

ppp pap sent-username XXXXXXXXXXX password 0 XXXXXX

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

--More-- !

!

!

!

!

line con 0

password xxx

line aux 0

line vty 0 4

password xxx

login

!

end

badboy#

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: 1721 adsl router, lan internet connection problem

Hello..

You have to do NAT configuration for your lan.

access-list 25 permit 10.10.10.0 0.0.0.255

ip nat inside source list 25 interface dialer1 overload

2 REPLIES
New Member

Re: 1721 adsl router, lan internet connection problem

Hello..

You have to do NAT configuration for your lan.

access-list 25 permit 10.10.10.0 0.0.0.255

ip nat inside source list 25 interface dialer1 overload

New Member

Re: 1721 adsl router, lan internet connection problem

it worked, thanks

118
Views
0
Helpful
2
Replies
CreatePlease to create content