Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1721 ATM dialer backup for serial line

Hi all,

I've been using the following config for ADSL backup to a serial line, however it seems to show strange behaviour.

interface ATM0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

hold-queue 224 in

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface FastEthernet0

description Customer LAN

ip address 1.1.1.1 255.255.255.248

speed auto

!

interface Serial0

description Link to ISP

bandwidth 1024

backup interface Dialer1

ip address 2.2.2.2 255.255.255.252

!

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

ppp chap hostname user@account.realm.net

ppp chap password 0 1234

ppp pap sent-username user@account.realm.net password 0 1234

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 Dialer1 254

When the router boots up with both lines connected, the Dialer1 is set to standby state, whilst the serial is working. If the serial line drops, logging shows the Dialer1 go up, but no further authentication/PPP events are logged and the device doesn't log in.

IF the router is booted up with the serial line disconnected, the ATM interface and dialer interface are brought up and the DSL works, and when the serial line is then brought up/dropped the ATM/Dialer will work each time.

Can anyone advise why this would be the case, or what better way to do the configuration.

We have swapped to using:

interface serial0

backup interface ATM0

So that the whole adsl is disabled until required, however this stops us from checking on ADSL sync/monitoring.

Thanks in advance!

2 REPLIES
Silver

Re: 1721 ATM dialer backup for serial line

You has to put...

int dialer1

ppp authentication chap (Should both end same)

idle time-out

router(Conf)#dialer-list 1 protocol ip permit

** Without this DDR will not work **

ip route 0.0.0.0 0.0.0.0 Dialer1 150

New Member

Re: 1721 ATM dialer backup for serial line

Thanks for that, sorry I should have mentioned that I had the dialer-list statement.

I have tried adding the ppp authentication and I have the same problem. Here is a log of the config and debug output.

When I manually issue an ATM0 clear, it brings the DSL up

interface ATM0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

hold-queue 224 in

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface FastEthernet0

description Customer LAN

ip address 1.1.1.1 255.255.255.248

speed auto

!

interface Serial0

description Link to ISP

bandwidth 1024

backup interface Dialer1

ip address 2.2.2.2 255.255.255.252

!

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

ppp authentication chap

ppp chap hostname user@account.realm.net

ppp chap password 0 1234

ppp pap sent-username user@account.realm.net password 0 1234

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 Dialer1 254

no ip http server

!

dialer-list 1 protocol ip permit

!

00:01:48: %LINK-3-UPDOWN: Interface Serial0, changed state to down

00:01:48: BACKUP(Serial0): event = primary interface went down

00:01:48: BACKUP(Serial0): changed state to "waiting to backup"

00:01:48: BACKUP(Serial0): event = timer expired on primary

00:01:48: BACKUP(Serial0): secondary interface (Dialer1) made active

00:01:48: BACKUP(Serial0): changed state to "backup mode"

00:01:49: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down

00:01:49: BACKUP(Serial0): event = primary interface went down

00:01:50: %LINK-3-UPDOWN: Interface Dialer1, changed state to up

00:01:50: BACKUP(Dialer1): event = secondary interface came up

00:01:51: BACKUP(Dialer1): event = secondary interface came up

00:02:21: BACKUP(Serial0): event = primary interface went down

router#ping 64.233.183.103

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 64.233.183.103, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

router#

router#

router#clear int atm0

router#

00:02:47: ATM0 dslsar_1a_reset: PLIM type is 18, Rate is 288Mbps

00:02:47: ATM0 dslsar_1a_shutdown: state=4

00:02:47: dslsar disable ATM0

00:02:47: Resetting ATM0

00:02:47: dslsar_1a_teardown_vc(ATM0): vc:1 vpi:0 vci:38

00:02:47: dslsar_1a_config(ATM0)

00:02:47: dslsar_1a_enable(ATM0)

00:02:47: ATM0: dslsar_init

00:02:47: ATM0 dslsar_MatchSARTxToLineSpeed(): usbw 288, clkPerCell 52013 prev_clkPerCell 9702

00:02:47: ATM0 dslsar_MatchSARTxToLineSpeed(): Changing line speed from fast to slow

00:02:47: ATM0 dslsar_update_us_bandwidth(): upstream bw =288 Kbps

00:02:48: (ATM0)1a_enable: delay activation of vcd=1, vc=0x82C4CFBC

00:02:48: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

00:02:49: dslsar enable ATM0

00:02:49: ATM0: dslsar_bringup_interface: Interface and atm_db flags are UP

00:02:50: dslsar_txRingParamInit_and_tcqSetup(): default tx-ring setting is selected for vpi/vci = 0/38

00:02:50: ATM0:dslsar_init_tx_chan_desc_per_vc, vcd = 1, addr = 0x00011040, size = 64

00:02:50: ATM0 dslsar_vc_setup: vcd 1

00:02:50: CONFIGURING(ATM0) VC 1 (0/38) IN TX SCHEDULE TABLE SET 0

00:02:50: (ATM0)Forcing Peakrate and Avgrate to: 288

00:02:50: (ATM0)Requested QoS: Peakrate = 288, Avgrate = 288, Burstsize =0

00:02:50: (ATM0)Configuring VC 1: slot 0 in TST 5

00:02:50: (ATM0) SUCCESSFUL CONFIGURATION OF VC 1 (0/38), QOS Type 4

00:02:50: dslsar_setup_cos(ATM0): vc:1 wred_name:- max_q:0

00:02:50: ATM0: vcd = 1, max_tx_time = 7450

00:06:47: Vi2 PPP: No authorization without authentication

00:06:47: Vi2 CHAP: I CHALLENGE id 212 len 35 from "ERX3.Sheffield"

00:06:47: Vi2 CHAP: Using hostname from interface CHAP

00:06:47: Vi2 CHAP: Using password from interface CHAP

00:06:47: Vi2 CHAP: O RESPONSE id 212 len 48 from "user@account.realm.net"

00:06:51: Vi2 CHAP: I SUCCESS id 212 len 4

00:06:52: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up

169
Views
0
Helpful
2
Replies
CreatePlease login to create content