Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

1721 Configured for PPPOE...I think?

Hi,

This thread is based on the configuration shown below. I have a 1721 connected to SBC via PPPOE. I'm using the router as the PPPOE client and have configured FE0 as the gateway and set up DHCP.

When I plug my laptop into FE0 I get an IP address. I can also set up a static address on my laptop and things work fine. However, I have a SCO server that was connected to the internet vi a Linksys router but now can't find the gateway when connected to FE0.

So I'm wondering if my config is missing something or has something wrong. SBC gave me five IP address but I only need one for now and can use the 192 addresses.

How should I set up FE1-FE4 so that I can plug other machines in to those ports and get an IP address and have them connect? I'm thinking I just create a VLAN and assign it to the port, like this:

interface Vlan26

description router interface for LAN segment

ip address 192.168.0.1 255.255.255.0

ip nat inside

!

interface FastEthernet1

description Connection to Wireless LAN

switchport access vlan 26

no ip address

!

At any rate, some guidance would be appreciated here. Special thanks go out to thisisshanky and spremkumar for helping me with the initial config.

Thanks!

Jon

Router#show run

Building configuration...

Current configuration : 1470 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.1

!

ip dhcp pool nap_dhcp_pool

network 192.168.0.0 255.255.255.248

default-router 192.168.0.1

dns-server 206.x.x.x.13.31.12

!

!

ip cef

vpdn enable

!

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/35

pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

ip address 192.168.0.1 255.255.255.248

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

speed auto

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface Vlan1

no ip address

!

interface Dialer1

mtu 1492

ip address <STATIC IP> 255.255.255.248

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp chap hostname <USERNAME>

ppp chap password 0 <PASSWD>

ppp pap sent-username <USERNAME> password 0 <PASSWORD>

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

ip nat inside source list 1 interface Dialer1 overload

!

!

access-list 1 permit 192.168.0.0 0.0.0.255

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

!

end

  • WAN Routing and Switching
2 REPLIES
Silver

Re: 1721 Configured for PPPOE...I think?

I want to know one information regarding your DHCP server.Is the DHCP server residing in different VLAN from the connecting client's VLAN?.If different, then you may have to go into the VLAN in which the DHCP client resides and in that interface VLAN configuration type "ip helper-address command .This commands forwards DHCP UDP packets.

New Member

Re: 1721 Configured for PPPOE...I think?

Nope, same VLAN. In fact, I haven't set up any VLAN yet as it's just plugged into FE0.

I'm working on a config right now that might do the trick though...will update this post when I get it done.

Thanks!

135
Views
0
Helpful
2
Replies