Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1750 drops connection after hours

All, I have a remote location that uses SWB DSL connection. After hours, the 1750's E0 interface stops responding to ping. I have tried keepalives and have had the same problem. I have called the ISP three times and they can find no problem. Last night, the router was bouncing up and down 10 times. PLease help.

Thanks

Current configuration : 3853 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname xxxx

!

no logging on

enable password 7 xxxx

!

username xxx password 7 xxx

username xxx password 7 xxx

username xxx password 7 xxx

memory-size iomem 20

ip subnet-zero

no ip finger

no ip domain-lookup

ip host test 2005 192.168.18.1

ip dhcp excluded-address 192.168.18.1 192.168.18.20

!

ip dhcp pool xxxx

import all

network 192.168.18.0 255.255.255.0

default-router 192.168.18.1

domain-name xxx.xxx.com

dns-server 172.17.2.60 xxx

netbios-name-server 172.17.2.60 172.17.2.30

netbios-node-type h-node

lease 30

!

ip dhcp pool jdirect1

host 192.168.18.20 255.255.255.0

hardware-address 0030.c154.724b

client-name NPI54724b

!

ip dhcp pool jdirect2

host 192.168.18.19 255.255.255.0

hardware-address 0030.c153.bdbc

client-name NPI53bdbc

!

chat-script modem ABORT ERROR "" "ATDT\T" TIMEOUT 60 CONNECT \c

!

!

crypto isakmp policy 11

xxx

authentication pre-share

crypto isakmp key xxxxxx address xxxxxx

!

!

crypto ipsec transform-set sharks esp-des esp-md5-hmac

!

crypto map nolan 11 ipsec-isakmp

set peer xxxxx

set transform-set sharks

match address 121

!

!

!

!

interface Ethernet0

ip address xxxxx 255.255.255.248

ip nat outside

no ip route-cache

no ip mroute-cache

half-duplex

crypto map nolan

!

interface FastEthernet0

ip address 192.168.18.1 255.255.255.0

ip helper-address 172.17.2.30

ip helper-address 172.17.2.255

ip helper-address 172.17.255.255

ip directed-broadcast

ip nat inside

no ip route-cache

no ip mroute-cache

speed auto

!

interface Async5

ip address 170.1.1.18 255.255.255.0

encapsulation ppp

keepalive 10

dialer in-band

dialer idle-timeout 300

dialer string xxxxx

dialer-group 1

fair-queue

ppp authentication xxxx

!

interface Dialer1

no ip address

no cdp enable

!

router eigrp 100

network xxxxx

network 170.1.0.0

network 172.20.0.0

network 172.21.0.0

network 192.168.18.0

auto-summary

no eigrp log-neighbor-changes

!

ip nat inside source route-map nonat interface Ethernet0 overload

ip kerberos source-interface any

ip classless

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

ip forward-protocol udp netbios-ss

ip forward-protocol udp 42508 xxxxxxxxx

ip route 0.0.0.0 0.0.0.0 Async5 200

no ip http server

!

no logging trap

access-list 110 deny ip 192.168.18.0 0.0.0.255 172.16.0.0 0.0.255.255

access-list 110 deny ip 192.168.18.0 0.0.0.255 172.17.0.0 0.0.255.255

access-list 110 permit ip 192.168.18.0 0.0.0.255 any

access-list 120 permit ip 192.168.18.0 0.0.0.255 any

access-list 121 permit ip 192.168.18.0 0.0.0.255 172.16.0.0 0.0.255.255

access-list 121 permit ip 192.168.18.0 0.0.0.255 172.17.0.0 0.0.255.255

access-list 150 permit esp host xxx host xxx

access-list 150 permit udp host xxx host xxx eq isakmp

access-list 150 permit ip any 192.168.18.0 0.0.0.255

access-list 150 deny ip any any

priority-list 1 protocol ip high

dialer-list 1 protocol ip permit

route-map nonat permit 10

match ip address 110

!

7 REPLIES
Silver

Re: 1750 drops connection after hours

Any good logs from the router? How about errors in 'show interface eth0' or 'show controller eth0'?

New Member

Re: 1750 drops connection after hours

xxxxxx#sh controller e0

PQUICC Ethernet unit 0 using SCC1, Microcode ver 4

Current station address 0004.dd0c.d3da, default address 8138.d0d8.80e5

idb at 0x810880D0, driver data structure at 0x81089E90

SCC Registers:

General [GSMR]=0x0:0x1088003C, Protocol-specific [PSMR]=0x80A

Events [SCCE]=0x0000, Mask [SCCM]=0x001F, Status [SCCS]=0x0002

Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0xD555

Interrupt Registers:

Config [CICR]=0x00365F80, Pending [CIPR]=0x8000C000

Mask [CIMR]=0x40200000, In-srv [CISR]=0x00000000

Command register [CR]=0x600

Port A [PADIR]=0x0000, [PAPAR]=0x0903

[PAODR]=0x0000, [PADAT]=0xF7FF

Port B [PBDIR]=0x0000100F, [PBPAR]=0x0000100E

[PBODR]=0x00000000, [PBDAT]=0x0000EDFC

Port C [PCDIR]=0x0000, [PCPAR]=0x0000

[PCSO]=0x0030, [PCDAT]=0x0FCC, [PCINT]=0x0000

wic_enet_regs_ptr->ctrl_reg is0xB5

SCC ETHERNET PARAMETER RAM (at 0xFF003C30)

CRC Preset [C_PRES]=0xFFFFFFFF, Mask [C_MASK]=0xDEBB20E3

Errors: CRC [CRCEC]=0, Alignment [ALEC]=0, Discards [DISFC]=0

PAD Char [PADS]=0x0

Retry Limit [RET_LIM]=15, Count [RET_CNT]=15

Frame Lengths: [MAXFLR]=1518, [MINFLR]=64

Max DMA Lengths: [MAXD1]=1518, [MAXD2]=1518

Group Address Filter [GADDRn]=0000:0000:0000:0100

Indiv Address Filter [IADDRn]=0000:0000:0000:0000

Physical Address [PADDR1]=DAD3.0CDD.0400

Last Address Set in Filter [TADDR]=CCCC.CC0C.0001

Persistence [P_Per]=0, Backoff Cnt [BOFF_CNT]=0

BD Pointers:

First Rx [RFBD]=0x0, First Tx [TFBD]=0x2318, Last Tx [TLBD]=0x2310

Receive Ring

rmd(FF002230): status 9000 length 72 address 1B00404

rmd(FF002238): status 9000 length 72 address 1AFF704

rmd(FF002240): status 9000 length 72 address 1AFEA04

rmd(FF002248): status 9000 length 72 address 1B04504

rmd(FF002250): status 9000 length 72 address 1B05884

rmd(FF002258): status 9000 length 72 address 1B07284

rmd(FF002260): status 9000 length 72 address 1B08604

rmd(FF002268): status 9000 length 72 address 1B00A84

rmd(FF002270): status 9000 length 72 address 1B09984

rmd(FF002278): status 9000 length 72 address 1B03184

rmd(FF002280): status 9000 length 72 address 1B06C04

rmd(FF002288): status 9000 length 72 address 1B01E04

rmd(FF002290): status 9000 length 72 address 1B03E84

rmd(FF002298): status 9000 length 72 address 1B08C84

rmd(FF0022A0): status 9000 length 40 address 1AFE384

rmd(FF0022A8): status B000 length 72 address 1B05204

Transmit Ring

tmd(FF0022B0): status 5C00 length 3C address 199B48A

tmd(FF0022B8): status 5C00 length 6E address 199C8E6

tmd(FF0022C0): status 5C00 length 6E address 199BF26

tmd(FF0022C8): status 5C00 length 6E address 199DFA6

tmd(FF0022D0): status 5C00 length 6E address 199C8E6

tmd(FF0022D8): status 5C00 length 6E address 199C8E6

tmd(FF0022E0): status 5C00 length 6E address 199C8E6

tmd(FF0022E8): status 5C00 length 6E address 199BF26

tmd(FF0022F0): status 5C00 length 286 address 1B0E9A6

tmd(FF0022F8): status 5C00 length 286 address 199E966

tmd(FF002300): status 5C00 length 286 address 199CF66

tmd(FF002308): status 5C00 length BE address 199E2E6

tmd(FF002310): status 5C00 length BE address 1B0E666

tmd(FF002318): status 5C00 length 286 address 199D5E6

tmd(FF002320): status 5C00 length 286 address 199BBE6

tmd(FF002328): status 7C00 length 6E address 199C8E6

0 missed datagrams, 0 overruns

0 transmitter underruns, 0 excessive collisions

0 single collisions, 0 multiple collisions

0 dma memory errors, 0 CRC errors

0 alignment errors, 0 runts, 0 giants

QUICC SCC specific errors:

0 buffer errors, 0 overflow errors

0 input aborts on late collisions

0 throttles, 0 enables

Silver

Re: 1750 drops connection after hours

Show log on the router does it show that the E0 went down? Maybe the problem is not an interface problem. It can be some other thing such as IP conflict on E0 interface.

Let me know,

New Member

Re: 1750 drops connection after hours

Also, look at sh ver -- it will give router uptime and the reason for the last reboot. Insure the router is staying up (or if it goes down, read the reason why).

New Member

Re: 1750 drops connection after hours

xxxxx#sh int e0

Ethernet0 is up, line protocol is up

Hardware is PQUICC Ethernet, address is 0004.dd0c.d3da (bia 0004.dd0c.d3da)

Internet address is xxxxxxxxxx/29

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 10BaseT

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

5391270 packets input, 3720647055 bytes, 0 no buffer

Received 147866 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

5753215 packets output, 1127870385 bytes, 0 underruns(0/0/0)

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

**************************************************************************

********************************************************************

xxxxxxx#sh log

Syslog logging: disabled (0 messages dropped, 1 messages rate-limited, 310 flushes, 0 overruns)

Console logging: level debugging, 313 messages logged

Monitor logging: level debugging, 0 messages logged

Buffer logging: disabled

Logging Exception size (0 bytes)

Trap logging: disabled

The sh ver shows an uptime of forty weeks.

Thanks for the help guys.

Silver

Re: 1750 drops connection after hours

Logging is disabled on your router. Enable logging so you can track what's going on the router. Use the command "logging buffered"

Let me know the logs after some days,

Regards,

New Member

Re: 1750 drops connection after hours

Can I just do a show log to view the logs?

134
Views
0
Helpful
7
Replies
CreatePlease login to create content