Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1760 ADSL NAT configuration problems

Good Day All,

I have a cisco 1760 with a WIC1-ADSL card installed. I have configured it and can connect to the internet, outbound. The problem I am having is getting traffic inbound to internal servers using NAT. The provider is not blocking any of the ports as I had this working using my provider's dsl modem and a 1605 ethernet router.

The DSL connection gets a DHCP address assigned and I think it may be the problem. Please review my configuration and advise.

Thank you in advanced!

! Last configuration change at 13:44:28 EDT Tue Jul 19 2005
! NVRAM config last updated at 06:58:58 EDT Tue Jul 19 2005
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
enable secret 5 <omitted>
!
clock timezone EST -5
clock summer-time EDT recurring
no aaa new-model
ip subnet-zero
no ip source-route
!
!
ip domain name <omitted>
ip name-server <omitted> (providers dns server)
ip name-server <omitted>     "     "     "
!
!
ip cef
ip audit notify log
ip audit po max-events 100
ip ssh break-string
vpdn enable
!
vpdn-group pppoe
request-dialin
  protocol pppoe
!
no ftp-server write-enable
!
!
!
!
no crypto isakmp enable
!
!
!
!
interface ATM0/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
dsl enable-training-log
hold-queue 224 in
!
interface ATM0/0.1 point-to-point
no ip redirects
no ip unreachables
pvc 0/35
  pppoe-client dial-pool-number 1
!
!
interface FastEthernet0/0
ip address 192.168.x.250 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
speed auto
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp pap sent-username <omitted> password 0 <omitted>
!
ip nat inside source list 20 interface Dialer1 overload
ip nat inside source static tcp 192.168.x.90 7070 interface Dialer1 7070
ip nat inside source static tcp 192.168.x.95 8443 interface Dialer1 8443
ip nat inside source static tcp 192.168.x.80 9090 interface Dialer1 9090
ip nat inside source static tcp 192.168.x.80 8090 interface Dialer1 8090
ip nat inside source static tcp 192.168.x.75 8080 interface Dialer1 8080
ip nat inside source static tcp 192.168.x.70 88 interface Dialer1 88

ip nat inside source static tcp 192.168.x.5 22 interface Dialer1 22

ip nat inside source static tcp 192.168.x.35 80 interface Dialer1 80
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
!
!
access-list 20 permit 192.168.0.0 0.0.255.255
snmp-server community <omitted> RW 20
snmp-server community <omitted> RO 20
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps config
snmp-server enable traps syslog
snmp-server enable traps rtr
snmp-server host 192.168.x.75 public
!
!
control-plane
!
!
line con 0
password <omitted>
logging synchronous
login
line aux 0
password <omitted>
login
line vty 0 4
password <omitted>
login
!
no scheduler allocate
!
end

Everyone's tags (3)
2 REPLIES

Re: 1760 ADSL NAT configuration problems

Hello!

"show ip nat translation"

"debug ip nat"

Does this commands show anything that can help you see what's the problem? Can you copy/paste some of this commands output here?

Cheers,

Calin

New Member

Re: 1760 ADSL NAT configuration problems

I added my DSL modem mac to the ATM 0/0 interface, as show vdpn had a 0000.0000.0000 mac listed.

Now It IS working. Internal tests to outside and back were and are still failing, but verfied on an external system it is working as desired.

Not sure if it was the MAC or not, but in the end, its working

725
Views
0
Helpful
2
Replies