Cisco Support Community
Community Member

1801 DSL Interface Problem


I put in place a cisco 1801 with Ethernet and DSL interface yesterday. Ethernet WAN works great. I have a situation where the dsl is dropping packets periodically. The line is hardly used and pings are around 80-100ms then it drops two or more pings then comes back. I tried to router supplier by the ISP and all works perfectly. Does this sound like a hardware issue?

I get this on logging

*Apr 21 10:56:20.972: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

*Apr 21 10:56:22.024: %LINK-3-UPDOWN: Interface ATM0, changed state to down

*Apr 21 10:57:34.564: %LINK-3-UPDOWN: Interface ATM0, changed state to up

*Apr 21 10:57:36.896: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up


Re: 1801 DSL Interface Problem

It could be an intermittent network problem. If the problem persists, collect debug messages for analysing teh actual problem.

Community Member

Re: 1801 DSL Interface Problem

i have the same issue with my 1801 and my ISP (BT broadband MAX DSL 8mb) thing is i was getting this before i upped to 8mb dsl. same issue where the ATM0 int goes down, put in the provided router and hand off via ethernet and all is well. parts of my config below (with user/pass removed)

as this only happens when im connected via dsl ive omitted the rest of the config so below is the dsl specifics only.

interface ATM0

description Master ADSL

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip virtual-reassembly

no ip mroute-cache

no atm auto-configuration

no atm ilmi-keepalive

no atm address-registration

no atm ilmi-enable

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1


dsl operating-mode auto



interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

no ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer idle-timeout 0

dialer persistent delay 60

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname ****

ppp chap password 7 ****

ppp pap sent-username ***



interface Loopback0

ip address * secondary

ip address * secondary

ip address *

ip mtu 1492

no ip route-cache

ip tcp adjust-mss 1452

hold-queue 100 out

any help you can shed would be great

Community Member

Re: 1801 DSL Interface Problem

I have had this with a number of router when i have dsl operating-mode auto set as "auto". On two occassion are IOS upgrade fixed it. I also had a situation with a 72 port lucent DSLAM where it wouldnt work relabilty with "auto" selected. Even with cisco specific firmware this was not relibale.

whats version are you using?

Community Member

Re: 1801 DSL Interface Problem

im currently on ios 12.4(9)T i upgraded last week to try and solve this issue, although i changed my dsl-operating-mode to itu-dmt and its currently staying up also reanabled enable-training-log

however in this config i was only seeing 2mb down, forced to ansi-dmt mode and im getting 4mb - 6mb down which is normall for my 8mb dsl.

time to see what happens.

CreatePlease to create content