Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1811 dual ISP routing issue, please help

Hi All,

We have a 1811 with 2 PPPoE link to the internet. It was running fine with policy route-map on VLAN1 untill yesterday's power outage.

After the power outage, it boots up ok. The 2 links to ISP are running fine. But only 1 routed connectiong works. I used debug ip policy, it seems routed ok, which is one server match the policy and routed. The rest did not match and normal forwarding.

The normal forwarding is the default gateway. But when I trace from the pc, it reached VLAN IP, then got lost.

The default gateway link (dialer0) also accept VPN connection. When VPNed in, it can reach the the network servers without issue. But if the traffic issued from the network server, it wont go through.

A NAT acl is like this,

access-list 105 deny ip 192.168.10.0 0.0.0.255 192.168.5.0 0.0.0.255

access-list 105 deny ip 10.0.0.0 0.0.0.255 192.168.10.0 0.0.0.255

access-list 105 deny ip 10.0.1.0 0.0.0.255 192.168.10.0 0.0.0.255

access-list 105 deny ip host 10.0.0.22 any

access-list 105 permit ip 10.0.0.0 0.0.0.255 any

access-list 105 deny ip any any

The policy route-map is

route-map vlantraffic permit 20

match ip address mailserver

set interface Dialer1

ip access-list extended mailserver

deny ip 10.0.0.0 0.0.0.255 192.168.10.0 0.0.0.255

permit ip host 10.0.0.22 any

Default gateway:

ip route 0.0.0.0 0.0.0.0 Dialer0

So in summary, it is working fine. But default gateway stopped working for 10.0.0.0/24 after lost power. The Dialer1 traffic is working.The configuration file was saved which I can see the latest updates. The routing was working for at least 2 years like this.

Another test I did to clarify this issue is I removed IP policy from VLAN1. Then 10.0.0.22 did routed to dialer0, but the rest of the machines are still lost at VLAN1. That really confuse me.

I also uploaded another earlier configuration 2 years ago. That configuration works for the Dialer0 traffic but not the Dialer1. Again I took away the Policy routing, the 10.0.0.22 still got lost.

So I dont know what has happened. I also upgrade the IOS.  I dont know if there would be hardware issue because of the sudden black out.

Somebody please help.

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: 1811 dual ISP routing issue, please help

Do you think that there is a chance that somebody made a change that caused it to be working, but didn't write the config?  That is most likely the case when something was working until after a power outage...

3 REPLIES
New Member

Re: 1811 dual ISP routing issue, please help

Do you think that there is a chance that somebody made a change that caused it to be working, but didn't write the config?  That is most likely the case when something was working until after a power outage...

New Member

Re: 1811 dual ISP routing issue, please help

No, nobody would touch the router except me.

New Member

Re: 1811 dual ISP routing issue, please help

How about try sending all of the traffic out the interface that isn't working?  If you remove the policy and change the default route it should send all traffic out the link that you only want the mail server to go out correct?  That way you can verify that in fact traffic can and will be routed out that interface, which would eliminate a hardware issue.

Other than doing that I can't really think of much else that can be the problem without seeing more of your config.

Does the DSL connect directly in to the router via a dsl wic, or is there a modem sitting in front of it?  If there's a modem, then maybe something happened on it that reverted the config back when it powered off?

422
Views
0
Helpful
3
Replies
CreatePlease to create content