Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

1811 want and switch port connection

can i put all 8 switch ports in one vlan. after assigning IP, on interface vlan 10 i'll give ip 10.1.1.1 . can i use "ip nat inside" on interface vlan 1 ??

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: 1811 want and switch port connection

Usman,

Your original post made me believe you understood the configuration.

Say, you want ports 1-4 to be in Vlan 20(inside Vlan) and ports 5-8 in Vlan 10 (outside Vlan)

1) Create the Vlans in the switch database

Rack1SW1#vlan database

Rack1SW1(vlan)#vlan 10 name outside

VLAN 10 added:

Name: outside

Rack1SW1(vlan)#vlan 20 name inside

VLAN 20 added:

Name: inside

2) Assign the ports to their respective Vlans:

Rack1SW1(config)#int ran f1/1 - 4

Rack1SW1(config-if-range)#switchport access vlan 20

Rack1SW1(config)#int ran f1/5 - 8

Rack1SW1(config-if-range)#switchport access vlan 10

3) Assign the IP address under the SVIs

Rack1SW1(config)#int vlan 10

Rack1SW1(config-if)#ip add 10.10.10.1 255.255.255.0

Rack1SW1(config-if)#int vlan 20

Rack1SW1(config-if)#ip add 10.20.20.1 255.255.255.0

4) Then configure NAT as you would on a regular router but place the ip nat inside under interface vlan 20 and ip nat outside under interface vlan 10

HTH,

__

Edison.

Please rate helpful posts

7 REPLIES
Hall of Fame Super Bronze

Re: 1811 want and switch port connection

Hi Usman,

Yes, you sure can.

Please see the following link for more configuration info:

http://www.cisco.com/en/US/products/hw/modules/ps2797/products_configuration_example09186a0080810449.shtml

HTH,

__

Edison.

Please rate helpful posts

New Member

Re: 1811 want and switch port connection

Thanks for your reply..

i could not find nat commands that works with built in switch ports. in 1811 / 1812

these are not routed ports.. right ?

usman

Hall of Fame Super Bronze

Re: 1811 want and switch port connection

No, they aren't routed ports.

You need to place the NAT under the SVIs (Switch Virtual Interface).

HTH,

__

Edison.

New Member

Re: 1811 want and switch port connection

thank you so much HTH,

can i get some specific example of that.. as i have to quote the same router some where .. and i have to prove that it will work that way..

thanks a lot

usman

New Member

Re: 1811 want and switch port connection

! 1. define vlan

vlan 10

name intern

!

! 2. put switchports into vlan

!

int fas 2

switchport mode access

switchport access vlan 10

no shutdown

!

! same for fas 3... fas 9

! fas 0 and fas 1 are real ethernet ports

!

! 3. configure ip

int vlan 10

ip address 10.1.1.1 255.255.255.0

no shutdown

ip nat inside

!

Yes, that also works with the default-vlan 1,

where initially all 8 switches ports

are members of.

Hall of Fame Super Bronze

Re: 1811 want and switch port connection

Usman,

Your original post made me believe you understood the configuration.

Say, you want ports 1-4 to be in Vlan 20(inside Vlan) and ports 5-8 in Vlan 10 (outside Vlan)

1) Create the Vlans in the switch database

Rack1SW1#vlan database

Rack1SW1(vlan)#vlan 10 name outside

VLAN 10 added:

Name: outside

Rack1SW1(vlan)#vlan 20 name inside

VLAN 20 added:

Name: inside

2) Assign the ports to their respective Vlans:

Rack1SW1(config)#int ran f1/1 - 4

Rack1SW1(config-if-range)#switchport access vlan 20

Rack1SW1(config)#int ran f1/5 - 8

Rack1SW1(config-if-range)#switchport access vlan 10

3) Assign the IP address under the SVIs

Rack1SW1(config)#int vlan 10

Rack1SW1(config-if)#ip add 10.10.10.1 255.255.255.0

Rack1SW1(config-if)#int vlan 20

Rack1SW1(config-if)#ip add 10.20.20.1 255.255.255.0

4) Then configure NAT as you would on a regular router but place the ip nat inside under interface vlan 20 and ip nat outside under interface vlan 10

HTH,

__

Edison.

Please rate helpful posts

New Member

Re: 1811 want and switch port connection

wow..

thanks a lot.. it worked..

Usman

760
Views
0
Helpful
7
Replies
CreatePlease to create content