Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1841 ADSL with Cellular Backup

Hi Cisco gurus, I need someone to look at my config. Would really appreciate your help.

I put together this config from various sources. The ADSL connects, I get a public IP, when i do a #sh ip int brief - I can ping the internet from the router. The problem is NAT does not seem to work, my computer can't surf the net and there are no entries in #show ip nat translations

When I pull the phone line out the Cellular interface comes up automatically as expected, gets a public IP and starts NAT'ing. I can surf the net no worries (entries seen in NAT table). Bizarre.

My config (important parts):

ip name-server 4.2.2.2

multilink bundle-name authenticated

chat-script internet "" "ATDT*98*3#" TIMEOUT 30 CONNECT

!

!

interface FastEthernet0/0

description $ES_LAN$$FW_INSIDE$

ip address 192.168.0.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface ATM0/0/0

backup interface Cellular0/1/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no atm ilmi-keepalive

dsl bitswap both

pvc 8/35

encapsulation aal5snap

protocol ppp dialer

dialer pool-member 2

!

!

interface Cellular0/1/0

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer idle-timeout 0

dialer string internet

dialer-group 1

async mode interactive

no ppp lcp fast-start

ppp chap hostname dummy

ppp chap password dummy

ppp ipcp dns request

!

interface Dialer2

description $FW_OUTSIDE$

mtu 1492

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

load-interval 30

dialer pool 2

no cdp enable

ppp authentication chap callin

ppp chap hostname *******

ppp chap password ******

!

ip local policy route-map track-primary-if

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer2 track 234

ip route 0.0.0.0 0.0.0.0 Cellular0/1/0 254

!

!

no ip http server

ip nat inside source route-map nat2cell interface Cellular0/1/0 overload

ip nat inside source route-map nat2dsl interface Dialer2 overload

!

ip sla 1

icmp-echo 203.23.236.9 source-interface Dialer2

ip sla schedule 1 life forever start-time now

access-list 1 permit any

access-list 2 permit 192.168.0.0 0.0.0.255

access-list 3 permit any

access-list 101 permit ip 192.168.0.0 0.0.0.255 any

access-list 102 permit icmp any host 203.23.236.9

dialer-list 1 protocol ip list 1

dialer-list 2 protocol ip permit

route-map track-primary-if permit 10

match ip address 102

set interface Dialer2

!

route-map nat2dsl permit 10

match ip address 101

match interface Dialer2

!

route-map nat2cell permit 10

match ip address 101

match interface Cellular0/1/0

!

!

line 0/1/0

exec-timeout 0 0

script dialer internet

modem InOut

no exec

transport input all

speed 384000

Thanks for the help

Chris

237
Views
0
Helpful
0
Replies
CreatePlease login to create content