Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

1841 PTP issues

Hi  everyone,

     Kind of a noob so go slow. I am trying to configure a PTP with 2 1841's ver 12.4 and I can't tell if my config is the issue or the ISP. I am bonding 2 t-1's with serial interfaces. Any help is appreciated.

Router1:

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

!

!

no ip bootp server

no ip domain lookup

ip domain name dm1.com

!

multilink virtual-template 1

!

!

!

username *

!

!

!

!

!

interface Null0

no ip unreachables

!

interface Loopback0

ip address 172.90.0.2 255.255.255.252

!

interface FastEthernet0/0

description Internal Interface

ip address 192.168.20.4 255.255.255.128

speed 100

full-duplex

no cdp enable

!

interface FastEthernet0/1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

shutdown

duplex auto

speed auto

no cdp enable

!

interface Serial0/0/0

description WLYbor PTP1

no ip address

encapsulation ppp

no fair-queue

no cdp enable

ppp multilink

!

interface Serial0/1/0

description WLYbor PTP2

no ip address

encapsulation ppp

no fair-queue

no cdp enable

ppp multilink

!

interface Virtual-Template1

ip unnumbered Loopback0

ppp authentication chap

ppp multilink

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.20.1

ip route 10.0.0.0 255.255.255.0 172.90.0.1

ip route 192.168.20.0 255.255.255.0 FastEthernet0/0

!

!

no ip http server

no ip http secure-server

Router 2:

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

!

!

no ip domain lookup

ip domain name dm1.com

multilink virtual-template 1

!

username *

!

!

!

!

interface Loopback0

ip address 172.90.0.1 255.255.255.252

!

interface FastEthernet0/0

description ColoLAN

ip address 10.0.0.253 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 172.40.0.2 255.255.255.252

speed 100

full-duplex

!

interface Serial0/0/0

description WLYbor PTP1

no ip address

encapsulation ppp

no fair-queue

pulse-time 1

no cdp enable

ppp multilink

!

interface Serial0/1/0

description WLYbor PTP2

no ip address

encapsulation ppp

no fair-queue

pulse-time 1

no cdp enable

ppp multilink

!

interface Virtual-Template1

ip unnumbered Loopback0

ppp authentication chap

ppp multilink

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.0.0.254

ip route 10.0.0.0 255.255.255.0 FastEthernet0/0

ip route 10.0.20.0 255.255.255.0 172.40.0.1

ip route 192.168.20.0 255.255.255.0 172.90.0.2

!

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: 1841 PTP issues

Hi Joe,

I do not quite understand if you are trying to bond these two routers together, or if you want to bond two T1's and the second end of the multilink bundle is the ISP itself.

Nevertheless, your configuration is more relevant to a PPP Multilink access concentrator than to just two routers connected via multiple parallel PPP links. You do not need the Virtual-Template interface nor the multilink virtual-template 1 command. A common PPP Multilink configuration of two serial interfaces commonly looks as follows:

interface Serial0/0/0

encapsulation ppp

ppp multilink group 1

no shutdown

interface Serial0/0/1

encapsulation ppp

ppp multilink group 1

no shutdown

interface Multilink1

encapsulation ppp

ip address negotiated ! or static IP address

! ... remaining configuration

! ... remaining configuration

! ... remaining configuration

Nothing more is needed to make a PPP Multilink work so I suggest removing all additional commands from your configuration you have currently used. The opposite side should be configured in the same way. Until you get the basic multilink running, I suggest avoiding the authentication (if not required by your ISP). Issues with authentication may complicate troubleshooting your current configuration, so let's try to avoid it at the beginning.

In addition, I see that both your routers have a static route pointing out the Fa0/0 interface. Avoid this style of configuring static routes. It is appropriate only for point-to-point interfaces and on Ethernet networks, it may cause issues (don't want to go into details now). Replace these static routes with routes specified by the next-hop IP address instead of egress interface.

Please keep me posted, and be sure to include the configuration of the routers once you change it according to the suggestion above. Thanks!

Best regards,

Peter

2 REPLIES
Cisco Employee

Re: 1841 PTP issues

Hi Joe,

I do not quite understand if you are trying to bond these two routers together, or if you want to bond two T1's and the second end of the multilink bundle is the ISP itself.

Nevertheless, your configuration is more relevant to a PPP Multilink access concentrator than to just two routers connected via multiple parallel PPP links. You do not need the Virtual-Template interface nor the multilink virtual-template 1 command. A common PPP Multilink configuration of two serial interfaces commonly looks as follows:

interface Serial0/0/0

encapsulation ppp

ppp multilink group 1

no shutdown

interface Serial0/0/1

encapsulation ppp

ppp multilink group 1

no shutdown

interface Multilink1

encapsulation ppp

ip address negotiated ! or static IP address

! ... remaining configuration

! ... remaining configuration

! ... remaining configuration

Nothing more is needed to make a PPP Multilink work so I suggest removing all additional commands from your configuration you have currently used. The opposite side should be configured in the same way. Until you get the basic multilink running, I suggest avoiding the authentication (if not required by your ISP). Issues with authentication may complicate troubleshooting your current configuration, so let's try to avoid it at the beginning.

In addition, I see that both your routers have a static route pointing out the Fa0/0 interface. Avoid this style of configuring static routes. It is appropriate only for point-to-point interfaces and on Ethernet networks, it may cause issues (don't want to go into details now). Replace these static routes with routes specified by the next-hop IP address instead of egress interface.

Please keep me posted, and be sure to include the configuration of the routers once you change it according to the suggestion above. Thanks!

Best regards,

Peter

New Member

1841 PTP issues

I made the changes you suggested and it is working. Thanks here are the configs.

Router1:

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

!

!

no ip domain lookup

ip domain name dm1.com

!

username

!

!

!

!

interface Multilink1

ip address 172.90.0.1 255.255.255.252

ppp multilink

ppp multilink group 1

!

interface FastEthernet0/0

description ColoLAN

ip address 10.0.0.253 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 172.40.0.2 255.255.255.252

speed 100

full-duplex

!

interface Serial0/0/0

description WLYbor PTP1

no ip address

encapsulation ppp

no fair-queue

no cdp enable

ppp multilink group 1

!

interface Serial0/1/0

description WLYbor PTP2

no ip address

encapsulation ppp

no fair-queue

no cdp enable

ppp multilink group 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.0.0.254

ip route 10.0.0.0 255.255.255.0 FastEthernet0/0

ip route 10.0.20.0 255.255.255.0 172.40.0.1

ip route 192.168.20.0 255.255.255.0 172.90.0.2

Router 2:

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

!

!

no ip bootp server

no ip domain lookup

ip domain name dm1.com

!

!

!

!

username

!

!

!

!

!

interface Null0

no ip unreachables

!

interface Multilink1

ip address 172.90.0.2 255.255.255.252

no cdp enable

ppp multilink

ppp multilink group 1

!

interface FastEthernet0/0

description Internal Interface

ip address 192.168.20.4 255.255.255.128

speed 100

full-duplex

no cdp enable

!

interface FastEthernet0/1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

shutdown

duplex auto

speed auto

no cdp enable

!

interface Serial0/0/0

description WLYbor PTP1

no ip address

encapsulation ppp

no fair-queue

no cdp enable

ppp multilink group 1

!

interface Serial0/1/0

description WLYbor PTP2

no ip address

encapsulation ppp

no fair-queue

no cdp enable

ppp multilink group 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.20.1

ip route 10.0.0.0 255.255.255.0 172.90.0.1

ip route 192.168.20.0 255.255.255.0 FastEthernet0/0

336
Views
0
Helpful
2
Replies