Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1841 split network

Hello .

I have a network with 48 pc's .

I have 1841 with 2 fast ethernets , 2 phisical atm's and 2 adsl wic cards and i have a dhcp server at 192.168.0.1 and i d like my router takes 192.168.0.254 ip.

I have 2 internet connections from the same isp and i d like to split my network.

I d like the half pc's (odd's) going internet from the first connection and the others from the second .

I dont know if i need to set dialers , i have 2 physical atm's.

I prefer to not set dialers if that is possible.

How can we tell to router for example: pc with 192.168.0.101 ip goes internet from the connection isp1 and pc with 192.168.0.102 goes internet from connection isp2 ?

Can you help me please ?

Can you send me the full config?

Thank you very much.

4 REPLIES

Re: 1841 split network

Hi,

You can use PBR policy based routing to achieve the same. You can divide your PC's into two diff subnets and then use the PBR to achieve the thing you are looking for.

Please refer the below links for some more information.

http://www.cisco.com/warp/public/732/Tech/plicy_wp.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/qos_c/qcpart1/qcpolicy.htm

HTH, Please rate if it does.

-amit singh

New Member

Re: 1841 split network

How do you apply PBR when:

Two subnets of local PCs coming via same interface (Fa0/1)

Two uplinks: 0/0 and 1/0

I have route-maps setup, with no luck

New Member

Re: 1841 split network

COuld youpost your config so we can see how it is setup. Using PBR you should be able to set the next hop for subnet a to the the 0/0 interface and subnet b to the 0/1 interface.

New Member

Re: 1841 split network

This is a configuration from my 1841 where my goal was similiar to yours. I am using 2 of the switch ports to trunk from the 1841 to my switches. I then created layer 3 interfaces on the 1841 for each of the layer 2 VLAN's. Then I Policy Route the traffic using route-maps out of my Fa interfaces. I am also doing NAT in my PBR configuration.

ip nat pool PORT-SB 11.11.12.12 11.11.12.12 prefix-length 28

ip nat pool PORT-NO 10.10.11.11 10.10.11.11 prefix-length 28

ip nat inside source route-map MAP-SB pool PORT-SB overload

ip nat inside source route-map MAP-NO pool PORT-NO overload

INTERFACE VLAN2

ip nat inside

INTERFACE VLAN3

ip nat inside

interface fa0/1

ip nat outside

interface fa0/0

ip nat outside

access-list 108 deny ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255

access-list 108 permit ip 192.168.2.0 0.0.0.255 ANY

access-list 118 deny ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255

access-list 118 permit ip 192.168.1.0 0.0.0.255 ANY

route-map MAP-SB permit 10

match ip address 108

set default interface fa0/1

route-map MAP-NO permit 10

match ip address 118

set default interface fa0/0

102
Views
0
Helpful
4
Replies
CreatePlease to create content