Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cd2
Community Member

1921 and HWIC-4G-LTE-G

I'm having issues with a 1921 and a new 4G card.

Below is the running config, show cellular and debug.  The SP is EE in the UK, the APN is supposed to be everywhere, eesecure is the user and the password is also set (although not shown).  The SP has confirmed the SIM is fine and the profile is correct.  Apart from that they are not willing to help.

Can't see what is wrong here, any ideas? Anything else I can check?

Thanks

Chris

Router#sh cellular 0/0/0 all

Hardware Information

====================

Modem Firmware Version = SWI9200X_03.05.19.04

Modem Firmware built = 2012/09/17 17:57:14

Hardware Version = 10

International Mobile Subscriber Identity (IMSI) = 23404100839842

International Mobile Equipment Identity (IMEI) = 359470040067474

Integrated Circuit Card ID (ICCID) = 8944302751624005845

Mobile Subscriber International Subscriber

IDentity Number (MSISDN) = 07947586729

Profile Information

====================

Profile 1 = INACTIVE*

--------

PDP Type = IPv4

Access Point Name (APN) = everywhere

Authentication = Unknown

Username: eesecure

Password:

* - Default profile

Data Connection Information

===========================

Data Transmitted = 0 bytes, Received = 0 bytes

Profile 1, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 2, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 3, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 4, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 5, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 6, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 7, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 8, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 9, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 10, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 11, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 12, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 13, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 14, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 15, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Profile 16, Packet Session Status = INACTIVE

        Inactivity Reason = Unknown

Network Information

===================

Current Service Status = Normal

Current Service = Packet switched

Current Roaming Status = Home

Network Selection Mode = Automatic

Mobile Country Code (MCC) = 234

Mobile Network Code (MNC) = 30

Packet switch domain(PS) state = Attached

Registration(EMM) state = Registered

Radio Information

=================

Radio power mode = ON

Current RSSI = -75 dBm

LTE Technology Preference = AUTO

LTE Technology Selected = LTE

Modem Security Information

==========================

Card Holder Verification (CHV1) = Disabled

SIM Status = OK

SIM User Operation Required = None

Number of CHV1 Retries remaining = 3

Error Information

=================

This command is not supported on 4G modems.

Modem Crashdump Information

===========================

Modem crashdump logging: off

Router#

Router#sh run

Building configuration...

Current configuration : 1787 bytes

!

! Last configuration change at 10:33:53 UTC Fri Nov 1 2013

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

enable secret 4 eaOP83n/Avy2EAs2tg7JbhLCX5T8h39E3GwBeTDW5sY

!

no aaa new-model

!

ip cef

!

no ipv6 cef

!

multilink bundle-name authenticated

!

chat-script lte "" "AT!CALL" TIMEOUT 60 "OK"

!

controller Cellular 0/0

!

!

interface Loopback0

ip address 192.168.1.1 255.255.255.0

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 10.10.10.10 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Cellular0/0/0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation slip

dialer in-band

dialer idle-timeout 60

dialer string lte

dialer-group 1

async mode interactive

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip nat inside source list 101 interface Cellular0/0/0 overload

ip route 0.0.0.0 0.0.0.0 Cellular0/0/0

!

access-list 101 permit ip 10.10.10.0 0.0.0.255 any

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line 0/0/0

script dialer lte

modem InOut

no exec

transport input all

transport output all

rxspeed 100000000

txspeed 50000000

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

!

end

Router#

Router#ping 8.8.8.8

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Nov  1 10:47:18.059: Ce0/0/0 DDR: place call

*Nov  1 10:47:18.059: Ce0/0/0 DDR: Dialing cause ip (s=192.168.1.1, d=8.8.8.8)

*Nov  1 10:47:18.059: Ce0/0/0 DDR: Attempting to dial lte

*Nov  1 10:47:18.059: CHAT0/0/0: Attempting async line dialer script

*Nov  1 10:47:18.059: CHAT0/0/0: Dialing using Modem script: lte & System script: none

*Nov  1 10:47:18.059: CHAT0/0/0: process started

*Nov  1 10:47:18.059: CHAT0/0/0: Asserting DTR

*Nov  1 10:47:18.059: CHAT0/0/0: Chat script lte started

*Nov  1 1.0:47:18.059: CHAT0/0/0: Sending string: AT!CALL

*Nov  1 10:47:18.059: CHAT0/0/0: Expecting string: OK....

Success rate is 0 percent (0/5)

Router#

*Nov  1 10:48:18.059: CHAT0/0/0: Timeout expecting: OK

*Nov  1 10:48:18.059: CHAT0/0/0: Chat script lte finished, status = Connection timed out; remote host not responding

*Nov  1 10:48:18.059: Ce0/0/0 DDR: disconnecting call

*Nov  1 10:48:33.059: Ce0/0/0 DDR: re-enable timeout

Router#

Router#

Router#

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
cd2
Community Member

1921 and HWIC-4G-LTE-G

It's a bug

CSCug43453

basically you need to reset the modem after a reboot.

so I entered

test cellular 0 modem-power-cycle

After this the unit will connect until the unit is rebooted/powercycled.

9 REPLIES
Hall of Fame Super Gold

1921 and HWIC-4G-LTE-G

This line of your output caught my attention

*Nov  1 10:47:18.059: Ce0/0/0 DDR: Dialing cause ip (s=192.168.1.1, d=8.8.8.8)

I am not clear where the source address of 192.168.1.1 came from. Is that the address learned by the cellular? If not what is it?

HTH

Rick

cd2
Community Member

1921 and HWIC-4G-LTE-G

It's the IP of loopback 0.

I'm not expecting that to ping (it's a RFC 1918 address) but the cellular interface should come up.

At this point the cellular interface has not learned an IP.

See

Router#sh ip int br | inc Cell

Cellular0/0/0              unassigned      YES NVRAM  up                    up

Cellular0/0/1              unassigned      YES unset  down                  down

Cellular0/0/2              unassigned      YES unset  down                  down

Cellular0/0/3              unassigned      YES unset  down                  down

Router#sh int cell 0/0/0

Cellular0/0/0 is up (spoofing), line protocol is up (spoofing)

  Hardware is 4G WWAN EHWIC - Global Multimode LTE/DC-HSPA+/HSPA+/HSPA/UMTS/EDGE/GPRS

  Internet address will be assigned dynamically by the network

  MTU 1500 bytes, BW 9 Kbit/sec, DLY 100000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation SLIP, loopback not set

  Keepalive not supported

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/10 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

     DCD=down  DSR=down  DTR=up  RTS=up  CTS=up

Router#

cd2
Community Member

1921 and HWIC-4G-LTE-G

I've also tried a 3G card on another provider (O2) changed the profile details accordingly and got pretty much teh same result.  I have got a little more debug...

Router#debug cellular 0/0/0 messages data

DATA debugging is on

Router#debug cellular 0/0/0 messages call

Router#debug cellular 0/0/0 messages callcontrol

CALLCONTROL debugging is on

Router#debug cellular 0/0/0 messages async

ASYNC debugging is on

Router#debug chat]

                 ^

% Invalid input detected at '^' marker.

Router#debug chat

Chat scripts activity debugging is on

Router#ping 8.8.8.8

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Nov  1 13:59:23.855: CHAT0/0/0: Attempting async line dialer script

*Nov  1 13:59:23.855: CHAT0/0/0: Dialing using Modem script: lte & System script: none

*Nov  1 13:59:23.855: CHAT0/0/0: process started

*Nov  1 13:59:23.855: CHAT0/0/0: Asserting DTR

*Nov  1 13:59:23.855: CHAT0/0/0: Chat script lte started

*Nov  1 13:59:23.855: CHAT0/0/0: Sending string: AT!CALL

*Nov  1 13:59:23.855: CHAT0/0/0: Expecting string: OK..

*Nov  1 13:59:26.575: new DSR value received, 1

*Nov  1 13:59:26.575: old value: handshakes->DSR= 1

*Nov  1 13:59:26.579: new DCD value received, 1

*Nov  1 13:59:26.579: old value: handshakes->DCD= 1

*Nov  1 13:59:26.639: new DSR value received, 1

*Nov  1 13:59:26.643: old value: handshakes->DSR= 1

*Nov  1 13:59:26.643: new DCD value received, 1

*Nov  1 13:59:26.643: old value: handshakes->DCD= 1

*Nov  1 13:59:26.675: Cellular0/0/0 DirectIP: Primary DNS address 88.82.13.12 added...

Success rate is 0 percent (0/5)

Router#sh cell 0/0/0 prof

Profile 1 = ACTIVE*

--------

PDP Type = IPv4

PDP address = 10.121.253.230

Access Point Name (APN) = btmobile.bt.com

Authentication = Unknown

Username: bt

Password:

        Primary DNS address = 88.82.13.12

        Secondary DNS address = 88.82.13.12

* - Default profile

Router#sh ip int br | inc Cell

Cellular0/0/0              unassigned      YES NVRAM  up                    up

Cellular0/0/1              unassigned      YES unset  down                  down

Cellular0/0/2              unassigned      YES unset  down                  down

Cellular0/0/3              unassigned      YES unset  down                  down

Router#sh int cell 0/0/0

Cellular0/0/0 is up (spoofing), line protocol is up (spoofing)

  Hardware is 4G WWAN EHWIC - Global Multimode LTE/DC-HSPA+/HSPA+/HSPA/UMTS/EDGE/GPRS

  Internet address will be assigned dynamically by the network

  MTU 1500 bytes, BW 50000 Kbit/sec, DLY 100000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation SLIP, loopback not set

  Keepalive not supported

  Last input 00:00:48, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/10 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     10 packets input, 280 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Router#

*Nov  1 14:00:23.855: CHAT0/0/0: Timeout expecting: OK

*Nov  1 14:00:23.855: CHAT0/0/0: Chat script lte finished, status = Connection timed out; remote host not responding

*Nov  1 14:00:25.547: !!! CARDROP!!!!

*Nov  1 14:00:25.547: new DSR value received, 1

*Nov  1 14:00:25.547: old value: handshakes->DSR= 1

*Nov  1 14:00:25.547: new DCD value received, 0

*Nov  1 14:00:25.547: old value: handshakes->DCD= 0

*Nov  1 14:00:25.547: Cellular0/0/0 DirectIP: Remove negotiated IP interface address

*Nov  1 14:00:25.547: Cellular0/0/0 DirectIP: Primary DNS address 88.82.13.12 removed

Router#

So something is being triggered it is just the script does not get a response so the interface does not come out of spoofing.

Is teher any way to decode what the cellular debugs actually mean or how they should look?

Hall of Fame Super Gold

1921 and HWIC-4G-LTE-G

Thanks for the additional information. If the source address of your ping will be 192.168.1.1 then I suggest that you modify your configuration of address translation and add a permit for 192.168.1.0. It has been my experience with 4G that providers reject traffic with that kind of source address and expect the source address to be in their address range.

Change your address translation, try the ping again, and let us know if the behavior changes.

HTH

Rick

cd2
Community Member

1921 and HWIC-4G-LTE-G

I did try but it makes no difference.  The Cellular interface does not, at this point, have an IP address so NAT is not performed (there is no IP to NAT to).

The failure is at Layer 2 in that the modem command does not get a response to activate the interface even though the profile is active (hence layer 1 is complete). The Provider never sees the IP packet as it is never sent.

This maybe one for TAC.

Regards

Chris Davis

cd2
Community Member

1921 and HWIC-4G-LTE-G

It's a bug

CSCug43453

basically you need to reset the modem after a reboot.

so I entered

test cellular 0 modem-power-cycle

After this the unit will connect until the unit is rebooted/powercycled.

Hall of Fame Super Gold

1921 and HWIC-4G-LTE-G

Thank you for the update and the explanation of the problem. That is very helpful information. Perhaps at this point you might mark the question as answered so that other readers would know that a solution has been found?

HTH

Rick

cd2
Community Member

1921 and HWIC-4G-LTE-G

You can't mark your own replies as answers I'm afraid.

Hall of Fame Super Gold

1921 and HWIC-4G-LTE-G

I guess that is right. In that case I will Endorse your response and it will be flagged in a somewhat similar way (not quite the same impact as you saying it is solved but at least it may get it a bit more attention as people read the forum).

HTH

Rick

6576
Views
0
Helpful
9
Replies
CreatePlease to create content