Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

2 interface's multilink

Dear all,

I am first time using the multilink interface for connecting the two remote sites(2 2611 routers)

this configuration doesn't work ???

I would like to ask the experts why this configuration dosen't work...

i cant make the 2 multilink up --> just 1 is work

R1

interface Multilink1

ip address 172.31.1.2 255.255.255.0

load-interval 30

ppp multilink

no ppp multilink fragmentation

multilink-group 1

!

interface Multilink2

ip address 172.31.2.2 255.255.255.0

load-interval 30

ppp multilink

no ppp multilink fragmentation

multilink-group 2

!

interface Serial0/0:0

no ip address

encapsulation ppp

ppp multilink

multilink-group 1

!

interface Serial0/1:0

no ip address

encapsulation ppp

ppp multilink

multilink-group 2

R1#sh ip int brie

Interface IP-Address OK? Method Status Protocol

Ethernet0/0 unassigned YES NVRAM up up

Serial0/0:0 unassigned YES manual up up

Ethernet0/1 10.10.10.1 YES NVRAM up up

Serial0/1:0 unassigned YES manual up down

Multilink1 172.31.1.2 YES manual up up

Multilink2 172.31.2.2 YES manual down down

_________________________________________________________________________________________

R2

interface Multilink1

ip address 172.31.1.1 255.255.255.0

no cdp enable

ppp multilink

ppp multilink group 1

!

interface Multilink2

ip address 172.31.2.1 255.255.255.0

load-interval 30

no cdp enable

ppp multilink

ppp multilink group 2

!

interface Serial0/0:0

bandwidth 2000

no ip address

encapsulation ppp

load-interval 30

delay 2000

fair-queue

ppp multilink

ppp multilink group 1

!

interface Serial0/1:0

bandwidth 2000

no ip address

encapsulation ppp

load-interval 30

delay 2000

fair-queue

ppp multilink

ppp multilink group 2

R2#sh ip int brie

Interface IP-Address OK? Method Status Protocol

Ethernet0/0 10.2.8.252 YES NVRAM up up

Serial0/0:0 unassigned YES manual up up

Ethernet0/1 unassigned YES NVRAM up up

Serial0/1:0 unassigned YES manual up down

Multilink1 172.31.1.1 YES NVRAM up up

Virtual-Access1 unassigned YES TFTP down down

Multilink2 172.31.2.1 YES NVRAM down down

14 REPLIES
Hall of Fame Super Gold

Re: 2 interface's multilink

Rafi

I do not understand why you are trying to do multilink with just a single serial in each multilink group.

But that is not what you asked, and I will try to give some help about your problem. I see that both routers show serial0/0 as up/up and therefore multilink1 is up. I see that both routers show serial0/1 as up/down. Since the serial in that multilink is down the interface multilink2 is down.

So the question becomes why is serial0/1 up/down. The status of up/down usually is an indication that the interface sees physical connectivity but is not able to send or receive keepalive messages. Can you tell us some things about the connection on serial0/1? What kind of connection is it? Can you verify the connection?

HTH

Rick

New Member

Re: 2 interface's multilink

i try this because the customer ask me for this :)

i got 2 e1 card wic 1-mft and i want to try to bring up 2 multilink thats all .

thanks

Re: 2 interface's multilink

Hi

In addition to Ricks post i would suggest to get the physical link checked which is getting connected n serial 0/1.

before that do try ur luck with a shut no shut command on the physical interface (serial 0/1).

while getting it looped and checking for the errors or reliability u shuld be careful with the status of the serial interface..

normal HDLC coded interfaces shows up up(looped) but the serial interface which is in the multilink bundle would show u up down down(looped).

with that you wont be able to ping ur interface ip and check for drops..

so while doign the check out there change it to HDLC and try checking it for errors or losses and revert back the settings after that..

regds

New Member

Re: 2 interface's multilink

hi

i change the encapsulation under serial 0/1:0 to hdlc , and the interface become up up --> but multilink 2 still down down

when i change it back to ppp encap its still the same in the serial 0/1:0 up down and the multilink 2 down down .

regards

Re: 2 interface's multilink

Hi

I did suggest to change the encapsulation for troubleshooting purpose thats when u get the link looped from remote site and to check the same for errors & drops.

Also once u revert back to the ppp u need to key in the multilink group command as well as ppp multilink uner the serial interface without which it wont bring ur multilink interface up .

In nomral condition if u want the serial to be there under a multilink bundle u must use encapsulation as ppp only..

wihtout which its not possible to bundle them up under a single mulilink interface..

regds

New Member

Re: 2 interface's multilink

so what can i do now ????

i cant bring up the 2 multi .

the physical is ok , the configuratoin is ok , and the

interfaces multilink still in the same condition :(

the first question was if i can do it ? i mean if this

2 multilink is possible on this routers , maybe the 2611 cant do 2 multi at the same time ? maybe i need to chane platform ?? i dont know

Silver

Re: 2 interface's multilink

Can you paste sh ppp multilink interface multilink 2 on both sides and if possible also debug ppp multilink events from both sides ?

New Member

Re: 2 interface's multilink

debug ppp multilink

Dec 1 17:10:41.471: %LINK-3-UPDOWN: Interface Multilink2, changed state to down

Dec 1 17:10:41.471: Se3/2:0 MLP: Request add link to bundle

Dec 1 17:10:41.471: Se3/2:0 MLP: Adding link to bundle

Dec 1 17:10:41.471: Se3/2:0 MLP: Bundle R1 in different multilink group

Dec 1 17:10:41.471: Se3/2:0 MLP: Link not added to bundle

Dec 1 17:10:42.467: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2:0, changed state to down^Z

Dec 1 17:27:21.847: %LINK-3-UPDOWN: Interface Multilink2, changed state to down

Dec 1 17:27:21.847: Se3/2:0 MLP: Request add link to bundle

Dec 1 17:27:21.847: Se3/6:0 MLP: Request add link to bundle

Dec 1 17:27:21.847: Se3/2:0 MLP: Adding link to bundle

Dec 1 17:27:21.847: Se3/2:0 MLP: Bundle R1 in different multilink group

Dec 1 17:27:21.847: Se3/2:0 MLP: Link not added to bundle

Dec 1 17:27:21.851: Se3/6:0 MLP: Adding link to bundle

Dec 1 17:27:21.851: Se3/6:0 MLP: Bundle R1 in different multilink group

Dec 1 17:27:21.851: Se3/6:0 MLP: Link not added to bundle

Dec 1 17:27:22.843: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2:0, changed state to down

Dec 1 17:27:22.843: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/6:0, changed state to down

Dec 1 17:27:29.903: Se3/2:0 MLP: Request add link to bundle

Dec 1 17:27:29.907: Se3/2:0 MLP: Can't add link to bundle, interface renegotiated without MP

Dec 1 17:27:31.919: Se3/2:0 MLP: Request add link to bundle

Dec 1 17:27:31.923: Se3/2:0 MLP: Can't add link to bundle, interface renegotiated without MP

Dec 1 17:27:33.935: Se3/2:0 MLP: Request add link to bundle

Dec 1 17:27:33.939: Se3/2:0 MLP: Can't add link to bundle, interface renegotiated without MP

Dec 1 17:27:35.951: Se3/2:0 MLP: Request add link to bundle

Dec 1 17:27:35.955: Se3/2:0 MLP: Can't add

Hall of Fame Super Gold

Re: 2 interface's multilink

I am a bit confused here. The original post included parts of the config that were for serial0/0 and serial0/1, but these debugs are for a router with serial3/2 and 3/6. Are we dealing with a different router here?

I have seen a similar set of symptoms before and the difficulty was an inconsistency in the router configs. Please post current complete configs of both routers.

HTH

Rick

New Member

Re: 2 interface's multilink

no this other 2 routers in lab , but this is the same debug from the production.

New Member

Re: 2 interface's multilink

Hello all,

FYI..we just had the same issue with an up-down. Turns out bell had some issue at their CO and replaced a card. (canned answer) none the less when we brought up the multilink I saw the same up-down. Once both Bell and I bounce our multilinks the circuit came back up and joined the bundle.

New Member

Re: 2 interface's multilink

hello every one.

I face the same problem few day ago....

I work in network solution company and I had the same problem.

just write inside the Interface Multilink2 this command:

ppp multilink endpoint ip THE IP ADDRESS TO THE OTHER MULTILINK IN THE OTHER SITE

and the same goes for the other site.

and the state will be up up.

New Member

2 interface's multilink

Hi, I have a same problem.

I have 1 cisco 2811 with IOS c2800nm-spservicesk9-mz.124-3g.bin.

This router have two Multilink interfaces, all interfaces serials are UP and the Multilink, one is UP UP and other is down down.

The remote routers are Two Cisco 7609 in diferent Location.

So, one multilink with two serials connect with Cisco 7609 A OK, the other multilink with two serials (OK) connect with cisco 7609 B DOWN DOWN.

Sorry for my poor english.

If somebody can help me....

Hall of Fame Super Gold

2 interface's multilink

We do not have enough information here to be able to figure out what is the problem. A starting point would be for you to provide the output of show interface for the physical interfaces and the multi link interfaces and also to post the configuration of the physical interfaces and multilink interfaces.From that perhaps we can understand the problem.

HTH

Rick

2326
Views
0
Helpful
14
Replies
CreatePlease to create content