Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2 Internet Line on the same Router

I have configured 2 Dialer interfaces on the router as i have 2 internet lines from the same ISP that i want to connect them both to the same router. The problem happens when i enable dialers at the same time the internet traffic becomes unstable up and down.

5 REPLIES
Hall of Fame Super Silver

Re: 2 Internet Line on the same Router

Hello Karam,

I would suggest you to post your configuration just hide public ip addresses and userame and passwords.

In this way you can get better help.

It is possible to use this setup but the NAT part can be rather complex and probably only a primary/backup scheme can be achieved.

Hope to help

Giuseppe

New Member

Re: 2 Internet Line on the same Router

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$

no ip address

ip nat inside

ip virtual-reassembly

ip policy route-map GCSSMAP

duplex auto

speed auto

h323-gateway voip interface

service-policy input block-p2p

!

interface FastEthernet0/0.1

description ***Data***

encapsulation dot1Q 1 native

ip address 10.10.20.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/0.3

description ***Voice***

encapsulation dot1Q 3

ip address 10.10.21.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

!

interface FastEthernet0/1

description **WIMAX-GCSSB1**

no ip address

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

no cdp enable

!

!

interface FastEthernet0/2/0

description **WIMAX-GCSSB2**

no ip address

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 2

no cdp enable

!

interface Serial0/3/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

clock rate 2000000

!

interface Serial0/3/1

bandwidth 512

ip address 10.10.250.14 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

ip flow ingress

clock rate 2000000

service-policy output voip-qos

!

interface Vlan1

no ip address

!

interface Dialer0

no ip address

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname gcssb1

ppp chap password 7 14001F52010D7A3F23

ppp pap sent-username gcssb1 password 7 02110902060F5F354B

!

interface Dialer2

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 2

dialer-group 2

ppp authentication chap pap callin

ppp chap hostname gcssb2

ppp chap password 7 0451060E1875425E07

ppp pap sent-username gcssb2 password 7 1213081F055F021424

!

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

!

!

ip nat inside source route-map b1 interface Dialer1 overload

ip nat inside source route-map b2 interface Dialer2 overload

!

!

access-list 1 permit 10.10.20.0 0.0.0.127

access-list 2 permit 10.10.20.128 0.0.0.127

route-map b2 permit 30

match ip address 2

match interface Dialer2

!

route-map b1 permit 20

match ip address 1

match interface Dialer1

Hall of Fame Super Silver

Re: 2 Internet Line on the same Router

Hello Kamar,

to have a primary/secondary setup use

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2 100

this should provide stability in internet access but also for this ACLs matching the whole client vlan need to be used in NAT config

access-list 3 permit 10.10.20.0 0.0.0.255

Hope to help

Giuseppe

New Member

Re: 2 Internet Line on the same Router

if i do as above i will have only one of the links active and the other one will be standby, and what i want to achieve is to have both links active at the same time and this is where the i have the problem any suggestion?

Re: 2 Internet Line on the same Router

Karam,

Please explain a bit more about how unstable they were.

Active/Active is what the router can do with per-destination load-balancing. It's hard to say when you are connecting Website-A having multiple public ip addresses. That may be a problem if you are connecting it with multiple sources(NATed at 2 links).

I would not be concerned about DNS because you said that they are the same ISP.

HTH,

Toshi

243
Views
0
Helpful
5
Replies
CreatePlease login to create content