Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

2 routes to router - eigrp

Hi forum,

I am connecting 2 physical links to my router via 2 switches, the router is connected to all remote sites via EIGRP, How do I made the EIGRP to always choose the route with the riverbed steelhead optimizer, and only failover to the other link when the link to the Steelhead failed.

I put this on the switch port connected to router:

bandwidth 64000

delay 20

but the EIGRP still make use of the 2 routes, and I have asymmetric routes on the riverbed all the times..

The network layout is as attached.

Thank you very much,

pN

5 REPLIES

Re: 2 routes to router - eigrp

Hi,

You can use the offset-list to increase the metric of the routes received from the other link in order to force it to act as backup.

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c2d96.shtml

HTH, please rate if it does help,

Mohammed Mahmoud.

Re: 2 routes to router - eigrp

EIGRP considers the parameters of the outgoing interface while calculating the metric and hence you need to manipulate the metrics on both sides of eigrp for proper operation

Can you post the configs of the 2811 and the L3 switches

Narayan

New Member

Re: 2 routes to router - eigrp

Hi Narayan,

the configuration of the core switch connected to the router is as append, the router has 2 ethernet ports, e0/1 is the one connected to the core switch, on the core switch side, i didnt do anything except setting one port to another vlan.

Thank you very much for your help, if you require further info, pls let me know.

pN

Router config:

!

!!

interface FastEthernet0/1

ip address 172.16.165.5 255.255.255.0

ip nbar protocol-discovery

duplex auto

speed auto

!

!

interface Serial0/2/0

bandwidth 1984

ip address 172.16.212.1 255.255.255.0

ip nbar protocol-discovery

ip flow ingress

max-reserved-bandwidth 100

service-policy output wan-qos

encapsulation ppp

ip route-cache flow

ip tcp header-compression iphc-format

compress stac caim 0

invert txclock

ip rtp header-compression iphc-format

!

!

router eigrp 100

network 172.16.0.0

network 192.168.5.0

network 192.168.62.0

network 192.168.121.0

network 192.168.123.0

network 192.168.254.0

default-metric 1000 100 255 1 1500

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.160.4

ip route 10.255.250.0 255.255.255.0 172.16.206.1

ip route 192.168.5.40 255.255.255.252 192.168.5.34

ip route 192.168.62.0 255.255.255.0 172.16.160.4

!

ip flow-export source FastEthernet0/0

ip flow-export version 5

ip flow-export destination 172.16.160.92 9996

ip flow-export destination 172.16.150.24 9996

=============================================

Core switch:

!

!

interface Tunnel0

bandwidth 1000000

ip address 192.168.5.9 255.255.255.252

tunnel source 192.168.123.1

tunnel destination 192.168.62.1

!

interface Port-channel10

description Connection to Switch3560-Passive Switch - Rack 2

switchport trunk encapsulation dot1q

switchport mode trunk

no snmp trap link-status

!

!

interface GigabitEthernet0/6

description link to bypass Riverbed Steelhead - to delete after test with KMS

switchport access vlan 6

bandwidth 64000

delay 20

shutdown

!

interface GigabitEthernet0/7

spanning-tree portfast

!

interface Vlan1

ip address 172.16.160.21 255.255.255.0

ip helper-address 172.16.160.29

no ip redirects

load-interval 30

standby 1 ip 172.16.160.3

standby 1 priority 250

standby 1 preempt

!

!

router eigrp 100

network 172.16.0.0

network 192.168.5.0

network 192.168.62.0

network 192.168.121.0

network 192.168.122.0

network 192.168.123.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.160.4

ip route 10.255.250.0 255.255.255.0 172.16.206.1

ip route 172.16.170.42 255.255.255.255 192.168.5.10

ip route 192.168.62.0 255.255.255.240 172.16.160.4

no ip http server

ip http secure-server

!

!

New Member

Re: 2 routes to router - eigrp

Actually, you go into the secondary eigrp process and give it a higher distance.

Example

#

router eigrp 250

distance eigrp 100 180

exit

#

Defaults

internal-distance: 90

external-distance: 170

Therefore your primary eigrp process will continue to route and if the wan interface advertised in this process were to fail, it would route within the second eigrp process.

For example, you could have a gre tunnel configured for backup and advertise the routes in the secondary process.

In regards to your Tunnel, you can configure the second eigrp process as follows:

interface Tunnel0

bandwidth 1000000**** use 1402

ip mtu 1514 **** for overhead

ip address 192.168.5.9 255.255.255.252

tunnel source 192.168.123.1

tunnel destination 192.168.62.1

eigrp 250

passive-inteface default

no passive-interface tunnel0

network 192.168.5.8 0.0.0.3

distance eigrp 100 180

no auto

exit

also note:

you will have to redistribute the primary eigrp process into the secondary and tag it with a routemap, and then the other side of the wan you would do the same as well.

This is out scope for now, but please do a search for "Preventing Suboptimal Routes by Using Route Tags."

Cheers!

New Member

Re: 2 routes to router - eigrp

The riverbed will pass through the traffic at layer 1 (by electrically closing the switch between the two cables, in, out)

so a dead riverbed still works...

try it!

412
Views
15
Helpful
5
Replies
CreatePlease to create content