Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2 spantree root switches

We have 4 separate sites, each site has an edge switch with VLAN 1 connected round the sites via 100mbps connections forming a loop (or square in this case), the last site was only connected a few weeks ago. The other day I had problem connecting to this site's edge switch via telnet, when I did get on I noticed errors showing mac addresses flapping between the VLAN1 'management' ports. I disabled one of the ports and the situation stablilised. Now I have investigated, it appears that three of the sites agree that the spantree root bridge is on the site that was last added, but one of the sites has elected it's own root at that site. The only anomoly I can see at this site is that the spantree ports have portfast enabled, which I am planning to remove, but I'm not convinced that this explains why one site is not taking part in the election. If anyone manages to follow this I would be grateful for any ideas in case I am missing something.

Cheers,Kevin.

5 REPLIES
New Member

Re: 2 spantree root switches

Follow up :

I suspect the dual root switches may be due to a diameter problem, where I have chopped one the redundant links, the 2 roots are 7 hops away from each other. Still, any other ideas please let me know. Regards, Kevin.

Re: 2 spantree root switches

Hi,

just saw your followup. My impression from your first post was, that we talk about 4 switches only, which seems not to be true.

For RSTP a maximum diameter of 3 hops is suggested for normal SPT a maximum diameter of 7 hops. You could configure the network diameter on the root switch, which would adjust SPT timers in all your switches to your topology.

Given the new information I would recommend using routed links between the sites, if your network does allow it.

Regards, Martin

Re: 2 spantree root switches

Hi,

I definately would remove the portfast from trunk ports or ports interconnecting switches.

Also I would recommend to set the bridge priority on the switch supposed to be root - otherwise a MAC address (lowest one) decides which switch will be root.

Make sure al switches use the same SPT protocol (PVST, rapid-pvst, etc.)

Also make sure the BPDUs reach the neighboring switches through your WAN ethernet connection.

Suggested config on root bridge:

spanning-tree mode rapid-pvst

spanning-tree vlan 1,22,24,25,27 root primary

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-1000

switchport mode trunk

switchport nonegotiate

speed 100

duplex full

spanning-tree link-type point-to-point

interface GigabitEthernet0/2

switchport access vlan 21

switchport mode access

speed 100

duplex full

Adjust interface naming, speed and duplex settings to your environment. In addition you could enable UDLD (unidirectional link detection) on switch-switch links and Loop guard to avoid SPT issues.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: 2 spantree root switches

Martin,

Thanks for that,very helpful.

There other switches at each site beyond the 4 edge switches, hence the diameter has reached 8 at the extreme. I have a switch of priority 30000 at on end, and discovered a switch of priority 8192 near the other end.

I have been researching hard and had just decided that udld would be on my list of trouble-shooting tools. As you say, I think disabling portfast and locating the root switch more centrally using prioority are the first steps.

Thanks again and for the config,I will probably post back in a few days with more news!

Re: 2 spantree root switches

Hi,

I have no experience wit RSPT in such a large switching cloud. The more safe approach would be to use "normal" SPT. The config would then be

spanning-tree mode pvst

Again, routed links between the sites would make a lot of sense to me, to avoid SPT issues across WAN and separate failure domains.

Also have a look at the following documents:

"Understanding and Tuning Spanning Tree Protocol Timers"

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a0080094954.shtml

Spanning Tree Protocol Problems and Related Design Considerations

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a00800951ac.shtml

Regards, Martin

315
Views
4
Helpful
5
Replies
CreatePlease login to create content