Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2501 Version 11.1(24) RIP redistribution Question

hello, my name is yunchouljung in korea

i have a question about RIP Redistribution in IOS Version 11.1(24)

2501 router

ip subnet-zero

no ip domain-lookup

!

interface Ethernet0

ip address 10.240.252.45 255.255.255.252

ip access-group 119 in

ip access-group 119 out

no ip redirects

no ip proxy-arp

ip route-cache same-interface

bandwidth 10000

!

router rip

version 2

timers basic 10 10 10 10

redistribute static metric 10

passive-interface Serial1

network 10.0.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.242.0.5

ip route 10.0.0.0 255.0.0.0 10.242.0.5

ip route 10.242.3.0 255.255.255.0 10.240.252.46

ip route 156.147.0.0 255.255.0.0 10.242.0.5

ip route 165.186.0.0 255.255.0.0 10.242.0.5

ip route 165.243.0.0 255.255.0.0 10.242.0.5

ip route 165.244.0.0 255.255.0.0 10.242.0.5

ip route 192.168.73.0 255.255.255.0 10.242.0.5

BuPyung#sh ip route

Gateway of last resort is 10.242.0.5 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks

S 10.0.0.0/8 [1/0] via 10.242.0.5 <===== "10.0.0.0/8" routing

C 10.240.252.44/30 is directly connected, Ethernet0

S 10.242.3.0/24 [1/0] via 10.240.252.46

C 10.242.0.4/30 is directly connected, Serial1

S 156.147.0.0/16 [1/0] via 10.242.0.5

S 165.186.0.0/16 [1/0] via 10.242.0.5

S 192.168.73.0/24 [1/0] via 10.242.0.5

S 165.244.0.0/16 [1/0] via 10.242.0.5

S 165.243.0.0/16 [1/0] via 10.242.0.5

S* 0.0.0.0/0 [1/0] via 10.242.0.5

3560 L3 SW

interface FastEthernet0/23

description ### to_Router ###

no switchport

ip address 10.240.252.46 255.255.255.252

no ip redirects

no ip proxy-arp

!

router rip

version 2

timers basic 30 30 30 30

passive-interface FastEthernet0/22

passive-interface FastEthernet0/23

passive-interface FastEthernet0/24

network 10.0.0.0

no auto-summary

!

ip classless

ip route 10.254.12.96 255.255.255.255 10.240.252.173

ip route 10.255.10.31 255.255.255.255 10.240.252.173 name RPMS_Services

BuPyung_L3#sh ip route

Gateway of last resort is 10.240.252.173 to network 0.0.0.0

R 192.168.73.0/24 [120/10] via 10.240.252.45, 00:00:04, FastEthernet0/23

R 156.147.0.0/16 [120/10] via 10.240.252.45, 00:00:04, FastEthernet0/23

10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks

C 10.240.252.44/30 is directly connected, FastEthernet0/23

S 10.254.12.96/32 [1/0] via 10.240.252.173

C 10.240.252.172/30 is directly connected, FastEthernet0/24

S 10.255.10.31/32 [1/0] via 10.240.252.173

C 10.242.3.0/24 is directly connected, Vlan3

R 10.242.0.4/30 [120/1] via 10.240.252.45, 00:00:04, FastEthernet0/23

R 10.254.10.0/24 [120/1] via 10.240.252.173, 00:00:10, FastEthernet0/24

R 165.244.0.0/16 [120/10] via 10.240.252.45, 00:00:04, FastEthernet0/23

R 165.243.0.0/16 [120/10] via 10.240.252.45, 00:00:04, FastEthernet0/23

R 165.186.0.0/16 [120/10] via 10.240.252.45, 00:00:04, FastEthernet0/23

R* 0.0.0.0/0 [120/1] via 10.240.252.173, 00:00:10, FastEthernet0/24

BuPyung_L3#

routing table in 3560 L3 SW is not show static rip entry from 2501 Router

S 10.0.0.0/8 [1/0] via 10.242.0.5

why 10.0.0.0/8 network is not see?

1 REPLY
New Member

Re: 2501 Version 11.1(24) RIP redistribution Question

The basic timing parameters for RIP are adjustable. Because RIP is executing a distributed, asynchronous routing algorithm, these timers must be the same for all routers and access servers in the network.

Are you even peering at all with the 2501? I don't think you are learning any routes at all from it?

Chris

268
Views
0
Helpful
1
Replies
CreatePlease login to create content